Previous 1 3 4 5 6 7 Next 1,018 Replies Latest reply: Nov 28, 2015 6:22 PM by augratin Go to original post Branched to a new discussion.
  • chronicon helveticum Level 1 (0 points)

    Hi Merid, well this adds a new perspective to things. You seem to be describing the intra-app problem described by babsonnexus. Are you also seeing the inter-app refresh problem? Perhaps we were blaming 512MB iThings simply because they are still in the majority. Knowing Apple, I wouldn't expect a response to this thread or any acknowledgment of the problem.


    The Apple Store did fill in a support issue on my behalf when I visited them this week (see an earlier post) but the more of us that do so the better.


    I've lost track a bit now. Is there anyone out there with a 1GB RAM iPhone or iPad who is *not* seeing this problem? I.e. is it universal but just too obscure to be easily described and/or searched for?


    As a long time Apple fan, my faith was shaken my the numerous iOS 6 problems. It has been further dented by iOS 7 niggles and glitches. Apple products used to just work.

  • sjmawer Level 1 (0 points)

    Hi everyone,

    original OP here.

    So, this started out with me using an iPhone 4s... I've recently upgraded to the 5c, and.... drumroll.....


    no fix


    I actually quite like the feature when it applies to Facebook, but when reading a book or webrowsing, it's a complete PITA.


    Doesn't look like Apple is acknowledging this as a problem... but it effectively means their mulitasking system is useless.

  • chronicon helveticum Level 1 (0 points)

    That's kind of disappointing but also somewhat encouraging in that Apple are more likely to fix a universal problem.

  • chronicon helveticum Level 1 (0 points)

    I think we were all hoping that 7.0.4 would solve the problem. It doesn't.

  • spacom Level 1 (0 points)

    Looks the problem is fixed for me for Ipad2 when updated to Ios7.0.4.

    Tested with abt 7 apps (Safari, FB and some of games) running and switching between them.

    Only Safar refresh some time but the original page reloads as it is.


    Will check more later.

  • spacom Level 1 (0 points)

    After the 7.0.4 update all looked fine for short time.

    But for sure, it didn't fix the problem and apps keep refreshing/resetting.

  • puskarich Level 1 (0 points)

    Upgraded my device from the 4s to the 5s. Both were iOS 7.04. Both have the issue, but does not seem as bad on the 5s. Time will tell.

  • babsonnexus Level 1 (0 points)

    7.0.4 has made then issue slightly less prevalent, but it is still there. Interesting that even upgrading to a new device that this was designed for seems to still have the same issue. Thanks for the info, makes it easier to say "No" to an upgrade of hardware.

  • JCCova Level 1 (0 points)

    I am so glad I found this discussion board. I thought my iPad mini was the only one having this issue. I use the Dictionary app a lot for translations and when I switch between the dictionary app to my mail, and switch back to the translation the entire translation is lost and I have to start all over. Well, i'm so used to this happening that now i just copy my text and paste it elsewhere so I won't have to type it again. This did not happen with ios6 thats for sure. I started using my desktop computer a lot more now just because it takes a long time to copy and paste over and over. I am so annoyed that apple has not done anything about this. I have seen this problem with other apps as well, for example 'iA writer', 'Textilus', Safari, Mercury, my Photos and Videos, just to name a few. This whole multitasking thing is a mess. I have tried to figure out why and when the apps refresh, but It seems like it refreshes and clears everything whenever it wants to. Very annoying and disappointing.

  • rick7 Level 1 (0 points)

    Welcome , JCCova. Yep, this is the type of experience that a lot of us are having with our apps since upgrading to iOS 7. For me, it's most frustrating with an app called Photo Manager Pro where I do a lot of my work on a typical day. When I switch back to do it after working somewhere else, the photo I was looking at is gone and the app has reset back to its display of initial root folders. Another big problem for me is Wikibot which loses the Wikipedia article I had been looking at.


    So many people are having this problem but I haven't seen it addressed in any of the iOS 7 reviews I've read. Apple doesn't seem to be addressing it.  And then I guess there seem to be other people who have noticed it but are fine with it, which I don't really understand.


    Makes me really appreciate my desktop PC running Windows which doesn't suffer from this ridiculous problem. Every app is exactly where you had previously left it when you switch back to it. I imagine the desktop and laptop Apple OS's also have good app-switching. This seems to be only a problem with Apple mobile devices running iOS 7 which doesn't have enough memory left over to do app-switching properly.


    I wonder if this is an issue with mobile devices running Android.

  • turfstuf Level 1 (0 points)

    Don't let apple off the hook by giving them the excuse that it is our fault for not having a device with adequate memory.  App switching worked correctly in iOS 6. We should have been warned that iOS 7 was going to take away the simple function of being able to switch between apps without losing anything.  My hunch is Apple didn't test it thoroughly and this issue is an unintended consequence AND can be fixed.


    So what can we do about this to get the problem acknowledged by Apple and ultimately FIXED?

  • rick7 Level 1 (0 points)

    Turfstuf, thank you -- you're absolutely right and we do need to keep this in mind.  I had one of the guys at the Genius Bar at the Apple Store tell me "Well, it's always worked this way.... you could see it crop up in iOS 6 sometimes.... it's just that now in iO7 it's been changed a little bit so's really up to the individual apps to code for the new way backgrounded apps are handled...." etc, etc. 


    NO.  By and large this is a problem that didn't exist before iOS 7 and was CAUSED by iOS7.  We were not warned about this either by Apple (or, ironically, by any of the reviewers).  If we had been, we could have made a choice about upgrading.  Exactly as you say, this app-switching problem is a major unintended and unforeseen consequence of something they did with iOS 7.  It's an introduced problem and can be and should be fixed.

  • paulfromstone Level 1 (5 points)

    My understanding of the "new" multitasking in iOS 7 is that there are addtional features that apps can use, but there is no fundamental change to the existing multitasking.


    As others have reported, it appears that the issue does exist on the latest devices, and my rudimentary comparison of memory usage showed minimal memory use difference between iOS 6 and 7.


    This all seems to be suggesting that it is an issue with iOS 7 itself. Hopefully Apple will discover and fix it before I defect to Android!

  • puskarich Level 1 (0 points)

    Rather than waiting for Apple to find this on their own, is there a way for a regular iOS user to log a support ticket/bug or is that limited to only developers?  While I see the issue on my 5s, I must admit it has been less frequent than it was on the 4s. If we want it on their radar screen, we probably need to do something a little more proactive than waiting for them to find this thread.

Previous 1 3 4 5 6 7 Next