11 Replies Latest reply: Nov 17, 2013 9:00 PM by Ghiltrini
someguy5956 Level 1 Level 1 (0 points)

I have an iPhone 4S that has served me well, and has been a trusty device of mine until recently. Before I installed iOS 7, my phone would be able to achieve cellular network speeds up to almost 8 Mbps and my battery could make it through the day. Since the install, it's like I've downgraded my phone. I've only been able to achieve network speeds up to 0.25 Mbps and now have to charge my phone about three times a day. Seeing as my cellular Internet speeds have decreased by about 32 times over. I thought that this might be a reception problem, but no matter the strength of the connection the results are still the same. My WiFi speeds are unaffected, just my cellular network data.

I went to my local Apple store today, where they attempted a firmware restore. This did not fix the problem, and the only other options they suggested were to replace the battery or buy a new phone. I find this to be absolutey disatifactory, to the point where I'm beginning to lose my faith in Apple's ability to resolve this. My phone worked flawlessly before, but now it's turning into a technilogical brick.


iPhone 4S, iOS 7.0.2
  • 1. Re: Cell Data Significantly Slower on iOS 7
    KalebsDad78 Level 4 Level 4 (1,705 points)

    Sorry about your issues...I have no degradation in cellular data speeds.  I just did a speed test (Speedtest app) and achieved 54.2 Mbs downlodad and 9.41 Mbps upload on a Verizon LTE network.

     

    Can you travel to a different part of town and test your network speeds again?  I would also do a proper reset on the phone to ensure there is no tiny hiccup that this could resolve.

     

    Hold the home button + the lock button for about 10-12 seconds until the Apple logo appears.  You will not lose any data or current settings.

  • 2. Re: Cell Data Significantly Slower on iOS 7
    someguy5956 Level 1 Level 1 (0 points)

    I have tried all of these steps already. My location is irrelivant to the speed, and I have done the following steps:

    1) Did two back to back hard-resets (No Change)

    2) Restored from backup (No Change)

    3) Reset network settings (No Change)

    4) Reset all settings (No Change)

    5) Reset all setting, clear all content, and set up as new iPhone (No Change)

    6) Did firmware restore at Apple store (No Change)

  • 3. Re: Cell Data Significantly Slower on iOS 7
    KalebsDad78 Level 4 Level 4 (1,705 points)

    Sounds like an internal antenna issue with the phone that the new OS just brought to life.  I can't think of anything software-related that would effect it when it's not a wide-spread issue.  I've been in the forums routinely since iOS7 was released and I have not seen anyone post about this kind of issue.

     

    Sorry I don't have any other recommendations for you but I hope you get the issue resolved soon.

  • 4. Re: Cell Data Significantly Slower on iOS 7
    someguy5956 Level 1 Level 1 (0 points)

    That is something I am beginning to consider. I just can't understand why a new OS would aggrevate the problem as I've had no issues updating in the past. I've also browsed the forums, and can't find anything like this either.

    Thank you for your time, and have a nice day.

  • 5. Re: Cell Data Significantly Slower on iOS 7
    Ksway Level 1 Level 1 (0 points)

    What carrier are you using? I may be wrong but it sound like data is being throttled.

  • 6. Re: Cell Data Significantly Slower on iOS 7
    someguy5956 Level 1 Level 1 (0 points)

    I am using AT&T, but I have one of their older unlimited data plan. While it did get throttled occansionally, it was never throttled for this long. I've been having this issue since the day iOS 7 came out.

  • 7. Re: Cell Data Significantly Slower on iOS 7
    ChazThePhoenix Level 1 Level 1 (10 points)

    Well the iOS download may have used all you monthly download limit. :) When does your monthly reset? I bet come anew billing period, it will work fine

  • 8. Re: Cell Data Significantly Slower on iOS 7
    Mike Osswald Level 1 Level 1 (50 points)

    I have the same problem after update - iPhone 5, AT&T - except that ONE TIME when I did speed test it was fast again! But that didn't last. When slow, .5 Mbps up and down. When normal, 18-20 up, 10-12 down. Haven't had time to blow everything away yet, tried hard reset to no avail.

  • 9. Re: Cell Data Significantly Slower on iOS 7
    MidnightGrimm Level 1 Level 1 (0 points)

    I have the same problem. iPhone 4S. 64gig. AT&T. Most recent version. (7.0.3) After updating to ios7, my data speeds dropped significantly. Pre update, I was getting 6-8mbps up. Now I'm only getting 0.1 to 0.2 up and 0.15-0.25mbps down. I contacted AT&T who assured me that I was not throttled. They updated my SIM card in store as well as reset all network settings. I've done many hard and soft resets. Backed up and restored. Everything except completely wipe the phone and start over. The only time my phone has data functionality is when I'm connected to a wi-fi network.

     

    My battery also does not last as long. Any use causes it to drop relatively quickly. I charge several times throughout the day as well.

     

    Have you had any luck in finding a work-around, or getting help from Apple? I would really like to have a working phone again! Glad to hear that I'm not the only one having this issue.

  • 10. Re: Cell Data Significantly Slower on iOS 7
    someguy5956 Level 1 Level 1 (0 points)

    Unfortunatly, I have not found a solution to my problem. Sometimes my phone works propery on 4G and other times it does not. I've learned to live with it by sticking to simple websites, not streaming video, and using WiFi wherever it's availible.

  • 11. Re: Cell Data Significantly Slower on iOS 7
    Ghiltrini Level 1 Level 1 (0 points)

    Hello, I'm from the Philippines and I also experience a significant slow data connection after updating to iOS 7.0.3.