12 Replies Latest reply: Mar 30, 2014 11:38 AM by kzil
jayfromwaukegan Level 1 (0 points)

I rented Iron Man 3 and about halfway through the movie I accidentally pressed "Menu" on the remote, exiting the movie, but there is no mechanism to resume the movie.

 

When I select "Rent" I get three options "Rent and Watch Now", "Rent and Watch Later", and "Cancel".

 

If I select either of the first two options I get a screen with an OK button and text that says: "You have already rented this item but it has not been downloaded. To download it, go to the Settings menu, select Downloads, then Check for Downloads."

 

There is not a "Downloads" option in the Settings menu.

 

Under Settings if I go to "iTunes Store" and then select "Check For Rentals" I get a spinning busy-icon that spins forever.

 

What's going on here? I have the latest update.

 

Please at least inform me how to get a refund.


Mac Pro, Mac OS X (10.6.7)
  • Deathblow2 Level 1 (0 points)

    Having the same problem here. As we can remember, before the latest update of Apple-TV it was possible to go to the Purchased section and it would also list the rentals still valid... but now it just says we have nothing purchased and as Jay writes, when trying to Check for rentals, the busy icon just keeps spinning with no results. VERY annoying.

    However, I've contacted support a few times and it doesn't seem to be a problem getting the refunds. But I am more curious to how we can resume watching the movies.

  • visualsusan Level 1 (0 points)

    We haven't even been able to start the movie. Same issue.  Apple? A little guidance here? I've got a slumber party in progress and can't start our movie! Thanks!

  • Winston Churchill Level 10 (95,544 points)

    You may wish to try logging out and back into your iTunes account.

  • jayfromwaukegan Level 1 (0 points)

    Thanks, Winston. That did it. In fact, I logged out of iTunes and the iCloud and then rebooted the AppleTV.

     

    "Check For Rentals" indicated nothing was rented (probably because the 24-hr period for my rental had not yet expired).

     

    My rental appeared marked "Rental" in the Movies section next to the same movie without that designation. I selected the former and then selected "Play". Now I'm watching my rented movie.

     

    There's obviously some bugs in the movie rental procedure but a workaround is found here.

     

    Thanks again.

  • wsport Level 1 (0 points)

    I had the same issue--with Iron Man 3 even. I logged out of just iTunes, did not restart my Apple TV, returned to Movies, and my rental was there. Thanks Winston!

  • Ryan Raith Level 1 (0 points)

    Same thing here. I waited forever for the spinning to stop, restarted Atv, restarted modem, (even though netflix was working). Wasted a lot of time. Thanks for answering.

     

    This is bad interface design, Apple. Access to a rented movie should be within the movie tab, not settings. Even if "resume rental" was in a different spot, don't say "go to the Settings menu, select Downloads, then Check for Downloads" Just give me link. and finally, a spinning wheel should time out if it isn't doing anything.

  • nolascoFX Level 1 (0 points)

    After I did an AppleTV software update I was unable to rent and complete the movie. It would play for 10 min the freeze. When I go to "Check for Rentals" it would just hang forever. I did a soft restart and even unplugged my AppleTV3 but no go. I tried resetting my Apple Extreme router but still unable to watch my rental. I finally "Reset All Settings" on my AppleTV3 and had to reconnect to my WiFi and re-enter my iTunes account but it fixed it. I was able to watch my rental.

  • 86-17530 Level 1 (0 points)

    thanks Jay, your instructions worked perfectly.

  • Kreplaw Level 1 (0 points)

    This worked.  Thank you.  I found it while on hold with customer service. Not only were they completely unhelpful, they tried to sell me a service plan.  I rented a movie on itunes, and have a Mac, 2 iphones, and an apple tv, but they want to charge me to report a technical problem.  Not cool Apple, not cool.

  • Tickle's dinner Level 1 (0 points)

    Thanks! Had this issue previously when my internet dropped out.

  • GatorElecEng Level 1 (0 points)

    That was very helpful. You ended a very irritating session that might otherwise have resulted in a game of skip the rock on the water only it would be my AppleTV

  • kzil Level 1 (0 points)

    Logging out and in helped. But hey Apple!! Fix this!