14 Replies Latest reply: Oct 12, 2013 5:06 AM by FrenchToast Branched to a new discussion.
FrenchToast Level 3 (645 points)

Hi guys,


This "issue" never happened before, but since I upgraded iOS to version 7 on my iPhone 4 (GSM), iTunes (also recently and manually updated to the latest version) will restart after I close it when my phone is plugged in in USB. Basically, I back up / sync my iPhone, then close iTunes. About thirty seconds later, iTunes restarts on its own, and I have to close it again to keep it that way, until the next restart.


At first, I thought it had to do with a loose or shaky USB slot, but I let my Mac sit on a flat surface, with the iPhone by its side, and every time I close iTunes, it restarts on its own, no matter what. Repairing permissions didn't help.


This is driving me nuts, all the more so since I've checked in iTunes preferences, and couldn't find any mention of a "keep alive" iTunes functionality.


I should add that this problem also happens when syncing via Wifi, but not as regularly as in USB mode. 


Ideas, anyone? Should I check or uncheck something on the iPhone?

MacBook Pro, Mac OS X (10.6.8)
  • C F McBlob Level 4 (2,865 points)



  • FrenchToast Level 3 (645 points)

    Hi, and thanks for taking the time to answer me!


    However, like I said in my OP, it started happening after I upgraded my iPhone to iOS 7 and updated iTunes to its latest version. When my iPhone was still running iOS 6, I didn't have this problem. iTunes settings have always been set to automatically sync iDevices as soon as they're plugged in on all my computers, because I find it more convenient. It has the positive side effects of syncing over WiFi automatically too.


    I've just synced my iPhone via WiFi, and iTunes hasn't restarted after I closed it, so there's still the chance it comes from a loose USB port somehow (I plug it to recharge the battery, mostly). Maybe something has changed in the way iTunes times syncing, or with it polling the App Store for app updates.


    Am I the only one who has noticed this issue?

  • williamssd Level 1 (0 points)

    I just noticed about 5 minutes ago that this exact same thing is happening to me, only it has been since I upgraded to iOS 7.0.2 -- iOS 7.0.0 for my iPhone 5 (Verizon) was fine up until now.  I believe I do the exact same thing you do:  I plug in my iPhone via the USB port on my MacBook Pro (early 2011), it syncs, and then I eject the iPhone in iTunes and quit iTunes (so that the phone is simply charging).  I'm going to try turning the phone off, and then back on to see if it continues.

  • williamssd Level 1 (0 points)

    Well, it's still early but it appears that after a full Restart of my MacBook Pro, and closing all apps on my iPhone and restarting it, that the problem is not recurring.  I'll still monitoring it to see if it happens again.

  • radaines Level 1 (5 points)

    Same issue here, however this only started after updating to iTunes 11.1. I am using an iPhone 3GS on iOS 6.1.3 so nothing to do with iOS 7. As long as the iPhone is connected to my iMac, I cannot keep iTunes closed, it keeps relaunching on its own.

  • FrenchToast Level 3 (645 points)

    Well, people, it looks like the plot is thickening... I haven't noticed if this issue started after upgrading to iOS 7.0 right away, or only after I went to 7.0.2, but the only thing we all have in common is that we all upgraded iTunes to 11.1 before noticing anything.


    I keep wondering if the new automatic app update in iOS 7.x couldn't be the culprit here. Do you have it enabled on your iPhones (aside from radaines, who's still on iOS 6)?

  • Paul_Cambridge Level 1 (0 points)

    I've had the same issue: iphone 5 on IOS 7 and itunes 11.1


    Like other posters, I'm not sure exactly when it first happened because you tend to live with it for the first couple of times, and the whole ecosystem seems to be changing all the time: as a simple user I don't pay much attention until something breaks!


    It's annoying as ****!


    Come on apple!  We eternal optimists expect better.

  • FrenchToast Level 3 (645 points)

    The latest iTunes update (11.1.1) didn't help either. I've just ejected the iPhone from iTunes and closed it down (iTunes, I mean), and sure enough, after about 30 seconds, iTunes restarted. I've plugged it into a Windows PC, and it doesn't happen, only on the Mac.

  • Applyne Level 1 (0 points)

    I have the same issue but when I checked the system logs in Console there are a bunch of crash reports for iTunes that happen at the exact time of quitting iTunes.  If I keep Console open then I can see the crash report being generated.  This seems to prompt OSX to reopen iTunes.  The crash reports seem to be associated with usbmuxd which is the daemon used for the cable connection to the iPhone/iPad.  I therefore do not think this is a function, but rather a feature.  Annoyingly sometimes iTunes also crashes if I plug in an iPhone/iPad whilst iTunes is already running, when I am playing tunes over Airplay and sometimes when streaming to Apple TV - all the crash reports seem to show the usbmuxd error EXC_BAD_ACCESS (SIGSERV).  I have tried repairing permissions and reinstalling iTunes but nothing solves this.  There are plenty of other threads on this also.


    Could one of you check your Console logs and see if you see the same?

  • FrenchToast Level 3 (645 points)

    There are so many entries in my Console, I can't find the one you mention, but I've noticed that syncing the iPhone over the WiFi won't make iTunes relaunch the way it does in USB, so I gather you're right about this daemon being the (probable) culprit. I hope Apple is working on a solution to this problem...

  • Applyne Level 1 (0 points)

    Should be under System Diagnostic Reports - something like usbmuxd_2013-10-09-1753.....  I hope that they fix it soon also as I am getting it on both my iMac and MacBook, so definitely a software problem.

  • FrenchToast Level 3 (645 points)

    Well, sure enough, there it was, and boy, it didn't come alone...


    Here's what's the latest entry shows (lots of mention of LDAP. That's Bonjour by another name, right?):


    Process:         usbmuxd [36]

    Path:            /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/Resources/u sbmuxd

    Identifier:      usbmuxd

    Version:         ??? (???)

    Code Type:       X86 (Native)

    Parent Process:  launchd [1]


    Date/Time:       2013-10-07 19:54:54.295 +0200

    OS Version:      Mac OS X 10.6.8 (10K549)

    Report Version:  6


    Exception Type:  EXC_BAD_ACCESS (SIGBUS)

    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000010

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread


    Thread 0 Crashed:  Dispatch queue: com.apple.main-thread

    0   usbmuxd                                 0x0000ee53 0x1000 + 56915

    1   usbmuxd                                 0x00009f58 0x1000 + 36696

    2   usbmuxd                                 0x000126c0 0x1000 + 71360

    3   com.apple.CoreFoundation                0x91eada3b __CFRunLoopRun + 8059

    4   com.apple.CoreFoundation                0x91eab3c4 CFRunLoopRunSpecific + 452

    5   com.apple.CoreFoundation                0x91eb1304 CFRunLoopRun + 84

    6   usbmuxd                                 0x00003134 0x1000 + 8500

    7   usbmuxd                                 0x00002375 0x1000 + 4981


    Thread 1:  Dispatch queue: com.apple.libdispatch-manager

    0   libSystem.B.dylib                       0x95ee9382 kevent + 10

    1   libSystem.B.dylib                       0x95ee9a9c _dispatch_mgr_invoke + 215

    2   libSystem.B.dylib                       0x95ee8f59 _dispatch_queue_invoke + 163

    3   libSystem.B.dylib                       0x95ee8cfe _dispatch_worker_thread2 + 240

    4   libSystem.B.dylib                       0x95ee8781 _pthread_wqthread + 390

    5   libSystem.B.dylib                       0x95ee85c6 start_wqthread + 30


    Thread 2:  com.apple.CFSocket.private

    0   libSystem.B.dylib                       0x95ee1ac6 select$DARWIN_EXTSN + 10

    1   com.apple.CoreFoundation                0x91eebc53 __CFSocketManager + 1091

    2   libSystem.B.dylib                       0x95ef0259 _pthread_start + 345

    3   libSystem.B.dylib                       0x95ef00de thread_start + 34


    Thread 0 crashed with X86 Thread State (32-bit):

      eax: 0x00000000  ebx: 0x00000000  ecx: 0x0001949c  edx: 0x00000001

      edi: 0x00009e18  esi: 0x0000ee49  ebp: 0xbffff0f8  esp: 0xbffff0d0

       ss: 0x0000001f  efl: 0x00010282  eip: 0x0000ee53   cs: 0x00000017

       ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000037

      cr2: 0x00000010


    Binary Images:

        0x1000 -    0x17ffc  usbmuxd ??? (???) <8D711021-8555-3BB4-AA07-8C56E6B53575> /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/Resources/u sbmuxd

       0x22000 -   0x10cff0  com.apple.mobiledevice 710 (710) <35441811-BA51-3BAF-B22A-30C16ECB7AC0> /System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/MobileDevic e

    0x8fe00000 - 0x8fe4163b  dyld 132.1 (???) <4CDE4F04-0DD6-224E-ACE5-3C06E169A801> /usr/lib/dyld

    0x90008000 - 0x90072fe7  libstdc++.6.dylib 7.9.0 (compatibility 7.0.0) <411D87F4-B7E1-44EB-F201-F8B4F9227213> /usr/lib/libstdc++.6.dylib

    0x9084c000 - 0x90905fe7  libsqlite3.dylib 9.6.0 (compatibility 9.0.0) <52438E77-55D1-C231-1936-76F1369518E4> /usr/lib/libsqlite3.dylib

    0x90906000 - 0x90949fe7  com.apple.MediaKit 10.5.1 (490) <4CF33D3A-ABA4-5AD8-2BCB-19FADF4347DB> /System/Library/PrivateFrameworks/MediaKit.framework/Versions/A/MediaKit

    0x90957000 - 0x90a57fe7  libxml2.2.dylib 10.3.0 (compatibility 10.0.0) <BE7FCD73-03B5-25A4-FCA4-D4980F1488D6> /usr/lib/libxml2.2.dylib

    0x90a58000 - 0x90ad2fff  com.apple.audio.CoreAudio 3.2.6 (3.2.6) <156A532C-0B60-55B0-EE27-D02B82AA6217> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio

    0x9123f000 - 0x91277ff7  com.apple.LDAPFramework 2.0 (120.1) <131ED804-DD88-D84F-13F8-D48E0012B96F> /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP

    0x912b9000 - 0x912d9fe7  libresolv.9.dylib 41.1.0 (compatibility 1.0.0) <8C2B5FA8-2469-21C7-D297-F95A0FFE5F19> /usr/lib/libresolv.9.dylib

    0x912da000 - 0x91317ff7  com.apple.SystemConfiguration 1.10.8 (1.10.2) <50E4D49B-4F61-446F-1C21-1B2BA814713D> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfi guration

    0x91e2b000 - 0x91e2cff7  com.apple.audio.units.AudioUnit 1.6.7 (1.6.7) <93EC71F1-4D4E-F456-8EFE-32E7EFD7A064> /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit

    0x91e32000 - 0x91e33ff7  com.apple.TrustEvaluationAgent 1.1 (1) <2D970A9B-77E8-EDC0-BEC6-7580D78B2843> /System/Library/PrivateFrameworks/TrustEvaluationAgent.framework/Versions/A/Tru stEvaluationAgent

    0x91e6f000 - 0x91feafe7  com.apple.CoreFoundation 6.6.6 (550.44) <F88C95CD-1264-782D-A1F5-204739847E93> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

    0x92025000 - 0x92102fe3  com.apple.DiscRecording 5.0.9 (5090.4.2) <92C85A16-5C80-9F35-13BE-2B312956AA9A> /System/Library/Frameworks/DiscRecording.framework/Versions/A/DiscRecording

    0x923ce000 - 0x923ceff7  com.apple.CoreServices 44 (44) <51CFA89A-33DB-90ED-26A8-67D461718A4A> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices

    0x92b06000 - 0x92b1afe7  libbsm.0.dylib ??? (???) <14CB053A-7C47-96DA-E415-0906BA1B78C9> /usr/lib/libbsm.0.dylib

    0x930b6000 - 0x930c3ff7  com.apple.NetFS 3.2.2 (3.2.2) <DDC9C397-C35F-8D7A-BB24-3D1B42FA5FAB> /System/Library/Frameworks/NetFS.framework/Versions/A/NetFS

    0x93215000 - 0x93215ff7  com.apple.vecLib 3.6 (vecLib 3.6) <FF4DC8B6-0AB0-DEE8-ADA8-7B57645A1F36> /System/Library/Frameworks/vecLib.framework/Versions/A/vecLib

    0x933a0000 - 0x9343dfe3  com.apple.LaunchServices 362.3 (362.3) <15B47388-16C8-97DA-EEBB-1709E136169E> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchS ervices.framework/Versions/A/LaunchServices

    0x9343e000 - 0x93447ff7  com.apple.DiskArbitration 2.3 (2.3) <E9C40767-DA6A-6CCB-8B00-2D5706753000> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration

    0x9349a000 - 0x938b0ff7  libBLAS.dylib 219.0.0 (compatibility 1.0.0) <C4FB303A-DB4D-F9E8-181C-129585E59603> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libBLAS.dylib

    0x9474f000 - 0x9475dfe7  libz.1.dylib 1.2.3 (compatibility 1.0.0) <33C1B260-ED05-945D-FC33-EF56EC791E2E> /usr/lib/libz.1.dylib

    0x9475e000 - 0x947a0ff7  libvDSP.dylib 268.0.1 (compatibility 1.0.0) <8A4721DE-25C4-C8AA-EA90-9DA7812E3EBA> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libvDSP.dylib

    0x947a1000 - 0x94ac1ff3  com.apple.CoreServices.CarbonCore 861.39 (861.39) <5C59805C-AF39-9010-B8B5-D673C9C38538> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonC ore.framework/Versions/A/CarbonCore

    0x94ac2000 - 0x94ad2ff7  libsasl2.2.dylib 3.15.0 (compatibility 3.0.0) <C8744EA3-0AB7-CD03-E639-C4F2B910BE5D> /usr/lib/libsasl2.2.dylib

    0x94ad3000 - 0x94b0bfe7  libcurl.4.dylib 6.1.0 (compatibility 6.0.0) <26FB5A40-6B39-1EA0-63D3-C2CC3BC6754D> /usr/lib/libcurl.4.dylib

    0x9510d000 - 0x9518dfeb  com.apple.SearchKit 1.3.0 (1.3.0) <9E18AEA5-F4B4-8BE5-EEA9-818FC4F46FD9> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchK it.framework/Versions/A/SearchKit

    0x9518e000 - 0x95191fe7  libmathCommon.A.dylib 315.0.0 (compatibility 1.0.0) <1622A54F-1A98-2CBE-B6A4-2122981A500E> /usr/lib/system/libmathCommon.A.dylib

    0x951e6000 - 0x952b1fef  com.apple.CoreServices.OSServices 359.2 (359.2) <7C16D9C8-6F41-5754-17F7-2659D9DD9579> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServi ces.framework/Versions/A/OSServices

    0x952b2000 - 0x9535ffe7  libobjc.A.dylib 227.0.0 (compatibility 1.0.0) <9F8413A6-736D-37D9-8EB3-7986D4699957> /usr/lib/libobjc.A.dylib

    0x95360000 - 0x95393ff7  com.apple.AE 496.5 (496.5) <BF9673D5-2419-7120-26A3-83D264C75222> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/AE.fram ework/Versions/A/AE

    0x954d5000 - 0x955d7fe7  libcrypto.0.9.8.dylib 0.9.8 (compatibility 0.9.8) <EB34F049-D9E1-BF19-CF03-B26A0352D40C> /usr/lib/libcrypto.0.9.8.dylib

    0x957ba000 - 0x95817ff7  com.apple.framework.IOKit 2.0 (???) <3DABAB9C-4949-F441-B077-0498F8E47A35> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

    0x95ec2000 - 0x96069ff7  libSystem.B.dylib 125.2.11 (compatibility 1.0.0) <2DCD13E3-1BD1-6F25-119A-3863A3848B90> /usr/lib/libSystem.B.dylib

    0x9606a000 - 0x96170ff3  com.apple.DiskImagesFramework 10.6.8 (289.1) <49B23766-6397-6F59-E287-3B2535FBD79B> /System/Library/PrivateFrameworks/DiskImages.framework/Versions/A/DiskImages

    0x97966000 - 0x97bd7fef  com.apple.Foundation 6.6.8 (751.63) <69B3441C-B196-F2AD-07F8-D8DD24E4CD8C> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation

    0x98251000 - 0x98279ff7  libxslt.1.dylib 3.24.0 (compatibility 3.0.0) <E761F29A-328B-29D9-3DF0-023F2C21E500> /usr/lib/libxslt.1.dylib

    0x9893c000 - 0x98d71ff7  libLAPACK.dylib 219.0.0 (compatibility 1.0.0) <5E2D2283-57DE-9A49-1DB0-CD027FEFA6C2> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libLAPACK.dylib

    0x98d72000 - 0x98d7eff7  libkxld.dylib ??? (???) <9A441C48-2D18-E716-5F38-CBEAE6A0BB3E> /usr/lib/system/libkxld.dylib

    0x98dc3000 - 0x98e32ff7  libvMisc.dylib 268.0.1 (compatibility 1.0.0) <595A5539-9F54-63E6-7AAC-C04E1574B050> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.fr amework/Versions/A/libvMisc.dylib

    0x98ebb000 - 0x99121ff7  com.apple.security 6.1.2 (55002) <E88E133F-5FB3-446F-B753-2B8AD577B46A> /System/Library/Frameworks/Security.framework/Versions/A/Security

    0x9912e000 - 0x99154ffb  com.apple.DictionaryServices 1.1.2 (1.1.2) <43E1D565-6E01-3681-F2E5-72AE4C3A097A> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Diction aryServices.framework/Versions/A/DictionaryServices

    0x99156000 - 0x9919cff7  libauto.dylib ??? (???) <29422A70-87CF-10E2-CE59-FEE1234CFAAE> /usr/lib/libauto.dylib

    0x991eb000 - 0x99224fe7  com.apple.bom 10.0 (164) <CC61CCD7-F76C-45DD-6666-C0E0D07C7343> /System/Library/PrivateFrameworks/Bom.framework/Versions/A/Bom

    0x998cc000 - 0x99978fe7  com.apple.CFNetwork 454.12.4 (454.12.4) <DEDCD006-389F-967F-3405-EDF541F406D7> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwo rk.framework/Versions/A/CFNetwork

    0x99979000 - 0x99a11fe7  edu.mit.Kerberos 6.5.11 (6.5.11) <F36DB665-A88B-7F5B-6244-6A2E7FFFF668> /System/Library/Frameworks/Kerberos.framework/Versions/A/Kerberos

    0x99a1d000 - 0x99a2afe7  libbz2.1.0.dylib 1.0.5 (compatibility 1.0.0) <828CCEAB-F193-90F1-F48C-54E3C88B29BC> /usr/lib/libbz2.1.0.dylib

    0x99a3d000 - 0x99bbffe7  libicucore.A.dylib 40.0.0 (compatibility 1.0.0) <60FF302E-5FAE-749B-BC70-0496DC2FBF2D> /usr/lib/libicucore.A.dylib

    0x99f1c000 - 0x9a059fe7  com.apple.audio.toolbox.AudioToolbox 1.6.7 (1.6.7) <423BDE4D-5082-B6CA-BB2C-E22A037235A4> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox

    0x9a472000 - 0x9a4b6fe7  com.apple.Metadata 10.6.3 (507.15) <74F05E64-2A68-BA10-CCD4-128D164E5A0F> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadat a.framework/Versions/A/Metadata

    0x9a7dc000 - 0x9a7e9ff7  com.apple.AppleFSCompression 24.4 (1.0) <09E7FA6D-4BE8-5CA6-732F-D70EDF0E3910> /System/Library/PrivateFrameworks/AppleFSCompression.framework/Versions/A/Apple FSCompression

    0x9aa8c000 - 0x9aac8fe7  libssl.0.9.8.dylib 0.9.8 (compatibility 0.9.8) <CEE95B62-8F1C-2013-6ED3-42EB8A1018DF> /usr/lib/libssl.0.9.8.dylib

    0xffff0000 - 0xffff1fff  libSystem.B.dylib ??? (???) <2DCD13E3-1BD1-6F25-119A-3863A3848B90> /usr/lib/libSystem.B.dylib


    What do you guys make of it? I tracked all mentions of my little own private self in all this, but I may have missed something. Please be discreet!

  • Applyne Level 1 (0 points)

    At least we know it is the same error.  I have no idea what it really means but it is the same error I am getting on both my machines.  We just have to wait for Apple to issue a fix!

  • FrenchToast Level 3 (645 points)

    The  problem stopped for me after transferring my purchases from the iPhone onto iTunes, while I was trying to get rid of another problem (the infamous "Can't sync/backup your phone due to not enough space..." issue described here, among other places).


    After the transfer, I managed to sync my iPhone, then closed down iTunes, and so far, my phone is still plugged in USB to the Mac, and iTunes hasn't relaunched.


    My 2 cents...