Previous 1 2 3 4 5 6 Next 238 Replies Latest reply: Jan 5, 2016 1:12 AM by ifonlyappleworked Go to original post Branched to a new discussion.
  • gawbagetwuk Level 1 (0 points)

    Sorry if this is already mentioned on here somewhere, but here's how I fixed it on my iphone 4s. I went to settings>music>home sharing>enter your apple ID and password. Then on your iphone open up your music, go to "more" (the last tab) and select "Shared". Make sure you select the library you're trying to share from your computer.

     

    Like I said, that fixed it for me. Hope it helps others.

  • gawbagetwuk Level 1 (0 points)

    Well never mind, that didn't last very long.

  • Msorli26 Level 1 (0 points)

    I figured it out! Plug your phone into your computer and wait till it appears on your ITunes. Then go to one of the songs that you want to add to your phone and hold the mouse over the song (like your want to drag and drop it). A link will appear for your phone to the right, drag the song over and drop it to your phone. After a few seconds, all of my music that I've been trying to add synced to my phone! The only problem was that it also added songs that I deleted off my phone so I'll have to go back and delete them all. But at least I have my new music now! Hope this works for everyone else!

  • darcyw77 Level 1 (5 points)

    Well, I finally caved and talked to an Apple dealer.  He told me that there are music licensing issues which no longer allow users to play songs on multiple devices like it used to.  Now you have to subscribe to Match and Apple carries the licenses for you to have your music on multiple devices.  Open iTunes and click on your Music library.  You  have many options across the top of the right-hand screen -- Songs, Albums, etc.  The far-right option is Match.  Click here to subscribe.  It did work for me.  I'm not happy that it's not a free option but I have ALL of my music back.

  • Dave Misch Level 1 (0 points)

    I have been working on this problem for the past 2 weeks.  Each time I sync my phone I find even more of my library becomes inaccessible. Now that I have gotten so frustrated that I can't play 90% of my music library on my Iphone, I just slammed it so hard onto my desk that I shattered the front screen, I guess the best solution to this problem is to go out an purchase a Samsung Galaxy.  I have already wasted enough time on this problem.   

  • ChantelMac Level 1 (0 points)

    I talked to a lovely person at Apple, and the problem is fixed like so:

    1. Unchecking the box that says "Sync Music"

    2. Hit "Apply" and let it wipe all of the music off of your iPhone.

    3. When this is complete, check the "Sync Music" box again and add your music. Voila!

    4. Be happy and enjoy your music!

  • finalnicolas Level 1 (5 points)

    It worked for me too!

  • Sully962 Level 1 (0 points)

    Go to settings-iTunes&app store- scroll down to automatic downloads and turn it on

  • Dave Misch Level 1 (0 points)

    I had already tried the recommendations of ChantelMac and Sully962 without success.  In fact, when I tried to wipe all the music off my phone there would still be 237 songs left no matter how many times I tried.  I finally fixed the problem by uninstalling iTunes and re-installing it again and then restoring my iPhone.  It seems to be working properly now.  The problem started just after I upgraded to the most recent version of iTunes a couple of weeks ago.  There must have been a corrupted file during the install.  Thanks for all of the suggestions. I appreciate it. 

  • ebslsc Level 1 (5 points)

    in regard to darcyw77's comments, 90% of my music was put on my computer, then transferred to my iPhone from CD's that I purchased and are in a drawer in my living room. I don't see how Apple can deny me access to those, but that music is affected the same as my iTune purchases.

     

    I'm still not buying any more iTunes til this is corrected. 

  • dadams51 Level 1 (0 points)

    This worked just like you said. Thanks so much.

  • shaunaruthmossy Level 1 (0 points)

    Trevormitchell1212, you are a GENIUS and have been most helpful.  Your trick worked for me!  I can't tell you how frustrated and sad this problem had made me.  THANK you!!

  • andrew_smith Level 1 (0 points)

    The 'fixes' here may be solving certain individuals' problems displaying similar symptoms, but the problems are various. Some problems are solved by messing with settings.

     

    My problem is: I purchased an audiobook from iTunes and it WILL NOT sync to my iPhone because they are m4b 'protected' files.

     

    Had I known I could not put them on my iPhone, I would not have purchased them. The solution to my problem is: either crack the protection so I can listen to the audio I purchased OR refrain from buying stuff from iTunes.

  • andrew_smith Level 1 (0 points)

    Oh dear. Turns out audiobook audio has to be synced under 'Books' not 'Music'.... and then appears under 'Music' on my iPhone.

     

    Ugh.

  • brett_7 Level 1 (0 points)

    hey all,

     

    after having the same problem as everyone else i was getting more and more annoyed. i found i fixed it by going onto music and selecting more option, shared and selecting my mac libary then re syncing and all music was uploaded to iphone hope this sorts everyones problem.

     

    i think the new update took off the option of libary sync.

Previous 1 2 3 4 5 6 Next