12 Replies Latest reply: Oct 1, 2014 9:35 PM by ICT_PCYC
davidaus Level 1 Level 1

Ever since installing iOS7 on both an iPad 4 and iPad 2 the proxy authentication password no longer saves as it did previously with iOS6.

It saves in the WiFI field and works for the session but when you come back to the iPad in the next day or turn the iPad off completely and turn it back on, it is asking for proxy authentication in Safari again. I've noticed that sometimes the value is still saved in the field in the Wifi properties and going back into it and changing a character and changing it back again fixes it for the session again. Sometimes however I've noticed the password field has been completely blanked out!

 

I also have upgraded to 7.0.2 this weekend on both devices and still no change.

 

Anyone else experiencing this and know of any fix? I have completely wiped out the settings several times and "forgotten" the Wifi network, manually re-entering all details without success.


iPad, iOS 7.0.2
  • MrBurbs Level 1 Level 1

    I am having the exact same problem on the iPads in our school. All the iPads that have been upgraded to iOS7 keep prompting for the authentication. It is still saved in the WiFi settings, but as Davidaus above states, it still prompts for the username and password for the proxy all the time. This has only happened on the iOS7 iPads, not the iOS6 ones.

    We do not use configurator, and the iPads are not 'managed' in any way, but we do use a Proxy and this is causing a big headache.

    I too have 'forgotten' the network, re-discovered and recreated all the proxy settings, but after a shut down and restart or after a while of been asleep, it starts prompting again for the proxy login details, even though they are still there.

     

    I have searched all over the web for a solution with no luck.

    Apple - can't you help?!!

  • Jo_E Level 1 Level 1

    Same problem here. 200 iPads in our school, updated one trolley to iOS7 and the passwords just won't stick.

    We are using configurator. Password is lost after a short time, or after being switched off.

  • Keith Whitehead Level 1 Level 1

    I have the same problem on my iPhone 5S.

     

    We have an authenticating proxy that requires log/pass and the iPhone does NOT remember these. Even when you put them in you have to do it 2-3 times.

     

    This is a major pain for one of our blind staff who bought and iPhone 5 to use SIRI

     

    I have also confrimed that th problem exists for my iPad mini and iPad 2

  • Matt Acosta Level 1 Level 1

    I am using the configurator with it, and it seems to stick after many manual attempts

  • Crosfields School Level 1 Level 1

    Exactly the same problem for us. Updated to 7.0.4 yesterday and still no fix. We use the Meraki MDM and even that won't get the settings to stay.

     

    We've switched to using a WPAD file and putting the URL to that in the Automatic configuration section instead. Unfortunately this doesn't allow us to specify authentication details, but it's that or nothing at the moment.

  • Blue John 26 Level 1 Level 1

    Finally solved this (for individual iphone/ipad - not sure about multiple machines)

    1) Enter the Port Number first

    2) Enter the Proxy Name and PRESS ENTER (Bottom right of keyboard) .This is what made the difference for me - sure I never had to do that previously...

     

    Cheers

  • Lava007 Level 1 Level 1

    [SOLVED]

    If you forget the network, rejoin it, then enter the settings, it makes it work.

  • Jo_E Level 1 Level 1

    @Lava007 - That's a workaround, but it's far from solved. I have hundreds of iPads - this should work as configured from the start. Shouldn't need to mess about with individual devices and re-enter settings all over again.

  • phka Level 1 Level 1

    Same problem here with our iPads. The workaround from blue john also didn't functioned.

    Very very stupid situation.... apple please help

  • Uge Level 1 Level 1

    Any update on this?

     

    It's driving me crazy.

     

    I use my personal iPhone with iOS 7 on my WiFi office.

     

    We're running ClearOS with proxy and content filter.

     

    The proxy requires authentification.

     

    It works fine with my MacBook with OS X, on any Windows machine, on all Android Phones.

     

    BUT on my iOS 7 iPhone it keeps asking me for the username and password.

     

    I did "forget network" and re-enter all settings manually, including username and password in the WiFi configuration, but nothing does it...

     

    It keeps asking me for the username and password ALL THE FREAKIN TIME and since the password is mucho complicated, it's just ****...

     

    I ended up disabling WiFi for now...

  • Texas Mac Man Level 8 Level 8

    This is an iPad user to user forum, so you are not addressing Apple.


     

    Send feedback/suggestions to Apple.

     

    http://www.apple.com/feedback/ipad.html

     

    Submitting Feedback to Apple

    https://sites.google.com/site/appleclubfhs/support/advice-and-articles/submittin g-feedback-to-apple

     

    File an Apple Bug Report, at http://bugreport.apple.com/

     

     Cheers, Tom

  • ICT_PCYC Level 1 Level 1


    Hi Guys

    Has anyone found a solution to this. It is driving us up the wall. We are looking to roll out a bunch of devices but until this is resolved, there is no way we can do this.

    Does the IOS8 fix the issue?

    Thanks in advance