9 Replies Latest reply: Oct 3, 2013 8:40 AM by Michael Grenadier
Kev Wms Level 1 Level 1 (0 points)

I am currently using FCP 5.1.4 and upon opening it this morning, the entire editing workspace has the same, illegible font (the letter 'A' in a box). Also, when I try and access my user preferences within FCP, it will crash.

 

Picture 6.png

Also, when I try and access my user preferences within FCP, it will crash. I have trashed my preferences and repaired permissions, but beyond that, I am clueless on how to resolve this problem.

 

Here is the crash report (abbreviated version)...

 

Version:        5.1.4 (5.1.4)

Build Version:  2

Project Name:   FCPApp

Source Version: 702211411

 

 

PID:    222

Thread: 0

 

 

Exception:  EXC_BAD_ACCESS (0x0001)

Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000024

 

 

Thread 0 Crashed:

0   com.apple.FinalCutPro                    0x0014e245 pKGGetCanvasWindow(KGCanvasRec*) + 9

1   com.apple.FinalCutPro                    0x000c56f2 InitSliderStuff(KGSliderRecord*, KGSliderType, double, double, long, unsigned char, double, long, char*) + 2178

2   com.apple.FinalCutPro                    0x000c5a3a pKGInitSlider(KGViewRecord*, KGSliderRecord*, KGSliderType, char*, KGRect*, double, double, long, unsigned char, double, long, long, char*, char*, unsigned long) + 204

3   com.apple.FinalCutPro                    0x000c5b1e pKGNewSlider(KGViewRecord*, KGSliderType, char*, KGRect*, double, double, long, unsigned char, double, long, long, char*, char*, unsigned long) + 216

4   com.apple.FinalCutPro                    0x002820c8 ScrollerInit(KGScrollerRecord*, KGRect*, char*, unsigned long) + 380

5   com.apple.FinalCutPro                    0x00282543 pKGScrollerMessage(long, long, KGDictInt*, KGViewRecord*) + 449

6   com.apple.FinalCutPro                    0x0026f0b3 ViewGetFromResource(KGFileRec*, long, KGViewRecord**, unsigned char) + 1557

7   com.apple.FinalCutPro                    0x0026f1cf pKGViewGetFromResource(KGFileRec*, long, KGViewRecord**) + 27

8   com.apple.FinalCutPro                    0x001ebada AudioGroupPreferenceHandler(long, long, KGDictInt*, void*) + 190

9   com.apple.FinalCutPro                    0x001d6cde pKGAppPreferenceShow(char*, unsigned char) + 904

10  com.apple.FinalCutPro                    0x0018c596 DefaultMenuHandler(long, long, KGDictInt*, void*) + 858

11  com.apple.FinalCutPro                    0x0013a1f3 HandleMenuCommand(long, unsigned char, unsigned char, unsigned char, KGErrorCode (*)(long, long, KGDictInt*, void*), void*) + 331

12  com.apple.FinalCutPro                    0x0013a3cf HandleCommand(long, unsigned char, unsigned char, unsigned char) + 251

13  com.apple.FinalCutPro                    0x003cda98 CommandProcess(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 362

 

 

Thanks-


Final Cut Pro 6, Mac OS X (10.4.11), Final Cut 5.1.4
  • Shane Ross Level 8 Level 8 (42,550 points)

    How did you trash your preferences?

  • Kev Wms Level 1 Level 1 (0 points)

    Thanks for the response Shane -

     

    I followed Larry Jordan's Final Cut Pro Tip of the Day

     

    A couple of notes -

     

    After trashing my preferences I opened FCP and found that my 'Choose Setup' prompt was not legible (still had the "A's in a box"font) . I also tried opening FCP under another user and while I was able to read my editing workspace and open projects, it was still acting strange and eventually crashed on me as well.

     

    This has not been a fun/productive day

  • Shane Ross Level 8 Level 8 (42,550 points)

    Hmmm...try PREFERENCE MANAGER from digitalrebellion.com. It's free, and does this with one button push...instead of you rooting around for files.

  • Kev Wms Level 1 Level 1 (0 points)

    Per your recommendation, I downloaded PREFERENCE MANAGER (ver 2.0.7 for OS X 4.x) and selected FCP and its associated files (seemed simple enough). I pressed TRASH and opened FCP. Unfortunately, I still get the 'boxed A' font for text.

     

    I've had this setup for almost 6 years and this is the first time I've had this occur. It seems like it would be a simple enough fix, but it's proving to be a tough nail to hit.

     

    In regards to the 'box A' font...is it possible in FCP to change the font for the editing workplace windows?

  • Michael Grenadier Level 7 Level 7 (20,335 points)

    Just a shot in the dark.  Make sure that your Mac OS system preferences are set for the correct language.  I'm in Mountain Lion at the moment.  It's in system preferences:  languages and text.

  • Kev Wms Level 1 Level 1 (0 points)

    @Michael Grenadier - Thanks for the suggestion. You had the same inclination as I did and it was actually the first thing I checked. 

     

    Would a re-install of FCP help at this point?

  • Michael Grenadier Level 7 Level 7 (20,335 points)

    no idea if a reinstall of fcp would solve the problem.  My guess is that it's an os problem rather than an fcp problem.   

     

    Here are a few things to try.  launch fontbook and validate all fonts.

     

    Go to system preferences:  accounts and create a new account.  Log out and log in to the new account.

     

    Have you installed any new programs recently or done any software updates?

     

    Are you using suitcase by any chance?  It's a font managerment program and I've seen problems in other programs with it.

  • Kev Wms Level 1 Level 1 (0 points)

    - Launched FONTBOOK and validated all fonts...every font checked out okay

     

    - Went to System preferences and created a new account. I logged out and logged back in under the new account...FCP displayed the now familiar 'boxed A' font on the editing work space windows and related dialogue boxes . FCP also crashed when I tried to access the User Preferences (this was also happening in my original user account).

     

    - I have not recently installed or updated any programs on my Mac. Also, I am not using Suitcase or any other font management software.

     

    Again, thanks for the suggestions. This issue has me mystified (and a bit behind on projects). I've used FCP for almost 10 years and I have never come across this particular problem.

  • Michael Grenadier Level 7 Level 7 (20,335 points)

    you might get digital rebellion's Pro Maintenance Pack

     

    http://www.digitalrebellion.com/promaintenance/

     

    It has a free trial and a crash analyzer.  Not sure if it'll work on such an old version of fcp, but worth a shot.