1 Reply Latest reply: Oct 1, 2013 7:54 PM by Steven Alexander2
Steven Alexander2 Level 1 Level 1 (0 points)

First of all, I have done all the suggestions given at the many communities to no joy(reset pram; smc;reboot; disconnect everything and pwr down for minutes, hours; try on different mac; different cable; etc). I am posting this to pick the brains of those who are having this issue and/or those who may have resolved this or can suggest other "reasonable" courses to take.


After searching through all, if not, most of the posts concerning the issue with MACs not communicating with the Canon Elura 100(and maybe other models of Canon. I don't know if other models are having this problem since I only searched this model), I have found no solution. I did, however, see a pattern over the years of posts since 2006. Prior to Leopard no one was having(that I saw) issues with the camera and their macs not able to communicate...until Leopard 10.5.# came on the scene. Every post using Panther and Tiger did not have an issue from what I saw. When Leopard came some reported issues then they were resolved...others reported issues and did not check back to follow-thru...and then others said they could not get their macs to communicate with the camera. It continued on to Snow Leopard but I only saw two people who actually said it is working. One of them I asked to post their settings for FireWire so that I could see the specs. Maybe some clues can be gathered from it. I just hope he responds. There was also a person who said that the camera worked on an manufacturer installed version of Leopard but not on an upgraded version. I am sure if I knew the actual "problem" then the solution could be found easily but I cannot find what could be the issue. Is it the pin layout? Is it a power/ground issue? Is it a driver issue? Is it a firmware issue on the camera? Is it the firewire itself? Cable?

 

I have read that one Poster used a 4pin to 6pin FireWire cable then purchased a 6pin to 9pin adapter to plug into his mac and that it worked. I don't understand this as it sounds like the pins need to be assigned differently in order for the camera and mac to communicate via adapter. I read another person say "don't do that". What pins are being changed with this configuration? According to the pinout between a 4pin and a 9pin, pins 1 - 4 are the same. I use a 4pin to 9pin to connect my elura 100 to my macbook pro(and imac) but I get the same error message "Unable to List FireWire Devices". The only pins the 4pin does not have that correspond to the 9pin are pins 8 and 6 which are power and gound pins. Since my Elura is plugged into power the power and ground pins are not needed.

 

What I really don't understand is what changed between Tiger and Leopard(including Snow Leopard) that would cause the macs to stop communicating with the camera?

 

I am simply convinced that Canon did not do their homework in making sure their product work with the OS's as the versions progress through the years. And I believe Apple stop listing camera models that work with their OS's.

 

Anyone have something to add?


MacBook Pro, Mac OS X (10.6.8), 17"; 2.2GHz IntelCorei7; 16GBRAM