Skip navigation

Google calendar sync does not work following ios7 upgrade

21914 Views 16 Replies Latest reply: Apr 11, 2014 7:40 AM by lorraine_whitton@yahoo.com RSS
1 2 Previous Next
Glmurphy Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 30, 2013 2:58 PM

I have an iphone 5th generation and I have been using Google calendar sync successfully for a year.  Since my ios7 upgrade, my google calendar will not sync with my iphone native calendar.  I have tried removing my google account and re-entering to no avail.  I have completely restored my iphone from scratch as well.  Nothing.   I do not have any calendars to choose from when I open the iphone calendar.  Is anyone else experiencing this?   Help!?

iPhone 5, iOS 7.0.2
  • rockmyplimsoul Level 5 Level 5 (5,375 points)

    Glmurphy wrote:

     

    I do not have any calendars to choose from when I open the iphone calendar.

    Assuming that you're using the default GMail account profile in your iPhone settings, did you verify that the GMail calendar option is turned ON?

     

    Also, when you open the Calendar app, tap "Calendars" at the bottom-middle of the screen.  Do you see your GMail calendar as an available choice?

     

    If you're not using the standard iOS profile for your GMail account, did you set it up as a CalDAV account?

     

    Finally, note that GMail activity is not "live" (i.e. Push) -- there is a delay according to whatever time you've set up for the Fetch interval.

  • rockmyplimsoul Level 5 Level 5 (5,375 points)

    Well, if you're sure that everything's set up correctly, and you don't have any calendars, then perhaps something is corrupted in your device.  It sounds like you did a full Restore, but did you reload your backup?  If something is corrupted, reloading your backup will just perpetuate the problem so you may have to start over completely, with no backup.  That is a very big hassle I know, but sometimes the only way out of jams like this.

     

    But first, maybe try setting up a CalDAV account for your GMail calendar.  This shouldn't be necessary, but it may get around starting from scratch.  I don't have a link to CalDAV instructions, but it is identical to CardDAV instructions used for syncing Google contacts (but this is no longer needed in iOS 7).  Take a look here, just replace references to CardDAV with CalDAV:

     

    http://support.apple.com/kb/HT4872?viewlocale=en_US

  • rockmyplimsoul Level 5 Level 5 (5,375 points)

    Wow, something's seriously wrong if you have no calendars to choose from. Unless someone else has a bright idea, it sounds like you'll need to restore as new (i.e. don't load a backup).  That will mean re-doing all your settings, preferences, accounts, etc.  Just make sure your contacts are stored somewhere safe (like your Google account).  Good luck!

  • ez G Level 1 Level 1 (0 points)

    This apparently is a common problem and this is the first thread that I found that offered a solution to the problem that I was experiencing with not having my Gmail calendar syncing with my iPhone (after going to ios7). Prior to upgrading, the calendar was working.

     

    I cringed when I read the suggestion of rockymyplimsoul and how glmurphy eventually solved the problem. Starting from scratch and re-entering/installing everything sounded too time consuming.

     

    Fortunately, after trying turning off/on the gmail calendar in settings unsuccessfully, I was able to fix the problem without having to reload everything by simply deleting my gmail account from my phone and then adding it. As a precaution, I turned the phone off then on after deleting the gmail account and before re-adding it. It worked taking a lot less time than reloading everything from scratch.

     

    Thanks rockymyplimsoul and glmurphy for getting me this far!

  • rockmyplimsoul Level 5 Level 5 (5,375 points)

    Sounds like you lucked out, Glmurphy indicated in the first post that the GMail account was removed and re-added with no success.  But deleting the account and re-adding it certainly is a good first step, glad it worked out for you!

  • Jonathan Winters1 Level 1 Level 1 (0 points)

    fwiw -- I used these instructions and it worked perfectly:

     

    1.  sign onto Google Calendar

    2.  go to settings (where the little gear thing is on the upper right of screen)

    3.  Mobile Setup (follow setup steps on that page; verification code, etc.)

    4.  Reboot phone, open up cal, and watch it sync.

     

    Good luck!

  • Porad Level 1 Level 1 (0 points)

    I was having a variation of this problem where my primary calendar was syncing, but secondary calendars (i.e. shared calendars to which I subscribe) were not.

     

    After reading this entire thread, and a whole bunch of other threads elsewhere, here's what worked for me:

     

     

    Visit the following page from your device's mobile browser: https://www.google.com/calendar/syncselect.  Google Apps users can go to https://m.google.com/sync/settings/

     

    Well, I'm a Google Apps user, and I'd tried https://m.google.com/sync/settings/ many times, to no avail.  So, I thought...well, why not try https://www.google.com/calendar/syncselect and see what happens.

     

    I did, it worked.  Go figure.

  • edsmini Level 1 Level 1 (0 points)

    Thanks everyone for the questions and answers.. I have an ipad mini, and was experiencing the same problems. I had downloaded a vendor calendar, so I uninstalled it, I then rebooted, followed the procedure to delete my gmail account and restart from scratch... I ran into other problems after resetting all settings AND after resetting network settings... well then I ran into router problems... I had to reboot my router which helped the entire process...

    Finally, I added my Gmail account again. This time all worked as planned. Thanks again!

  • jerrywood Level 1 Level 1 (0 points)

    I had the same problem and it solved perfectly without needing to reinstall from scratch, didn't even have to restart the phone.

     

    Jonathans answer worked for me, on the desktop

    1. sign into google calendar

    2. top right corner, under your user ID, click the gearbox and choose the last menu item "Mobile setup"

    3. on the next page click "sync with apple devices" to open instructions

     

    which are (on iPhone)

    1. set up a new mail account, use google,

    2. enter your name, username and password

    3. leave the name "gmail"

    4. select "calendar" (and whatever you also use)

     

    if you have multiple calendars or subscribed to any calendars such as sports, TV shows etc. then go to

    https://www.google.com/calendar/syncselect and select them, they will also sync on the iPhone

     

    now you should have your calendar twice, goto calendar app on iPhone, then select only the new "gmail" calendar hust created, watch it sync and then go back to iphone settings "mail, calendars and contacts) and delete the old account / calendar

  • Changyang1230 Level 1 Level 1 (0 points)

    I had a similar problem as you and went through the different suggestions with no success. What did it for me in the end was a simple "reset all settings" under Settings app -> General -> Reset. You will have to reconfigure a few things e.g. wifi password, wallpaper setting, ringtone etc; but you will regain access to your calendar sync.

     

    I guess I had luck on my side - it would have taken me one full day if I were to wipe my tablet and restart from scratch.

     

    (I updated from iPad 2 with iOS 6.1 to iPad Air, used the back up and restore option. The old gmail calendar (which used the exchange protocol) appeared but I soon realised that all the new events I added since then were not synced to the iPad air, i.e. the iPad Air is only displaying all the calendar items that were already there in the iPad 2 but it's not actually synced to the Google server. I then deleted the exchange account altogether (as I realised Google stopped supporting the exchange protocol in new devices), and tried to set up a new CalDAV account via the instructions by Google, and this is how I ran into "no calendar showing" situation)

  • Solv IT Level 1 Level 1 (0 points)

    A quick note - I noticed that once the gmail was set up and you go into the Calendar app, tap "Calendars" at the bottom-middle of the screen.  If your GMail calendar is not available as a choice - pull the screen down (refresh) and it should populate the gmail calendar at this time.  Hope this helps.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.