3 Replies Latest reply: Oct 4, 2013 5:58 PM by Jowindsor
Jowindsor Level 1 Level 1 (0 points)

after switching to comcast my mac is not recognizing my wireless printer, comcast doesn't know anything , hp says to call comcast....


MacBook Pro
  • hands4 Level 4 Level 4 (2,215 points)

    Wireless printers in general can be flaky.  Here are a few stories that may help you.

     

    Are you sure they are on the same network?  Click and hold on the wireless symbol and see what networks you detect.  Maybe adding the cable modem also added a second network.  That happened to me when I changed from DSL to cable.

     

    I had an HP printer that was flakey over my wireless network.  Sometimes it would work, sometimes it took a long time to start printing, and sometimes it just would not print.  It was not an issue of signal strength.  It was in the same room as the router.  I eventually had to plug it into a Mac via a USB cable and share the printer from that Mac to the rest of the house.

     

    When I purchased a new Epson printer I moved the HP printer down to my office on the first floor.  (The router was in another office on the second floor.)  On the first floor, farther from the router, it worked like a champ.  Go figure.

     

    I now have a Canon printer and it has worked like a champ with one exception.  For unknown reasons my MacBook Air stopped queuing to it even though our MacBook could still print to it.  I could to test prints from my MBA but it would not find the printer if I queued a document to print.  I tried all the regular stuff like turning it off and on, rebooting my Mac, deleting and recreating all the printer entires, etc.  Then when we had some electrical work done on our house the power was out for 15 minutes.  That fixed it!  So I suggest unplugging it, not just powering it off to reset it.

     

    If nothing else, revert to my workaround of a USB connection to a Mac close to the printer, if you have a stationary Mac.

  • hands4 Level 4 Level 4 (2,215 points)

    I found some useful Max OS X printer references in another thread:

     

    http://support.apple.com/kb/HT4670

     

    http://support.apple.com/kb/HT3771

  • Jowindsor Level 1 Level 1 (0 points)

    Thanks Hands4! I had a friend help me through it right after I posted this. For some reason my computer wasn't recognizing my network, picking up my daughters across the street! Fixed for now! thanks again