1 Reply Latest reply: Oct 2, 2013 6:32 PM by Barry
Dan Connors Level 1 Level 1 (0 points)

I do my bills on Numbers. I enter the account in one column. I see this problem. I am wanting to enter: Master Card

 

I enter M and I see: Master Card, shown in a dropdown listing. This is the expected behavior

If I type quickly, I will get things like Master Cardter Card, which seems to me to be caused by a delay in Numbers registering the keystrokes.

Numbers is also very slow to react to these events:

Insert a 5 lines below the last line on a form with a footer using Option-down arrow: About 7 seconds

Move to the next column after making an entry and then pressing tab: about 3 seconds

 

The table I'm working in has 4750 rows. The entire file is 672KB. Machine is MBP Retina 2.9GHz i7 w8GB RAM, all updates loaded.




MacBook Pro with Retina display, iOS 6.1.4, 13" Late 2012
  • Barry Level 7 Level 7 (29,210 points)

    Hi Dan,

     

    First issue: If you're typing all of "Master Card" auto fill is a feature you are not using. Turn it off.

     

    'Also' issues: Numbers is slow with large (and even moderately large) tables. It is further slowed by including multiple header and footer rows.

     

    That is likely (at least partially) due to tables being recalculated whenever there's a change to a table—a behaviour that cannot be turned off.

     

    I don't see an easy solution, although you might find the situation alleviated by splitting your table into six month or quarterly tables.

     

    Let Apple know you'd like this behaviour changed to speed the application; Provide Numbers Feedback using the menu item of that name in the Numbers menu in Numbers.

     

    Regards,

    Barry