2 Replies Latest reply: Dec 4, 2013 10:53 AM by mbhenre
Agent Vanilla Level 1 Level 1 (0 points)

The application update process is flaky since updating to IOS7. Note, since I've had a couple of bad updates (Google Authenticator, 1Password, DrudgeReport etc) since IOS7 came out, I've disabled the auto-app update because I want to review the release notes before clicking "UPDATE".

 

1) I'm getting ghost icons like the one seen in this separate post. To my knowledge the ghost icon problem was a known IOS7 beta problem, but I waited for the official IOS7 launch and then for a few more days before updating my phone's IOS.

 

https://discussions.apple.com/message/23261962#23261962

 

 

2) When I see update notifications, I press either "Update All" or "Update", and the apps aren't seemingly updating reliably. The "Update" box next to the apps turns into a blue circle, the progress indicator goes round and round, sometimes I see a blue square in the center of the circle, then the button goes back to "Update" when I expect that it should turn into "Open". Sometimes it works, sometimes it doesn't. I've fussed around by killing the app update process, restarting, doing one app at a time, clicking into the app detail then pressing "Update". I can't figure out what the issue is and there isn't enough information shown on screen to further diagnose.

  • 1. Re: IOS7 Updating apps flaky (ghost icons & update failures)
    dmcstern Level 1 Level 1 (10 points)

    I'm having the identical problem on my iPhone 4 after upgrading to IOS 7--no ability to update apps or download new apps.  Here is what Apple tech support emailed to me:

    I understand that you are unable to download or update applications after updating iOS7 on your iTunes. I know you must be eager to get this resolved and I will be happy to help you today.

     

    ... to help you better with this issue I would request you to please try this steps given below to resolve your issue.

     

    Please follow this steps:

     

    1) Double tap the home button

    2) Hold down on an icon

    3) Tap the red "X" on iTunes, and the App Store.

    4) Tap Settings > Store > Tap your Apple ID, and choose sign out

    5) Tap Settings

    6) Tap General

    7) Tap Reset

    8) Tap Network Settings

     

    Once it has been closed with multi-tasking, and you have rebooted the device in the network settings reset, please sign in, and try again. 

     

      Howevr, if you are facing the same issue than for this issue, you may need to call our AppleCare technical support team. A technical Advisor will be able to tell you about Apple's complimentary and fee-based support. The technical Advisor can also assist you in determining what option might be most helpful to you in this case.


    Mildly amusing that the instructions for force-closing a program are the IOS 6 instructions, which do not work on IOS 7. 

     

    Otherwise I'm having a little success with this.  Some apps (not all) are updating. It seems that a few more apps update each time I go through the process (close everything, sign out, and either reset or reboot, then go to the app store, sign in and try to update all).  So far it has been a very lengthy, iterative process. 

  • 2. Re: IOS7 Updating apps flaky (ghost icons & update failures)
    mbhenre Level 1 Level 1 (0 points)

    Thanks, dmcstern.  I had several updates to do and couldn't figure out the blue circle with the square in the middle!  Some of them still upated but I was left with 5 that did not and would not, so I tried your fix and it worked.  Except of course for closing the App Store app!  I mean...duh! 

     

    I appreciate you posting this fix.  The remaining apps are updating as we speak, though the circle/square still exists - it is gradually getting thicker all the way around!  Yay, progress!