Previous 1 2 3 Next 30 Replies Latest reply: Apr 6, 2015 9:42 PM by DARinCanada
Jaytee93 Level 1 (0 points)

Since I upgraded my Iphone 4S to iOS 7, i can't control my music with the steering wheel controls anymore with the special (and original) USB Hyundai cable.

It was working perfectly before...

Any solutions?


iPhone 4S, iOS 7
  • norm123 Community Specialists

    Hello Jaytee93

     

    Check out the article below for troubleshooting that connection with your car.

     

    iOS: Troubleshooting car stereo connections

    http://support.apple.com/kb/TS3581

     

    Thanks for using Apple Support Communities.

     

    Regards,

    -Norm G.

  • Paul Conaway Level 3 (885 points)

    jaytee94, Have you checked with your local Hyundai dealer? They maybe aware of a solution

     

    Paul

  • jsf321 Level 1 (0 points)

    I am having the same problem - toyota prius. The built in ipod/iphone cord now triggers the "non original cable" message - so no charging and no head controls.  This is really bad!

     

    Joey

  • graemegrov Level 1 (0 points)

    Have a similar problem with my recent Elantra. Despite selecting song currently playing, when connecting iPhone to car, song ALWAYS reverts to first song. No such problem with ios6.3.

  • Streetscrapper Level 1 (0 points)

    Same problem with my Nissan. Given the number of people who are experiencing the same thing, it seems hard to believe that the problem would be with the car - especially when there was no problem before the update!

  • Nicole Beaudet Level 1 (5 points)

    I have the same problem with my Nissan Murano.  Last week worked perfect, now I can't control my music after the upgrade.  I have tried my iPhone, iPad, and iPod and non of them work.   So it is the software. 

  • Punisher138 Level 1 (0 points)

    I am having the same issue with my iphone 4S with ios7 in my 2012 Hyundai Accent.  Never had any issues until "upgrading" to 7...

  • josephfromcalgary Level 1 (0 points)

    This seems to be a recurring theme with Apple iPhone updates.  The updates seem to change some of the code that controls Bluetooth functions.  Without updates to your hardward (in my case, JVC and Panasonic car audio decks), the update renders some of the functionality useless, in particular the audio controls for music.

     

    The 'fix' is to use a now 'broken' piece of hardware until the manufacturer makes available a firmware update for the audio unit, have it removed from the vehicle, take it in to a service center and have the firmward installed, then pay for a re-instal.  Well, maybe you can do it on your own, but the updates are not available for a while, if ever, so.... 

     

    All I know is that the exact same thing happened to me with the previous update and I'll NEVER update my iPhone again for that reason.  Major hassle.  I'd rather have the old OS and a functional phone/car audio/bluetooth system in my car.

     

    It would be nice if there was some backward compatibility built into these updates from Apple, but they seem to rule the roost.  Incidentally, if you download the new version of IOS, apparently you cannot un-install it to get back to normal.

  • paulfromwinnipeg Level 1 (0 points)

    I have the same problems with my 2012 Nissan Murano.  Before the iOS7 upgrade, everything worked perfectly, now I can't control my music after the upgrade (via USB), and the phone will actually crash hard (total black screen) after playing music in the car for a period of time.

     

    The phone has also frozen / crashed twice in 2 days since the upgrade, and has NEVER crashed before.

     

    This is definately an undocumented feature of iOS7 - very disappointing Apple, and to top it off, I can't roll back to iOS6.

     

    So I have a phone that crashes, won't pair reliably with my bluetooth on a 1 year old car, and won't play music.

     

    Pretty expensive paper-weight. Guess I buy a new Andriod and throw the iPhone in the river eh Apple? 

  • bangarang2 Level 1 (0 points)

    I also have this problem with my 2009 Hyundai Sonata gls. My wife and I both have the 4s. My phone is running the latest iOS 7.04 and she is running 6.1.5. Her phone works fine with the Hyundai iPad adapter (music / charging / car controls all work) but when I plug in my phone nothing happens, not even a charge. This appears to be Ana iOS issue not a Hyundai issue. Please fix!

  • rpbf Level 1 (0 points)

    Same problem with iPhone 5S and 4, both with iOS 7.0.4, crashing with my Hyundai Azera, with factory Infinity audio. The music stops playing and beeps like if I had disconnected and reconnected it. Neither controls in the head unit or steering wheel working, not even the title name appears correct.

  • graemegrov Level 1 (0 points)

    I'm not sure Apple plans to fix this, as three IOS updates have come and gone with no fix in sight for what many of us regard as a major issue.

  • bearbeme Level 1 (0 points)

    I just bought a 2013 Elantra and was having problems getting my ipod and iphone5 with the IOS7 update to work properly using the radio controls to control the devices.  The devices would play through Aux but I could not control them through the radio controls.  I had to control the music through the device itself.  I was connected using the Hyundai adapter and an Apple 30 pin to Lightning plug adapter.  I stumbled upon a post about the Veloster having problems with the Hyundai adapter working and to use the original Apple charging/syncing cord instead.  I tried using the original Apple cord and now I have clear sound and full function of the ipod 7th gen and iphone 5 through the radio controls.  I know it won't solve the bluetooth problems but it is wirth a try if you are connected using the Hyundai cord. 

  • oski65 Level 1 (0 points)

    Read bearbeme's post and had the same experience.  All Lightning adapters apparently are not the same!  My iPhone 5 is running IOS7 and I could charge my phone and synch to my laptop using a cheap Lightning adapter.  Neither the phone nor my 7G Nano iPod would connect to the car audio using this adapter.  Bought an authentic Apple adapter and everything works...playlists on the navigatin screen, audio controls on the steering wheel.

     

    Doesn't seem like the problem is IOS7.  There's something proprietary in the Apple connector, which is why it's $30 versus a $4 knockoff?

Previous 1 2 3 Next