Previous 1 2 Next 22 Replies Latest reply: Mar 13, 2015 11:45 PM by RedTex Go to original post
  • Maire Lapalme Level 1 Level 1 (0 points)

    Hi Nettan03

    Thank you for helping. I checked it out, Bonjour ran on both my computers. There is more to it. I'm on the actual v.11, too. So let's sit and wait.

     

    @all: I bought Airfoil to get around it. Works fine for music but watch out on movies, the sound comes with delay to the pictures. Spent $25 on that crap before checking out on the trial version... argh!

  • Mike__D Level 1 Level 1 (0 points)

    You asserted that "Security and Windows Firewall are not an issue."  Can you elaborate on what you meant by that?  Do you have no firewall running?  Or are you using a different firewall? 

     

    I had the exact same issue you describe - my Windows laptop couldn't find my Airplay speakers, even though my iPhone and Mac had no issues.  It turns out that the firewall was exactly my issue (I have Symantec Enterprise Protection running on my system providing the firewall).

     

    There are a few less common ports and protocols used by Apple products (there's a complete list of what they use here).  In my case, the problem appeared to be the default blocking of UDP port 5353 (Multicast DNS) and TCP port 3689 (Digital Audio Access Protocol).  I configured two firewall rules to allow local access to those ports from my local subnet, bumped them to the top of my rules list, and all my Airplay issues went away (it also solved an issue where the Airport Utility couldn't find my Airport Express from my Windows box). 

     

    Disclaimer: you can expose yourself to a lot of Bad Stuff mucking with firewall rules if you don't know what you're doing, so read up/find an expert if you've never configured a firewall rule before.  Also, there are some security concerns around MDNS if you configure it wrong. I accept no responsibility for your getting pwned. 

  • Jonnabas Level 1 Level 1 (0 points)

    I have the same, funny thing though I managed to get the icon up and did play my movie on TV via Apple TV, but the next move did not get the Icon and trying with the first movie again I couldn't get Air Play Icon up there any more... this is .. æhh .. a lil special or???

  • doyleniemann Level 1 Level 1 (0 points)

    No, that is exactly the problem. 90% of the time, itunes won't recognize the airplay devices -- either my Apple TV or the Apple network extender. But every once in a while, it will. No apparent reason why it works then and not otherwise. Nothing is changed that I can see. It is very frustrating and makes me not want to use airplay.

  • RedTex Level 1 Level 1 (0 points)

    Enable "Network discovery and file sharing" in windows.  Often can be accessed through the network icon under the start menu, but also Network and Sharing Center - Advanced sharing settings.

    I did not have to have public folder sharing on.

     

    This is after turning firewall off and on, ipv6 off and on, adding rules for mdns and daap in firewall ports, etc.  It is replicatable - turn off network discovery - the icon goes away.. Turn it on, the airplay icon comes back.

     

    In the end, I just reset windows firewall to the defaults (network and sharing center > windows firewall > restore defaults), added itunes as an app to the firewall (Allow a program or feature through windows firewall) and then enabled "network discovery" and "file sharing" as above.  This seems to work fine.

     

    The problem had come about because I turned off homegroup and a bunch of other network setting at some point, but locking everything down seems to turn off airplay as well.

     

    Message was edited by: RedTex

  • nicreal Level 1 Level 1 (0 points)

    try this it works for me every time

    quit itunes

    open network and sharing center on PC

    click on change adapter settings

    right click on adapter- and disable adapter

    right click on adapter and enable adapter

    start itunes

    BAM the airplay devices work

     

    I find that after a few hours the airplay connection fails, I repeat this process and it works fine

    now if only I could get my wife to do it so she is not so frustrated with the airplay network in our house.

     

    -eecummings--

  • thainsd Level 1 Level 1 (0 points)

    Found an answer on another thread that worked for me: Re: w7 64-bit, iTunes 11.1.1.11 no airplay no remote access

     

    Under the Network options, Change Adapter Settings / right click in the network card and select properties, UNCHECK the Internet Protocol Version 6 (TCP/IPv6). Restarted iTunes and it all worked.

  • RedTex Level 1 Level 1 (0 points)

    Currently iTunes 12.1.1.4 - have done some more investigation on this issue, and how it can appear.

    I have 2 windows 7 machines, one is x64 64bit and the other is 32 bit.

    Both are laptops with multiple interfaces, one has a built in mobile broadband.

    I have an airport express and an appleTV both on the network.

    It is a fairly complicated network, with the router running OpenWRT, and some wireless bridges and smart switch as well.  I also have a linux server running Firefly with a shared itunes library and sync several iDevices.

     

    With various revisions of itunes the airplay has appeared and disappeared, and the problem reappeared with the current version.  I tried several troubleshooting permutations, and different things (network config, firewall, homegroup, etc.)  Also lately, the shared libraries and wireless sync (home sharing) was hit or miss, seeming to be there sometimes and sometimes noe.

     

    The one common factor has been ipv6.  Turning it off completely works.  iTunes seems to play better with windows firewall now - default settings work fine, no need to add specific ports anymore.  THis is also tested by turning the firewall off and seeing if airplay reappears..   However, I wanted to find a fix that worked with ipv6, since I actually use an ipv6 internet tunnel.   IT was possible to start the machine, launch itunes, quit itunes, turn off ipv6, turn on ipv6, then launch itunes again, and it worked.  However this is clunky.

     

    What I found is that the problems sometimes seemed to appear when turning on and off the homegroup settings as in my previous post.  However, windows uses ipv6 for the homegroup as well, and this was interacting with bonjour sometimes.  Turning off ipv6 as a protocol for the network adaptors brought back airplay on all devices, repatably.  However I actually want to use ipv6, and realized that lately the problems appeared more often since I set up an ipv6 tunnel to the outside world.  The devices are auto configuring ipv6 via dchp, however, oddly enough it was preventing airplay. 

     

    There are some oddities in the windows 7 implementation of ipv6, and it appears that bonjour gets confused if you have a working ipv6 route alongside ipv4 networks This may be related to the way Windows 7 sets up an auto generated pseudo random ipv6 address before getting the real one from the server (and I suspect Bonjour is locking to the original address)

     

    to work around these windows oddities, You can disable the ipv6 4941 behavior by issuing in an "run as administrator" command shell the below:

     

     

    netsh interface ipv6 set privacy state=disabled store=active

    netsh interface ipv6 set privacy state=disabled store=persistent

    netsh interface ipv6 set global randomizeidentifiers=disabled store=active

    netsh interface ipv6 set global randomizeidentifiers=disabled store=persistent

     

    This seemed to work for me in all test cases, with the default firewall config, and having joined a homegroup. 

     

    In addition, I needed to update the drivers for my intel wireless network card to the latest (from intel web site) - may need to reissue the above after updating NIC drivers.

Previous 1 2 Next