1 Reply Latest reply: Oct 3, 2013 5:21 PM by plums4
plums4 Level 1 (5 points)

Running OS 10.8.5. Message "This version of AirPort Utility doesn't support this base station. Go to AirPort Service...for more info" pops up. My wireless internet networks are fine but I am trying to network a printer and a few other mobile devices and I need to use the AirPort Utility.  Anyone have an answer for me?  I believe I am running on the latest for what is necessary and am not sure why this is happening.