5 Replies Latest reply: Oct 7, 2013 10:02 AM by BDAqua
Greg Flamer Level 1 (5 points)

I have a macbook 13" Aluminum (late 2008).  It originally came with OS 10.5.5 and a 250 GB hard drive.   I have upgraded over the years to the current version of mountain lion OS 10.8.5. I decided it was time for a bigger HD and bought a 750 GB Travelstar HD (7200 RPM 16 MB cache).  I had the Genius Bar folks assist me with backing up my original HD to a 1 TB external HD. I tested the external drive after backup and it booted perfectly on its own.


I self installed the new internal HD.  I booted up the computer using my original OS 10.5 installer disks as that is all I had. It took me to disk utility where I was successfully able to format the new HD. I followed all the online instructions of partitioning, picking 1 partition, picking the OS X Extended (journaled) and making sure the GUID is chosen under options.  I then plugged in the back up drive.  I used Restore choosing the external drive as the source and the formatted new HD drive as the destination.  After 3 hours, the transfer of data appeared to be successful. I verified the new HD and there were no problems.


I then rebooted the computer thinking the hard drive was now up to date and would start normally. Instead the Mountain Lion OS X Installer screens came up.  I wasn't sure why I needed to go through this again but thought that since at least it was now mountain lion and not leopard that something had gone right. I proceeded through the steps of restoring from a time machine backup.  My external drive was picked up as was the backup versions to select .  That brought me to the Select a Destination screen.  It says "searching for disks". It is stuck here. It's been searching for 2 hours with no signs of progress. 


I should note that I've tried every other option from the Mountain Lion Utilities menu. I tried to reinstall mountain lion. It stops at the select where you want to install OS X screen.  When I try to choose the new HD it says "this disk is locked" and won't let me go further.


I tried going back to disk utility to erase the drive and start from scratch. It won't let me erase or re-partition the HD stating that it cannot be done because "couldn't unmount disk".


I tried rebooting the computer holding down command R to start the recovery Mode. Still wouldn't let me erase the HD or repartition.


I've rebooted at least 10 times with the external drive plugged in, not plugged , holding down the alt key, etc


I have read all forums and feel like I've tried everything. The disk utility clearly recognizes the internal HD and I can see that files were copied as the available space has gone down by the amount of data I have. The fact that the mtn lion installer came up when I don't even have any mtn lion installer DVD means something must have copied over correctly.


Thanks for any other ideas...I just want my computer to start. 

MacBook 13"Alum (Late 2008), Mac OS X (10.5.6)
  • BDAqua Level 10 (122,202 points)

    Hi Greg,


    Have you tried booting from the external drive & using Disk Utility there on the Internal again, that isn't clear out here.

  • Greg Flamer Level 1 (5 points)

    Thanks for the reply.  I did try booting from the external drive after the new HD install and had the same problems.  Searching for disks, unable to erase or re-partition due to "couldn't unmount disk" errors.  I am at the genius bar in a few minutes.  If they can solve it I will post the solution...Thanks again.

  • BDAqua Level 10 (122,202 points)

    Please do!

  • Greg Flamer Level 1 (5 points)

    So the genius bar folks did solve the problem.  They said that when I restored the contents of my external drive to the new hard drive that all it did was copy it as an image file.  I apparently should have cloned the contents instead of using the restore option out of disk utility.  So I basically had to re-install Mountain Lion from scratch.  I was unable to do  this at home as I did not have re-install DVD's.  Once Mountain Lion was re-installed, it walked me through step by step to use my external back up drive (time machine back up) to get it functioning.  Now happily using the laptop with 750 GB. The extra space is lovely and I can finally dump the movies and photos that have been clogging up all my other devices....Thanks.

  • BDAqua Level 10 (122,202 points)

    Great to hear, thanks & enjoy!