Previous 1 3 4 5 6 7 Next 103 Replies Latest reply: Nov 23, 2015 3:25 AM by lineberger54467 Go to original post Branched to a new discussion.
  • funkymelodies Level 1 (0 points)

    We have 2 iPad 2 in our home but only one of them had the WiFi problem. I had a SMC modem bridged with a dlink-655 and the signal would constantly drop.  Reading other forums I discovered that it could be the issue of the modem itself so I swapped the SMC for a Hitron modem still bridged with dlink-655 and haven't had issues since.

  • dvnonstop Level 1 (0 points)

    I just hit the same issue, iPad 2, iOS 7 upgrade, no wifi.


    I found that I actually DO have wifi, but only within 10 to 15 feet of my router. Which seems to indicate packet loss / interference.


    I took the iPad to a local Apple store - on their Airport wifi network, it worked fine, with good range. The router at home is an ISP rebranded Netgear.


    So the iPad hardware is clearly still working fine, but something in iOS 7 has created an issue with the Netgear. Maybe it is putting out a different signal strength, maybe it’s doing something different that is causing crosstalk or interference, maybe there’s now a timing issue – impossible to know without being able to diagnose at a much lower level. The final proof of it being an interoperability issue was that I bought an Apple Airport Express, cabled it to the Netgear router at home, and voila, the iPad 2 now has full wifi reception around the house again via the Airport.


    My suspicion would be that there are wifi chips in some of the older Apple devices that aren’t quite behaving as they used to under the new iOS. Note that I have newer devices on iOS 7 (iPhone) that have been talking to the Netgear router fine. It’s kind of impossible to know if either device isn’t truly compliant to standards, or what else the issue might be, without being diagnosed at a lower level, which a consumer can’t do.


    If you do have this issue, I would suggest trying the following:


    - You can reset network settings on the iPad, and reset your router. Not likely to fix it, but resetting everything first always worth a shot.

    - Upgrade the firmware on your router if you can (mine is ISP controlled, so I couldn’t try this)

    - Set the router to 802.11n only. I suspect this was the difference between the Airport Express (802.11n) and the Netgear (802.11b/g/n). I can’t lock my router to 802.11n only, and I can’t work out how to tell which band it connects to on the Netgear.

    - Turn off Bluetooth on the ipad (can interfere with 802.11b/g, some users reported success with this, didn’t work with me).

    - On the router, experiment with wifi multimedia settings (Power Save off, WMM off). Didn’t work for me – if it works for you, I’d try the router firmware upgrade if you didn’t already

    - On the router, experiment with bandwidth and channel settings (again, might assist if an interference issue, but didn’t work for me)

    - Jailbreak your device and restore the previous iOS (your old device is no longer under warranty anyway, but not recommended for the inexperienced)

    - Install an Apple AirPort device


    With testing on more devices, the issue could likely be narrowed further, but the bottom line is there’s an incompatibility here, and if you have this issue you’re going to need to upgrade/replace your router, or install an Apple Airport device to put your ipad back on the network.

  • Jake Bullet Level 1 (0 points)



    I have had the same problems and have been researching this issue for seemingly days. I have however just got my iPad 2 back on wifi...


    I tried all the Resets, Forget this Network, type advice listed on various posts, none of which unfortunately worked for me.


    I believe the problem is with DHCP and my iPad trying to use an IP address that either isn't available from my router, or isn't working for some reason.


    I logged in to my router (BT Infinity but they all the same I think), and searched the connected items (and old redundant items). I found an IP address that wasn't being used (I actually deleted an old redundant device and used the IP address from this)


    I then went to my iPad 2 Settings > General > Wifi


    Select the Static Tab (rather than DHCP) and input the IP address there.


    That is all I did, and Hey Presto Back online.


    I know first hand how frustrating this issue has been for me and seemingly thousands of others, not a perfect permanent fix perfect but it worked for me and it is certainly worth a try if like me you have exhausted the other possibilities.


    In the meantime Apple, please fix this issue properly!


    Good Luck

  • victorfromdublin 13 Level 1 (0 points)

    I am writing this  using my sons I pad 2 which is getting wifi signal perfectly, thankfully he has not updated his software still on 6.1.3 however my IPad 2 was ''updated"  to 7.1.2 some weeks ago  it is now useless cannot get signal further the 2 mtrs away ( it is actually beside me without signal while i have 4 bars on the iPad running 6.1.3)  from the router

    I notice so many posts on this & Apple seem to be ignoring the problem they have created why?

  • victorfromdublin 13 Level 1 (0 points)

    Tried Turing off blue tooth did not work for me

  • Texas Mac Man Level 8 (46,560 points)

    victorfromdublin 13 wrote:


    I am writing this  using my sons I pad 2 which is getting wifi signal perfectly, thankfully he has not updated his software still on 6.1.3 however my IPad 2 was ''updated"  to 7.1.2 some weeks ago  it is now useless cannot get signal further the 2 mtrs away ( it is actually beside me without signal while i have 4 bars on the iPad running 6.1.3)  from the router

    I notice so many posts on this & Apple seem to be ignoring the problem they have created why?

    You tagged onto an older post. If you want an answer to your specific question, you need to create a new post. By creating a new post, you will receive emails when helpers post responses.


     Cheers, Tom

  • elizabea Level 1 (0 points)

    This is the exact same problems I am having.  Very frustrating!

    Since my ipad is pretty useless right now.  I have been borrowing my

    boyfriends Microsoft Surface Pro and I love it!  We have 2 HP pc, HP

    laptop, the surface pro wh have no issues and 2 useless ipads. If this doesn't fix the problem

    I am switching!   

  • LotsofCoppers Level 1 (0 points)

    Hey ppl, I've found an interesting solution to internet drop outs. I have ipad 2 (drops) iphone 4 and 4s slow connection and an ipad 3 with slow internet. All the solutions above in this topic didn't help me to fix the problem. I found a new one just by a coincidence and it fixed all my problems for all devices, 2 days pass and no drop outs so far.



    1) Go to your router settings by using your browser on (I have tp-link router) enter login and password usually it's "admin".

    2) Go to Wireless settings --> wireless settings or something like that depending on your router system. There you should find setting for router "mode". You need to change it from 11bgn mixed to 11bg.

    3) Finally you have to restart your router in order for an update to take place.


    It worked for me and for my friend who uses same type of router and an ipad 2 as well. It seems that after iOS update wifi doesn't recognize "N" router and works on older B and G setups.


    In addition you can forget your network in ipad settings and reconnect using your password.


    Keep up this topic if it helps.





    I just want to bump this up b/c this post saved our Christmas!  My son received  brand new Air 2 that would not stay connected to our wireless. It was so frustrating.  My other son received a Mini and had no problems at all staying connected.


    I tried all sorts of fixes and was just about to give up and look into sending it back... (what a huge hassle that would have been!) and I so fortunately just happened to read this post.  This worked!!  Hooray!

  • lineberger54467 Level 1 (0 points)

    I Tried all suggestions. Hardware and software are up to date. Still dropping connection after about 30 seconds connect time.

  • MichelPM Level 6 (10,625 points)

    If you are still on iOS 7 and you are still exeperiencing WiFi issues after all of this time, why don't you just upgrade to iOS 9?


    Best and most reliable way to upgrade your iPad to the latest iOS version.

    Ideally, your iDevice should maintain a minimum free storage amount of 4- 6 GBs or greater on any iDevice (the more free space, the better) , plus, more than 50%-60% battery status to ensure proper operation, as well as, to ensure the possibility of a successful iOS upgrade/update installation.
    In addition it is best to upgrade an iDevice connected up to a computer running iTunes with you iDevice sync'd and backed up through iTunes rather than Over The Air (OTA) using a wireless WiFi connection.

    First, connect your iPad to USB and sync and backup your iPad to iTunes.

    Then disconnect/eject your iPad from the computer.

    From just the iPad, in the Settings App under the General setting erase and reset your iPad to completely erase your iPad 2 and then, again, from the iPad, set it up as a new iPad setup to factory "out of the box" operation.

    Then reconnect your iPad 2 to the computer and make sure to cancel the syncing, by tapping the small X to the left in the top  center iTunes display box.

    iTunes should detect your iPad and ask if you want to update to the latest iOS version.

    Select OK. If iTunes begins to try and sync, again, cancel the sync. Let the update continue until it loads into the iPad.

    May take anywhere from 30 minutes to an hour to update the iPad.


    Once your iPad is updated and your iPad appears in iTunes, again, CANCEL the sync, once more.

    Select Restore from Backup instead and pick your last backup to restore back to your iPad 2.

    Once the restore is complete, finish setting up the iPad and let it sync back to iTunes you can either cancel the sync, again or let it backup, again.

    Then disconnect the iPad.

    Do one hard reset of your iPad by holding down both the Home and sleep/wake buttons simultaneously until your iPad goes to black and restarts with Apple logo, then release the buttons.

    Once your iPad is back to the Home screen,

    In the Settings App under the General tab, to the right under Spotlight sesrch, try disabling the search under apps that really do not need a search, like some games, remotes, apps that really do not need to be searched, etc., to reduce the list for Spotlight to search.

    Try turning on Reduced Motion.
    This is found in the Settings App in the General tab the left panel.
    In the right panel look under Accessibility, the look for Reduce Motion and turn this feature "On".
    You should see an appreciable performance increase on all iPad 2, 3 and 4 models.

    In the Settings App under the General Tab, in the right column, look for Background App Refresh and turn this setting to "off".

    I update ALL my iDevices connected up to my iMac and sync'd over USB through iTunes.
    My Mom"s and Wife's iPad 2s were still both on iOS 7.
    I have NEVER, EVER had an issue with any iOS updates.

    Good Luck!

  • lineberger54467 Level 1 (0 points)

    I am using 9.1......

  • MichelPM Level 6 (10,625 points)


    Wasn't sure.

    Have you tried the previous Poster's suggestions with modifying your WiFi MODEM/router settings?

  • lineberger54467 Level 1 (0 points)

    JJust tried the suggestions. No effect.

    AS part of the problem solving, I have an airport express as my main router from my broadband and iMac, and a second airport express located in the room upstairs, about six feet above the main router, to which my speakers are connected. Could there be interference there?  Both are second generation airports.

    Thanks for your help!!

Previous 1 3 4 5 6 7 Next