5 Replies Latest reply: Nov 2, 2013 4:15 AM by sanjampet
ikenet Level 1 Level 1 (0 points)

This morning I downloaded and installed Security Update 2013-004 onto my iMac running Mac OS X Lion 10.7.5 and now i cannot unlock any preferences even though i am an Admin and using the correct password and other users are prevented from logging in at user login screen. Anyone have the same issue?  Can someone help?


iMac, Mac OS X (10.7.5)
  • 1. Re: Unable to unlock preferences after Security Update 2013-004
    ikenet Level 1 Level 1 (0 points)

    Wow! Is the apple user community is stumped by this or am i the only person that has experienced this?

  • 2. Re: Unable to unlock preferences after Security Update 2013-004
    Eric Root Level 6 Level 6 (16,200 points)

    I have asked the hosts to relocate your post to the Lion community, where hopefully you'll get a better response.

     

    10.7 Lion

  • 3. Re: Unable to unlock preferences after Security Update 2013-004
    LilyLC Level 4 Level 4 (2,620 points)

    What have troubleshooting procedures have you tried?

     

    Try verifying your hard disk with Disk Utility in the Utilities folder.

    After launching Disk Utility, in the left pane, click on the name of your hard disk.

    In the right pane, click the First Aid tab and then click the Verify Disk button.

    If the test result is OK, then click the button to Repair Disk Permissions.

     

    If the Verify Disk test result reports errors, you will need to reboot the computer in Lion Recovery HD and use Disk Utility there to repair the disk. See instructions by Kappy.

     

    HTH

  • 4. Re: Unable to unlock preferences after Security Update 2013-004
    ikenet Level 1 Level 1 (0 points)

    @LilyLC - Thanks for the pointers.  I'm not a Mac person so i need whatever guidance you can provide.  I followed your instructions. This is the very first thing i've tried to fix this and sad to say it didn't work. After running Verify Disk it came back OK, then I clicked Repair Disk and the 1st line reads

     

         "Warning: SUID file  “System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAg ent”  has been modified and will not be repaired.

     

    Then it listed several :

     

         Permissions differ on “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resourc es/Dutch.lproj/DisplaysPref.nib”; should be -rw-r--r-- ; they are -rwxr-xr-x .
         Repaired “System/Library/PreferencePanes/.Displays/V1/Displays.prefPane/Contents/Resourc es/Dutch.lproj/DisplaysPref.nib”

     

    The paired "Permissions differ" & "Repaired" log went on for a long while... I lost count after about 400 and it went on for a very long list and ended with Permissions repair complete.  I don't know if this is normal or indicative of a problem. Anyway, after doing this I restarted  hoping I'd be able to login at the user login screen, but no dice.  I tried logging in for myself and a couple other users. For each user including myself it recognizes the entry of the correct password, the screen goes to white and finally returns to the user login screen.

     

    Since i was getting nowhere with user logins i clicked the "Restart" button on the bottom and after restarting it logged me directly into my desktop (I suppose because I'm the computer Admin).  When I go to System Preferences to the "User & Groups" option and click on the lock at the bottom left to unlock ability to make changes it brings up the authentication Admin Name & PW to which i enter and it accepts (no shaking as with wrong password) but lock never unlocks.

     

    Last comment, i thought I'd download the newer version of OS X Mountain Lion thinking maybe an OS X upgrade would reset everything, but the same thing as above happens with the User & Groups menu - it flashes but never starts the software install.

     

    I know the solution will probably be something simple. I'm perplexed  and frustrated with the difficulty to find the fix.  Sorry for the long description, but i'm hoping the detail will spark ideas leading to resolving this issue.  Thanks & Please Help!

  • 5. Re: Unable to unlock preferences after Security Update 2013-004
    sanjampet Level 5 Level 5 (7,550 points)

    Next thing to try is a SMC reset

     

    http://support.apple.com/kb/HT3964

     

    Follow directions for your machine, try a PRAM/NVRAM reset as well (link at bottom of page)