8 Replies Latest reply: Oct 24, 2014 6:53 PM by Peter Inova1
Aeropl Level 1 Level 1 (0 points)

I imported some songs into iTunes. They don't have an iCloud icon at all. Why aren't they uploading into iCloud?

 

P.S. Apple, it would make sense to add this information to this page: http://support.apple.com/kb/TS4124

  • randers4 Level 9 Level 9 (62,555 points)

    Uploaded songs won't show a cloud symbol in the iCloud download column.

     

    Open iTunes and clidk on Music under Library.  Then go to View>Show View Options and check "iCloud Status" in the Music section.  Then look at you song list.  Uploaded songs will say "Uploaded" in the iCloud status column.

  • Aeropl Level 1 Level 1 (0 points)

    In the past I have had no problem with songs I have imported into iTunes. Now I am trying to import mp3's of my band which are 255 kbps VBR files. I tried right-clicking and "converting" the songs to aac within itunes. The duplicate acc files have the iCloud icon, but there is the error icon for "duplicate" file (see the page referenced above) . I am just trying to get these into iCloud so i can listen on my iphone.

  • randers4 Level 9 Level 9 (62,555 points)

    I wonder if you might need to delete the originals from your library in order to get the AAC versions to upload rather than being seen as duplicates.  You might try deleting the mp3's (keep on your computer), then going to Store>Update iTunes Match to see if the AAC 's will upload.

  • Aeropl Level 1 Level 1 (0 points)

    view options.JPGIf I go to View-->Options I only see these three options: sort albums, group compilations, and artwork size. There is no option for "iCloud status".icloud icons.jpg

    And here is a screenshot of the iCloud icons (and lack of) that I'm talking about; I have to admit I've about had it with iTunes. I'm running v11.1.1.11 and just trying to get songs so I can have them so I can stream on my phone.

  • randers4 Level 9 Level 9 (62,555 points)

    Change to Songs rather than Albums, then go to View>Show View Options and you should see this:

     

    Screen Shot 2013-10-07 at 11.08.42 PM.jpg

     

    Which will then add this:

     

    Screen Shot 2013-10-07 at 11.10.48 PM.jpg

  • Aeropl Level 1 Level 1 (0 points)

    Thanks. I tried deleting the duplicates but that didn't help. However, I started from scratch and imported the songs into iTunes as 256kbps constant bit rate mp3 files. That fixed the problem. Apparently iCloud wasn't accepting the variable bit rate (VBR) files. A suggestion for Apple: Please have more descriptive error messages for the iCloud status, as that would have saved a lot of headache here.

  • whiteboy_slim Level 1 Level 1 (0 points)

    If iTunes doesn't like VBR files, why is the default for importing from CD 256kbps VBR?

  • Peter Inova1 Level 1 Level 1 (0 points)

    This page of info seems to have changed recently, or else I'm just dense.

     

    I, too, am having problems with songs into the cloud. In my case, I'm generating the song files and putting them into iTunes from GarageBand. Most of them upload into the cloud in some mysterious manner. I don't do anything special, they just are there, and I can listen to them on my iPhone. But occasionally, a file just doesn't make it. How do I FORCE a file to rise up into the cloud?

     

    Also, every so often, a double cloud icon appears with a note telling me that there is a duplicate file so it gets confused and/or confusing.

     

    Is there a sure-fire way to manage that which I wish to send into the cloud and keep locally that which I don't wish to fly into the cloud?

     

    In other ways, the cloud seems poor for managing songs by other criteria. How does one cause the ORDER of songs in an album to stay where you want them?