Skip navigation

Why do I only see Bonjour services on my iOS devices?

1014 Views 17 Replies Latest reply: Oct 9, 2013 8:19 AM by Linc Davis RSS
1 2 Previous Next
contralateral Calculating status...
Currently Being Moderated
Oct 8, 2013 2:49 AM

Hi all,

 

I have a strange issue where only my iOS devices (iPhone 5 and iPad Mini, both on iOS7) can see any Bonjour services, while OS X computers don't see anything. All the devices are in a WiFi network that's hosted by a Cisco AP1142N. This manifests itself in the fact that I can only stream to my AppleTV when I use an iOS device, AirPlay doesn't work at all on the laptops.

Bonjour Browser on the iPhone reveals a plethora of available services, amongst those also _airplay._tcp (where my AppleTV is listed), whereas Bonjour Browser on OS X just shows the services running on the device itself.

Does anyone have any idea what could be causing this?

 

Many thanks and best regards

iPhone 5, iOS 7.0.2
  • MrHoffman Level 6 Level 6 (11,720 points)

    mDNS (Bonjour) multicast traffic will be blocked by IP routers within the configuration, can be blocked by protocol-level network filters, and the multicast traffic can also be partitioned by a vLAN configuration.

     

    Various Cisco devices commonly implement all of those features; IP routing, filtering, and vLANs.

     

    Minimally, confirm you're either not using vLANs or that you're all configured on the same vLAN, and also look to reconfigure the WiFi over to an Access Point configuration and away from an IP router configuration, if it's not already there (as implied by the AP in its name).

     

    FWIW, you're probably better off asking some Cisco-knowledgeable folks for help with configuring this Cisco gear for mDNS traffic, as I'm guessing that you may have more Cisco gear here than just that (apparent) WiFi AP, and it's very likely the configuration of your Cisco networking gear is the source of the mDNS issues here.

  • BobHarris Level 6 Level 6 (12,510 points)

    Many thanks for your reply. I agree that this issue is strongly related to the configuration of the Cisco AP, however what I don't get is why one device is able to use mDNS just fine, while on the other it's completely unavailable, all on the exact same network — your assumption about the AP just being a bridge is correct, there is no IP routing going on the Cisco box. So the only difference between the two cases is the IP address assigned by the DHCP server (which is also separate from the access point).

     

    It seems like there are two different implementations of the mDNS stack in iOS and OS X, which is a bit surprising.

     

    This sounds very much like you have 2 subnets, and not 1.  WIth the iOS devices being on one subnet and the Mac being on the other subnet.

     

    You say the Cisco device is just an access point, however, if it is still enabled as a full router that will create a separate subnet and block all Bonjour traffic going across the Cisco device.

     

    And it it also possible that the Cisco device does not have router capabilities, but also blocks Bonjour traffic just the same.

  • BobHarris Level 6 Level 6 (12,510 points)
    • Your point about the blocking of Bonjour traffic is probably exactly on the mark — but then again, why does it work with iOS devices?

     

    If the iOS devices are talking to one WiFi access point, and the Mac is talking to another or using ethernet, then the traffic would have to pass through the Cisco device.

     

    Or, have you enabled all kinds of firewall features on your Mac?  That is to say, if you are having issues with the Mac, that would explain the Mac issues.  If you have enabled the firewall, try disabling it to see what happens.

     

    Did you install a 3rd party anti-virus product.  Most of them cause more problems they they solve (a lot more problems).  If you did, disable it.

     

    I assume there has been a Mac reboot.

     

    I would also try rebooting into 'Safe Mode' (boot holding the Shift key).  In Safe Mode all 3rd party extensions are not loaded and many startup items are not started.  So if something is interferring with the Mac's Bonjour services, that might give a clue that something is interferring.

  • BobHarris Level 6 Level 6 (12,510 points)

    I would also try rebooting into 'Safe Mode' (boot holding the Shift key).  In Safe Mode all 3rd party extensions are not loaded and many startup items are not started.  So if something is interferring with the Mac's Bonjour services, that might give a clue that something is interferring.

    Good idea, but unfortunately still the same situation.

    Can you plug the Mac in via ethernet?

     

    If you can, can you plug it into ethernet, are there more than one device you can plug it into.  If, so try them all.

     

    NOTE: I'm running out of ideas.

  • Linc Davis Level 10 Level 10 (107,885 points)

    The devices are positively on the same subnet, 10.10.0.0/8 to be exact

     

    That netblock makes no sense. Change it to /24.

  • MrHoffman Level 6 Level 6 (11,720 points)

    I'd encourage asking for assistance in a Cisco-related forum, as you're much more likely to get better information on Cisco gear elsewhere than you will here.  (No, I'm not willing to absolve the Cisco device here.  Not yet.)

     

    That you're getting some mDNS traffic with some hosts does not eliminate the Cisco gear.   I'd swap out the Cisco gear for another vendor's AP  — I'd usually swap for a dumb network switch and patch cables for these cases, but you need WiFi here — and see if things start working.  An AirPort Expess, AirPort Extreme or Time Capsule configured in its bridged mode will work, as will any comparatively unsophisticated AP.

     

    That written, are you at Cisco WLC 7.4, if that's applicable here?

  • Linc Davis Level 10 Level 10 (107,885 points)

    the subnet is 10.10.0.0/16

     

    Do you actually have more than 256 nodes on your network, or do you plan to have that many?

  • BobHarris Level 6 Level 6 (12,510 points)

    Is it possible that the netmask for the Mac's Airport is /24 ?  I ask, because the netmask controls what a broadcast message looks like

     

    Applications -> Utilities -> Terminal

     

    ifconfig

     

    en1: is generally the Airport device.

     

    Look for 'netmask'  0xffff0000 would be /16

    0xffffff00 would be /24

    0xff000000 would be /8

     

    Also look at the en0: (ethernet interface) and see if its netmask is the same as the Airport and that both match the router settings.

     

    I actually agree with Linc that /24 (256 nodes) is more then enough for a home setup.

  • Linc Davis Level 10 Level 10 (107,885 points)

    I would test with /24.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.