4 Replies Latest reply: Oct 8, 2013 3:52 PM by dbruyere12
dbruyere12 Level 1 (0 points)

I have a computer lab set up and I have my administrator computer with remote desktop. When I hilight all of the workstations I see that I can run an application on all of the workstations but I don't know how to just open a folder that is in everyones' application folder.


iOS 6.1.4
  • Camelot Level 8 (46,665 points)

    You can send the UNIX command 'open', with the path to the directory:

     

    /usr/bin/open /path/to/some/directory

     

    and it should open on the user's desktop.

  • dbruyere12 Level 1 (0 points)

    I think I needed to add more info. I'm setting this up for a teacher that needs to go into the lab and basically click on something that will handle it for her. She understands how to use remote desktop to open an application but that's about it. I tried a script but it doesn't show up on the list of applications.

     

    Also, all of the usernames were set up differently. I was hoping to be able to drop something in each workstations application folder to execute from the admin computer.

     

    FYI, I'm a pc guy so this is all new territory to me.

  • dbruyere12 Level 1 (0 points)

    I think I just figured it out. I just saved the applescript as an application and tested it. Ran perfectly. I have to test it in remote desktop next.

  • dbruyere12 Level 1 (0 points)

    It worked. I just used the script below and and saved it as an app. I dropped it in the applications folder of all the workstations and was able just use "open application" to run it from remote desktop.

     

    tell application "Finder"
    open ("/Applications/FolderName" as POSIX file)
    end tell