7 Replies Latest reply: Oct 17, 2013 9:15 AM by apple tv ***** since the last update
bimmergirl1994 Level 1 Level 1 (0 points)

Having an issue with playing my purchased movies. The issue is that I click play on the movie I want and the gray circle shows like its loading then it reverts back to the play screen again. I have reset it to factory and after 8 minutes or so when it comes up it allows me to play and watch 1 movie. After I stop the movie or try to go into a different movie it no longer works and I have the same issue again. I have checked my firewall and my Avg they are not the issue. I have reset my Internet and the same problem continues. Air play, HBO to go, Netflix all work no issues.

 

Any help would be greatly appreciated!


Apple TV
  • BlakesGold Level 1 Level 1 (10 points)

    Have the same issue, have you recently upgraded the software?  I downgraded back to v5.3 and my content now plays.  Looks like an issue with the update.

  • Kelly1064 Level 1 Level 1 (0 points)

    I am having this exact same problem. So how do I downgrade from 6.0? Can't seem to find the answer using the search bar.

  • rebby575 Level 1 Level 1 (0 points)

    Same problem -- click play, changes to "loading screen" for a few seconds, then flashes back to the "play" screen. I also can't purchase other movies. The first two times I tried,  the "are you sure purchase buttons" screen, click it and it flashes back to the movie not screen. Just now, I tried again after restarting, It got me to a screen that required my security code for my credit card. After I put it in, it said I'd have to go to iTunes to finish the authorization. The first time I tried through my iTunes account, it said the service wasn't available. The second time, it let me enter the numbers. Now, back to the Apple TV, again, it wants the security code again. Several attempts failed.

     

    Now, trying to download a free iphone game: iTunes story is temporarily unavailable.

     

    I'm persistant.

     

    Added:

    Apple TV is running 6.0.

    Netflix plays fine.

    Music (itunes match) plays fine.

  • BostonRedSox1 Level 1 Level 1 (0 points)

    How did you downgrade from v6.0 to v5.3? I have tried everything to get my purchased movies to play, but nothing works. I tried resetting the apple tv and the router, I restored the apple tv to factory settings, I logged off and back on, and I deleted my itunes information and reentered it. The best I have been able to accomplish is getting 1 movie I have purchased to play after restoring, but then it starts not letting purchased movies play again. I can watch previews, netflix, and hulu plus without a problem. I cannot even purchase any movies since the update. Please help me downgrade so I can go back to watching my movies and tv shows, thank you.

  • Nicholas Natteau1 Level 1 Level 1 (15 points)

    Just ran into the same issue and same problem here. Netflix works perfectly but films purchased on Apple iTunes just refuse to load, why!??? It doesn't seem like I can downgrade to the earlier software version either. I have no choices in my General Prefs list under Software Update.

  • rebby575 Level 1 Level 1 (0 points)

    This morning, my Apple TV suddenly started playing purchased movies again.

     

    The only thing new that I'd tried is that we rented a movie on iTunes to watch on my MacBook Pro.

     

    After watching it for a few minutes, I noticed a menu item that let me view it on Apple TV. It worked. I'm sorry that I don't remember what the menu item was.

     

    Maybe that refreshed the link from iTunes to Apple TV again. 

     

    This archived KB article may offer some hints.

     

    MacBook Pro 17" mid-2010. 2nd Gen Apple TV.

  • apple tv ***** since the last update Level 1 Level 1 (0 points)

    i have the same problem here.. rented a movie, watched through the half of it when it all suddenly gone off. now it shows as if i havent ever rented it.. its been like this for last few days...