9 Replies Latest reply: Oct 10, 2013 6:27 AM by Tony T1
dmiller2606 Level 1 Level 1

Hello everyone ,

I have a 16GB usb stick and i only use it on my mac. Today i wanted to use it and tried to put some files onto it but it didn't work. The first thing i did is check the info and there it said under Sharing & Permissions: You can only read. Nothing else nothing to change the permissions or anything. Next thing i did was check the internet and see what they are saying... i tried fixing my problem with Disk Utility but it is coming up with an error that says:

Could not change the partition type for /dev/disk0s2 - Resource busy


When i try to erase it, it says:


Disk Erase failed with the error:

Unable to write to the last block of the device.


When i try to verify it there is also an error:


Error: This disk needs to be repaired. Click Repair Disk.


but the all the buttons (Verify Disk Permissons, Repair Disk Permissions, Verify Disk and Repair Disk) are greyed out


The good news is there is only one file on it which i really don't care about, the bad news is i don't want to go to the shops and buy one (only if there is reaaallyyy no way of fixing). I need the USB stick for school so it would be nice if someone could help.


If you want i can post some screenshots of the errors.