13 Replies Latest reply: Apr 24, 2014 3:21 PM by NateDiggity
shaybeer Level 1 Level 1 (0 points)

Hi,

 

I've temporarily swithced from iPhone to Android and I've been largly dissapointed that I can't participate in group messages between iphone users (where I'm the only android phone), because of their phones still see my phone number as iPhone. It seems to me that there is a huge issue with apple's software managing contacts, which basically keeps all previous apple users hostage, making them unable to freely communicate. Did anyone have similiar issue, and was he able to find a solution for it? Any word from Apple?

  • snozdop Level 5 Level 5 (5,800 points)

    iMessage, which is most likely what you've been using for group messaging on the iPhone, is not available for Android devices.

     

    If your phone number is associated with iMessage, and you switch your SIM to a non-iPhone, you should turn iMessage off BEFORE switching the SIM. Apple cannot magically see what phone you have your SIM in, so if you've previously registered your phone number for iMessage, your contacts will not know you are no longer using an iPhone unless you unregister your phone number from iMessage.

  • shaybeer Level 1 Level 1 (0 points)

    That makes perfect sense. Thanks for a hint. The caveat is, what do I do if I've already got rid of my iPhone. Any way I can do it online, using my apple account, or by Apple service?

     

    Thanks,

  • snozdop Level 5 Level 5 (5,800 points)

    From: http://support.apple.com/kb/HT5538

     

    "If you no longer have access to the iPhone that is using the number you want to remove, reset your Apple ID password."

  • shaybeer Level 1 Level 1 (0 points)

    I've already done that. Did not help. Apparently, the iMessage is linked (in most cases) to your phone #, not your apple account. I guess at that point my only option is to snatch an iphone, go to my operator, activate it, disable the iMessage, and switch back to another phone.

  • Nikk333 Level 1 Level 1 (0 points)

    My wife switched to the Samsung S4. The Verizon store made the changes to the phone prior to diabling, I unregistered the phone and change the apple ID user and email, deleted all previous contacts. Re booted and still nothing!!  Anyone have any other suggestions???

  • photogirl426 Level 1 Level 1 (0 points)

    I am having this same issue.  I recently switched to an Android, but my sisters have iPhones.  When they group message me, my number only comes through as iMessage when everyone else in the group has iPhones.  If there is one other person with an Android (that didn't switch from iPhone), then my number shows as a Text vs. iMessage.  I have turned off Facetime, iMessage and deactivated my number on my old iPhone.  I also have an iPad (that I will still use), but I turned off everything on that one as well temporarily.  In addition, I removed my iCloud apple ID from both devices.  My contacts with iPhones are still having issues!  HELP!

  • Switched_back_to_ANDROID Level 1 Level 1 (0 points)

    Just log into your iphone with a new apple ID, voila !

  • jessbliss258 Level 1 Level 1 (0 points)

    I'm having the same issue with my sister that switched to an android... We were able to message fine for a while even in group messages with our parents (who both have iphones) but now for some reason anytime I group message my sister and my parents, my sister doesn't receive it because she is on an android...

  • broogle Level 1 Level 1 (0 points)

    I went through this after switching from iPhone to Android. I changed my password etc etc and nothing worked. I spent a couple of hours talking to Apple and Verizon support, and finally got this info from a second-level Apple support rep: this is a known problem that will be fixed in some future release. Meanwhile, ask friends with iPhones to send you one-to-one messages, not group messages.

  • tsmart0103 Level 1 Level 1 (0 points)

    Has there been any update to this? I'm running into the same issue.  My iMessages were turned off on my old phone but my contacts' messages are going through as iMessages on the group texts.

  • photogirl426 Level 1 Level 1 (0 points)

    You need to call Apple Support to have them disassociate your phone number from your Apple ID.  There is no other way to do this other than to call (it's not possible to do it yourself).  This is entirely an apple issue according to the rep I spoke to on the phone.  After doing that, change your apple id password, remove all existing imessages/texts from your previous apple devices (iPhones, iPads, etc.).....and be sure that anyone that texts you from an apple device removes all their messages as well! (they do not have to reset their apple id passwords).  Restart all devices and it should help (that is what finally worked for me).  Good luck!

  • broogle Level 1 Level 1 (0 points)

    I did all that. No luck. I thought it was just group messages that failed, but my wife just sent me a direct MMS message from her iPhone and it never arrived. This has to get fixed by Apple, and I hope it happens soon - I have been in message limbo for three months. I am sure there are friends who are wondering why I never replied to their message. The idea that I would contect everyone who might possibly send me a text message and have them delete all their messages is nuts.

  • NateDiggity Level 1 Level 1 (0 points)

    I think I figured it out... at least for me..   My mom recently switched from the iphone 4s to an android and me and my 4 sisters all have iphones still. She asked us to delete her contact info and so we did, but still nothing worked.  So I went into my settings and turned off imessage.  and it worked!!  She gets my texts in group message mode.  My understanding of imessage is that all it does is saves your plan texts by sending the texts using wifi or data and not using you texts from your plan..  but since I have unlimited texts through verizon, it doesn't matter for me..  sorry if any oft hat is confusing. i'm trying to type fast. anyways,  this is working for me now, hopefully this helps someone.