4 Replies Latest reply: Oct 9, 2013 1:35 PM by zinc1oxide1
zinc1oxide1 Level 1 Level 1 (5 points)

Despite running Mac OS X Mountain Lion and Safari 6.0.5, whenever I attempt to play a video from Apple's Developer WWDC site, I receive the following error:

 

System Requirements


To watch the streaming version of this video, use the latest version of Safari on a Mac running OS X Lion or later. Alternatively, you can watch this video in the WWDC app or download the video when available.

 

I instead force to download the video.

 

Any suggestions?


iMac, OS X Mountain Lion (10.8.5), 27" Intel Core I5 - 4GB ram