7 Replies Latest reply: Mar 6, 2014 6:14 AM by Raddish
Madeline Morrison Level 1 Level 1 (5 points)

I'm not sure whether this is a bug or an intentional behavior - either way, I'd sort of like to turn it off. I also had a hard time searching for this, so apologies if it's been discussed before.

 

I'm running Mountain Lion v 10.8.5 on a mid-2010 white MacBook. I'm using Safari v 6.0.5. For a while now I've noticed a behavior where when I'm typing in the address / search bar, Safari seems to autofill what I'm typing with some website URL (after only a few letters) and then take me to it automatically, before I have a chance to stop it. So like for instance, if I'm using the search bar to google (for instance) "facts about honey badgers," as soon as I typed "fac" Safari will autofill "facebook.com" and take me to Facebook instantly, before I can do anything about it. I have no idea what triggers this behavior, I'm not pressing "enter" or anything - I have no idea why it's deciding to implement its autocomplete. It doesn't always happen, but when it does it's super annoying. And Safari doesn't seem to always know it's happened - since it happens so fast, a lot of times I'm still typing while Safari is going to the website. So when I get to Facebook, it still registered my typing and the searchbar now reads "ts about honey badgers." So it could tell I still wanted to type up there, it just took my "fac" and used it to take me to Facebook, which I did not want.

 

I hope this made sense - any idea what's happening or how I can turn it off? Thanks!


MacBook, OS X Mountain Lion (10.8.2), 2.4 GHz Intel Core 2 Duo
  • Carolyn Samit Level 10 Level 10 (95,985 points)

    Open a Finder window. From the Finder menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    ~/Library/Caches/com.apple.Safari/Cache.db

     

    Click Go then move the Cache.db file to the Trash.

     

    Quit and relaunch Safari to test.

     

     

    If that didn't help, with Safari open press Command ,  )comma) to open the Prefernces pane. Select the Privacy tab.

     

    Click:  Remove All Website Data.

     

     

    If that didn't help, try troubleshooting extensions and third party plugins.

     

    From the Safari menu bar click Safari > Preferences then select the Extensions tab. Turn that OFF, quit and relaunch Safari to test. If that helped, turn one extension on then quit and relaunch Safari to test until you find the incompatible extension then click uninstall.

     

    If it's not an extensions issue, try troubleshooting third party plug-ins.

     

    Back to Safari > Preferences. This time select the Security tab. Deselect:  Allow all other plug-ins. Quit and relaunch Safari to test.

     

    If that made a difference, instructions for troubleshooting plugins here.

     

     

    messaged edited by::  cs

  • Madeline Morrison Level 1 Level 1 (5 points)

    Thanks, I'll try all these things. Unfortunately, it won't be easy to tell whether they work, since it's not a regular (or even really reproduceable...) occurrance. It's just sort of something that happens sometimes, seemingly at random, maybe once every day or two. Frustrating.

  • Carolyn Samit Level 10 Level 10 (95,985 points)

    I'm sure it's frustrating..  try deleting the cache.db now. It only takes a minute. If the problem persists, then remove all website data, etc.

  • Madeline Morrison Level 1 Level 1 (5 points)

    Okay, I deleted the file. I guess now I'll wait and see if it happens again. If this is the last you hear from me, assume it worked!

     

    If anyone else does know definititively what is causing this problem (or has had this problem themselves), please do let me know.

  • Linc Davis Level 10 Level 10 (159,080 points)

    Step 1

     

    From the Safari menu bar, select

            

    Safari Preferences Extensions

         

    Turn all extensions OFF and test. If the problem is resolved, turn extensions back ON and then disable them one or a few at a time until you find the culprit.

     

    If you wish, you may be able to salvage the errant extension by uninstalling and reinstalling it. Its settings will revert to their defaults. If the extension still causes a problem, remove it permanently or refer to its developer for support.

     

    Step 2

     

    In the Privacy tab, check the box marked

    Prevent search engine from providing suggestions

  • Taejun Level 1 Level 1 (0 points)

    I am having the same issue

    very sad that every suggestions didnt work for me.

     

    I didnt install any extensions at all.

    I am using Korean on my iMac OSX 10.9.1 .  Wonder that could be the any problem..

     

    its the most horrible thing I've ever expierenced on any apple devices.

    most horrible thing..

    I don't want to use chrome on osx..  but there would be no way if this kind of silly problem remains for monthes like this

  • Raddish Level 1 Level 1 (5 points)

    I'm having the same issue - it seems to be a bug in Safari. I hope Apple fix it soon, as it's really annoying!