14 Replies Latest reply: Mar 28, 2014 8:12 AM by msz1
vschafer Level 1 Level 1 (0 points)

I recently enabled root user following instructions from my web hosting server, and fixed the problem.

Now that I want to disable the option, following instructions from http://support.apple.com/kb/HT1528,

the option from Edit Menu is greyed out.

How do I fix it?

MacBook Pro, Mac OS X (10.7.1)
  • Linc Davis Level 10 Level 10 (177,485 points)

    Did you unlock the preference pane?

  • vschafer Level 1 Level 1 (0 points)

    I followed these instructions and was unable to complete step 9.  Not sure what you mean by preference pane ...


    1. From the Apple menu choose System Preferences....
    2. From the View menu choose Users & Groups.
    3. Click on the lock and authenticate with an administrator account.
    4. Click Login Options....
    5. Click the "Edit..." or "Join..." button at the bottom right
    6. Click the "Open Directory Utility..." button.
    7. Click the lock in the Directory Utility window.
    8. Enter an administrator account name and password, then click OK.
    9. Choose Disable Root User from the Edit menu.
  • Grant Bennet-Alder Level 9 Level 9 (54,185 points)

    If you were completely successful at step 7 and step 8, that choice should now be showing in step 9.


    If you mistyped the password, for example, or used a non-Admin accountname, the lock would still be locked, and "Disable Root user" would not be shown in the Edit Menu.

  • vschafer Level 1 Level 1 (0 points)

    When I entered Admin accountname/passw, the lock icon opened and it showed "Authenticated by" and my name

  • Grant Bennet-Alder Level 9 Level 9 (54,185 points)

    Once the lock is unlocked, at step 9, that choice changes back and forth between Enable root user and Disable root user, depending on the current state.


    If it is now showing Enable Root user, you have succeeded disabling Root user, and it is offereng you the option of enabling again.

  • Linc Davis Level 10 Level 10 (177,485 points)

    You have to authenticate as "root," using the password you set. Authenticating as any other user won't work.

  • vschafer Level 1 Level 1 (0 points)

    Grant, it doesn't show Enable Root user.  It shows Disable Root user but it is greyed out.


    Linc, I guess I made the big and terrible mistake of not writting down usern/passw then.

    Actually, I think (not sure) that when I got the prompt, I entered the same usern/passw I use as the primary (and only) user of my computer.

    Does it mean I will have to re-instal my OS and start from scratch?

  • Linc Davis Level 10 Level 10 (177,485 points)

    If you think you may have set the same password for root that you use for your admin account, try it. Otherwise things get more complicated.

  • vschafer Level 1 Level 1 (0 points)

    I changed my admin account password and now step 8 authenticates if I use the new Admin password but doesn't let me disable root admin either. 


    That means I did create a different root admin.  I just don't remember what it was :-(

  • Linc Davis Level 10 Level 10 (177,485 points)

    Please take these steps to reset the root password.

    Step 1

    Boot into Recovery mode. The OS X Utilities screen will appear.

    Step 2

    Take this step only if you use FileVault 2. Launch Disk Utility, then select the icon of the FileVault boot volume ("Macintosh HD," unless you gave it a different name.) It will be nested below another icon with the same name. Click the Unlock button in the toolbar and enter your login password when prompted. Then quit Disk Utility to be returned to the main screen.

    Step 3


    Utilities Terminal

    from the menu bar. In the window that opens, type this:


    Press the tab key. The partial command you typed will automatically be completed to this:


    Press return. A Reset Password window opens. Select your boot volume if not already selected. Pull down the menu labeled Select the user account and select

    System Administrator (root)

    Follow the prompts to set a password. It's safest to choose a password that includes only the characters a-z, A-Z, and 0-9.



    from the menu bar.

    Step 4

    Follow the instructions in this support article under the heading "Disable the root user."

  • vschafer Level 1 Level 1 (0 points)

    I'm out of country and I guess it is better to wait until I get back and update Time Machine, just to be on the safe side.  But thank you very much for your time.  I'll follow your suggestions/instructions, no doubt.

  • vschafer Level 1 Level 1 (0 points)

    Linc Davis, sorry for the delay to return with an update on this thread.

    I wasn't able to perform all steps suggested above until now.

    I was able to follow your instructions, followed by the steps on article's step 5 on how to disable the root user

    Unfortunately it doesn't recognize either username or password


    But I would like to say that on the reset password screen, it didn't ask me for a username, so I'm afraid that is where the problem is, not the password.


    However, the article you suggested was for Mountain Lion and now I am running 10.9.2

    Is this relevant? Maybe this new OSX has a different way of resetting it.

  • msz1 Level 1 Level 1 (0 points)

    I have the same issue that my "Disable Root User" and "Change Root Password" are greyed out.  Even if I log in to the Directory Utility as root, I do not see the ability to "Disable Root User" (or change password).  The lock icon shows the credentials are ok (unlocked icon), but the edit options are greyed out.  I don't want to disable root right now anyway, but I was just checking the option and noticed this.

        I'll try rebooting my MacPro(osx 10.8.5).   Maybe a process is running as root or some file open.  Very strange.  I was able to enable root access with my ID.  But I can't disable it with my ID, or the root id....


    Any thoughts?

  • msz1 Level 1 Level 1 (0 points)

    I got it.  I had to click on the "Services Tab" inside of the directory utility.  I was on the "Directory Editor" tab by default.  Once I clicked on the services tab, I could change root info with either user.