Previous 1 2 Next 17 Replies Latest reply: Dec 1, 2015 7:52 PM by naz002
mrfistpump Level 1 Level 1

Screen Shot 2013-10-10 at 9.45.34 PM.png

I always get this annoying message. So if anyone knows how to fix this please tell me, thank you.


MacBook Pro, OS X Mountain Lion (10.8.3)
Solved by Linc Davis on Oct 10, 2013 9:00 PM Solved
Back up all data. Launch the Keychain Access application in any of the following ways: ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.) ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.  ☞ Open LaunchPad. Click Utilities, then Keychain Access in the icon grid. Select the login keychain from the list on the left side of the Keychain Access window. If your default keychain has a different name, select that. If the lock icon in the top left corner of the window shows that the keychain is locked, click to unlock it. You'll be prompted for the keychain password, which is the same as your login password, unless you've changed it. Right-click or control-click the login entry in the list. From the menu that pops up, select Change Settings for Keychain "login". In the sheet that opens, uncheck both boxes, if not already unchecked. From the menu bar, select    Keychain Access ▹ Preferences ▹ First Aid   If the box marked Keep login keychain unlocked is not checked, check it. Select   Keychain Access ▹ Keychain First Aid    from the menu bar and repair the keychain. Quit Keychain Access.
Reply by John Galt on Oct 10, 2013 7:57 PM Helpful
In addition to the other's suggestions, review the following to determine if it is applicable: Mac OS X: Keychain Access asks for keychain "login" after changing login password.

All replies

  • Tlix Level 4 Level 4

    You may need to open up Keychain Access from the Utilities folder and reset the default login keychain. Be aware this may mean you need to re-enter all your passwords at least once so they are remembered. It will be under Keychain Access -> Preferences -> Reset my default keychain.

  • Grant Bennet-Alder Level 9 Level 9

    I don't think you want to RESET your keychain (which will probably dump all your passwords). I think you want to grant access for that Application to be able to access your keychain automatically. The procedure is a little complicated:

     

    OS X Lion: Allow applications to access your keychain

  • John Galt Level 8 Level 8

    In addition to the other's suggestions, review the following to determine if it is applicable: Mac OS X: Keychain Access asks for keychain "login" after changing login password.

  • Linc Davis Level 10 Level 10
    expertise.desktops
    Desktops

    Back up all data.

     

    Launch the Keychain Access application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Keychain Access in the icon grid.

     

    Select the login keychain from the list on the left side of the Keychain Access window. If your default keychain has a different name, select that.

     

    If the lock icon in the top left corner of the window shows that the keychain is locked, click to unlock it. You'll be prompted for the keychain password, which is the same as your login password, unless you've changed it.

     

    Right-click or control-click the login entry in the list. From the menu that pops up, select Change Settings for Keychain "login". In the sheet that opens, uncheck both boxes, if not already unchecked.

     

    From the menu bar, select

       

    Keychain Access Preferences First Aid

      

    If the box marked Keep login keychain unlocked is not checked, check it.

     

    Select

      

    Keychain Access Keychain First Aid

       

    from the menu bar and repair the keychain. Quit Keychain Access.

  • Cannotfindanavailableusername Level 1 Level 1

    same problem.. seems that Link Davis way solve the issue.. thank You, crossing fingers..

  • clarebear Level 1 Level 1

    So I just started experiencing this last night.

    I've opened up Keychain Access and selected the option - Change Settings for Keychain "login", but it just freezes :(

    Tried rebooting again but just the same.

    Why hasn't Apple released a bug fix for this??!

  • Grant Bennet-Alder Level 9 Level 9

    Why hasn't Apple released a bug fix for this??!

    Probably because you are the only person experiencing this problem.

  • clarebear Level 1 Level 1

    Oh really Grant, seems that over 300 people have complained about keychains recently on the Apple forums alone, already.

    Anyway, I was able to fix it by following what Steve said here:

    https://discussions.apple.com/message/23768561#23768561

     

    P.S. This is for the "local items" login promt, not the "login" keychain promt (which would be the fix above).

     

    (I've edited the orginal to this)

    1. Go to Finder

    2. Look for the hidden folder Library, ie: /Users/clarebear/Library/Keychains.

    3. Inside the Keychains folder is a single folder with random numbers and letters, ie: ACE4BDA3-B48C-5F97-AEB0-3836B9E48457

    4. Drag this folder onto your desktop.

    5. Re-boot and you should be good to go.

    6. If Ok drag the folder off your desktop into the trash!!

     

    Only thing that popped up when rebooting was icloud asked for my password, so I entered it and it went away.

    Problem solved.

  • Supa_Fr35h Level 1 Level 1

    Deleting the hidden folder a la clarebear's suggestion above did the trick for my "local items" problem.

  • michaelpstokes Level 1 Level 1

    clarebear's suggestion worked for me for a few hours and then the messages about keychain started again.  I am using retina MacBook Pro.

  • Király Level 6 Level 6

    I had this problem too. Keychain first aid didn't fix it for me. I found this to be very annoying because I don't and never have used the Messages app, so I don't know why it would be asking in the first place for my keychain password.

     

    But I was able to fix it by making the passwords for the keychain and my user account login the same. That prevented the Messages app from asking for it at login.

  • dan wool Level 2 Level 2

    I tried everything suggested here and many other things to fix this same issue, that started when I migrated to a new Mac. Nothing worked. Then I remembered that I used a different the account login password when I set up the new Mac. Once I changed the new Mac's login password to match the old one, the messages stopped. I'd still like to have the ability to change my login password, but this stops the madness for now.

  • RJV Bertin Level 3 Level 3

    That's a nice solution if you don't care about leaving your default keychain open, providing full access to its contents.

     

    I prefer to use a dedicated "open" keychain for that, one that only gets locked when you suspend the system but otherwise remains open and only contains less-sensitive passwords. But for that to work you need to know which entries an application needs to have access to, in order to transfer them from the default keychain to the open keychain.

     

    So, specifically, what is or are the keychain entries that the Messages Agent needs to access to?

  • clandau Level 1 Level 1

    I raised this issue in another thread (what is the "messages agent" i am asked to sign into every time i turn on my Mac?) and got no response there.

     

    Maybe the answer for those of us concerned about leaving a keychain unlocked all the time, is to make "login" the open keychain, and put our sensitive information in another keychain that does not stay unlocked. I don't know what the Messages Agent is, but I don't think I've given it any sensitive passwords. I'm going to try this.

Previous 1 2 Next