4 Replies Latest reply: Dec 21, 2013 6:56 PM by boscoeuk
jjakz11 Level 1 Level 1 (0 points)

I just got a new Airport Extreme base station to replace a 4 year old Extreme.  I also have two Airport Express extenders. My old base station and my two extenders have been working -- I bought the new Airport Extreme because I stopped getting wifi in one part of the house a few weeks ago (despite the two extenders) and thought a newer model base station could help fix that.  I also was hoping to use my old Extreme base station as an additional extender (giving me a total of 3 extenders).  I have my new base station up and running.  However, I am unable to add the two Airport Expresses to my network.  My Airport Utility shows the two Airport Express as "New AirPort Base Stations," but when I try to click on one to add it, I get the following error message: "An unexpected error occurred. Try again."  It also is not giving me a way to use the Expresses to extend the network--just listing them as additional base stations.  Anyone have any suggestions?  Thanks!


Airport Extreme 802.11ac, OS X Mountain Lion (10.8.5)
  • Tesserax Level 8 Level 8 (49,125 points)

    Two things to try:

    1. During the extended network set up phase temporarily connect each of the extending base stations to the base station that they will be extending.
    2. Perform a "factory default" reset on each of the extending base stations.
  • jjakz11 Level 1 Level 1 (0 points)

    Haven't tried the first step, but did try doing a factory default reset on each of the extending base stations.  All are flashing amber.  Airport Utility shows "Other Wi-Fi Devices (3)" but still getting same error message.

  • yobuc Level 1 Level 1 (0 points)

    I have posted this elsewhere:

     

    I am having the same problem with Mavericks, repeatedly getting the "An unexpected error occurred. Please try later" or something similar. And I kept trying again and again and again and again with the same result.

     

    So I booted up my iMac (Processor  2.7 GHz Intel Core i5) with my old Mountain Lion disk and, using the Airport Utility 6.2, I was able to set up the Airport Express on the first try. No unexpected errors.

     

    Imagine that.

     

    From a troubleshooting standpoint, I have to posit that something is awry either with Mavericks itself or the new Airport Utility 6.3.2. regarding the setup of the Airport Express. The Airport Extreme doesn't seem to encounter the same problems, but then again I have made only a few minor changes. Nothing involving setup. (And I'm not going to)

     

    If you can boot up under an older OSX, I'd suggest you try that first, and then make sure your Airport utility is in the 6.2 range, not 6.3.

     

    I think this is strictly a software problem, either or both with the Airport Utility or the newest OSX.

  • boscoeuk Level 1 Level 1 (0 points)

    Hey thanks yobuc!,

     

    Had the same problem and your 'old school' solution worked for me as well. Agree somthing is very wrong if this is the solution!