1 Reply Latest reply: Nov 19, 2013 1:42 PM by newbie302
bgw8probe Level 1 Level 1 (0 points)

I am running OS X Mountain Lion Server 2.2.2 with the VPN switch on. I have no problem with my MBP connecting to the VPN server, however since upgrading to iOS 7 on my devices they will not connect. I keep receiving the following error. All the correct ports are forwarded and I am using an Airport Extreme as my router. This boggles my mind because VPN worked just fine on iOS 6, please help.

 

 

 

"The L2TP-VPN server did not respond. Try reconnecting. If the problem continues, verify your settings and contact your Administrator."


iPhone 4S, iOS 7.0.2
  • 1. Re: VPN on Mac works but not my iOS 7 devices
    newbie302 Level 1 Level 1 (0 points)

    Had similar problem (could VPN to Mountain Lion Server 2.2.2 with my Mavericks Macbook Pro. When trying to VPN to the server from my IOS 7.0.4 iPhone, I could get a connection, but wasn't able to access my Contacts on the server - verification kept failing with and without SSL).

     

    I had created the VPN profile using the Server app and then saved it and emailed it to my IOS 7.0.4 iphone. I also had access to an IOS 5.x iPad, and installed the same profile there. Contacts sync worked fine on the IOS 5 device.

     

    I finally deleted the VPN profile on the iphone, and manually created one on the iPhone 7.0.4 by typing in the account info from the Server User pane and from the Server VPN pane.

     

    It was a bit long typing in the shared secret, but when I was finished, I was able to connect, and now I could - on the iPhone - create a new Contacts account including server information, and the verification was successful. I can now access the Contacts on the iPhone and on my server.

     

    Am guessing something in IOS 7.0.4 misreads the VPN profile, which causes problems down the line. Apple?

     

    Good luck bgw8probe!