8 Replies Latest reply: Oct 30, 2013 8:03 PM by mrjgc
mrjgc Level 1 Level 1 (0 points)

Hi all,

 

I have a problem with iPhoto that I can't pin down.  I'm running OS X 10.8.5 with all latest updates applied.  I have iPhoto '11 9.4.3 720.91.  When I open iPhoto I see a box notifying me that thumbnails are updating.  Before the progress bar reaches the end iPhoto closes.  There is no error or warning message, and no crash report.

 

  • At first I tried rebuilding various parts of my library using the command-option method of launching iPhoto.  I started with Repair Permissions, Rebuild Thumbnails and Repair Database.  These all ran sucessfully, but didn't change the situation.
  • To understand whether the problem was with my library or with something else I did two things:
    • I created a new library under my user account, lauching with Option key, and selecting Create New. Under the new library iPhoto launches and stays open, but when I import any photo into the library iPhoto closes, no error or warning and no crash report.
    • I created a fresh user account, logged in under that user account and started iPhoto.  Similar to the new library test I am able to launch iPhoto and it stays open until I import a photo and then closes with no error, warning or crash report.
  • My next port or call was launching in safe mode by booting with the shift key held.  In safe mode I launched iPhoto and it stayed open and I was able to see my photo library.
  • I initially avoided running the Rebuild database step, but I went back to non-safe mode and ran the rebuild database step.  This took a while to run, but ultimately didn't change anything.

 

At this point I feel as though I have ruled out a problem with my library since this happens on brand new libraries.  I got it working in safe mode and I feel that this implies that something that runs in normal mode, but not safe mode could be interfering.  I don't know where to start with that, so I tried a few other "last resort" steps.  Figuring that it's not the library I guessed it could be something up with the software or operating system.

 

  • I uninstalled iPhoto, reinstalled from my iLife install disk, and applied all updates.  Same result.
  • Finally, and rather reluctantly, I reinstalled the operating system, and applied all updates.  Same result.

 

I have finally reached the point where I don't know how to diagnose this any further, and I'm looking to you kind people for help.

 

With no crash report (that I can find) is there any other way I can see why iPhoto is closing?  What else can I try?


iPhoto '11, OS X Mountain Lion (10.8.5)
  • Terence Devlin Level 10 Level 10 (131,900 points)

    Open the Console (in your Utilities folder) and watch it as you launch iPhoto and it goes down.

  • mrjgc Level 1 Level 1 (0 points)

    Thanks Terence.  I'm not too familiar with debugging on OS X.  Here's first 50 lines of the log:

     

     

    Process:         com.apple.qtkitserver [2164]

    Path:            /System/Library/XPCServices/com.apple.qtkitserver.xpc/Contents/MacOS/com.apple. qtkitserver

    Identifier:      com.apple.qtkitserver

    Version:         1.0 (1)

    Build Info:      QuickTime-2599041000000000~1

    Code Type:       X86 (Native)

    Parent Process:  ??? [1]

    User ID:         501

     

     

    Date/Time:       2013-10-13 10:00:53.821 -0400

    OS Version:      Mac OS X 10.8.5 (12F45)

    Report Version:  10

     

     

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread

     

     

    Exception Type:  EXC_BAD_ACCESS (SIGBUS)

    Exception Codes: KERN_PROTECTION_FAILURE at 0x000000000000000b

     

     

    VM Regions Near 0xb:

    --> __PAGEZERO             0000000000000000-0000000000001000 [    4K] ---/--- SM=NUL  /System/Library/XPCServices/com.apple.qtkitserver.xpc/Contents/MacOS/com.apple. qtkitserver

        VM_ALLOCATE            0000000000001000-0000000000029000 [  160K] ---/--- SM=NUL 

     

     

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

    0   com.apple.CoreFoundation                0x97aed34c CFBasicHashFindBucket + 76

    1   com.apple.CoreFoundation                0x97b624ff CFBagGetValue + 31

    2   com.apple.qtkitserver                   0x0003641c objectForProxy + 62

    3   com.apple.qtkitserver                   0x0003733a helperObjectForProxy + 22

    4   com.apple.qtkitserver                   0x0003c330 do_getArrayOfTracks + 112

    5   com.apple.qtkitserver                   0x0002ab4d _XgetArrayOfTracks + 112

    6   com.apple.qtkitserver                   0x00035470 QTKitServer_server + 122

    7   com.apple.qtkitserver                   0x000362a4 mach_port_callback + 78

    8   com.apple.CoreFoundation                0x97aee46f __CFMachPortPerform + 303

    9   com.apple.CoreFoundation                0x97aee325 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE1_PERFORM_FUNCTION__ + 53

    10  com.apple.CoreFoundation                0x97aedf52 __CFRunLoopDoSource1 + 146

    11  com.apple.CoreFoundation                0x97b23cea __CFRunLoopRun + 2154

    12  com.apple.CoreFoundation                0x97b2301a CFRunLoopRunSpecific + 378

    13  com.apple.CoreFoundation                0x97b32ab1 CFRunLoopRun + 129

    14  com.apple.XPCService                    0x00070d03 xpc_service_main + 460

    15  com.apple.qtkitserver                   0x000361c2 main + 158

    16  libdyld.dylib                           0x99ce7725 start + 1

     

     

    Thread 1:

    0   libsystem_kernel.dylib                  0x98e520ee __workq_kernreturn + 10

    1   libsystem_c.dylib                       0x946a60ac _pthread_workq_return + 45

    2   libsystem_c.dylib                       0x946a5e79 _pthread_wqthread + 448

    3   libsystem_c.dylib                       0x9468ddaa start_wqthread + 30

     

     

    Thread 2:: Dispatch queue: com.apple.libdispatch-manager

    0   libsystem_kernel.dylib                  0x98e529ae kevent + 10

    2   libdispatch.dylib                       0x9a19ac71 _dispatch_mgr_invoke + 993

  • mrjgc Level 1 Level 1 (0 points)

    I've been watching the console for a bit and noticed that the crash report I included above is also generated when I open finder in a location that shows a picture preview.  It seems that theres some instability in the qtkitserver.  The thread attempts to restart every 10 seconds, but fails the first couple of times.  As far as the rest of the operating system is concerned there's no impact I can detect, only for iPhoto.

  • mrjgc Level 1 Level 1 (0 points)

    This appears to be the same issue as found in this thread:

     

    iPhoto closes unexpectedly when importing photos

     

    Interestingly (for me anyway) is that these both occurred at around the same time.

  • léonie Level 9 Level 9 (68,245 points)
    • My next port or call was launching in safe mode by booting with the shift key held.  In safe mode I launched iPhoto and it stayed open and I was able to see my photo library.
    • I initially avoided running the Rebuild database step, but I went back to non-safe mode and ran the rebuild database step.  This took a while to run, but ultimately didn't change anything.

     

    You have confirmed so far, that iPhoto crashes in all accounts, but not when booting into Safe Mode. That shows, some non standard system extension must be causing this, that will be disabled in Safe  Mode.

     

    What is the last software that you installed, before this crashes started? Something you added recently must have added incompatible extensions.

    You can get a list of all non-standard extensions by running the utility EtreCheck: You can download it for free here: Etresoft: EtreCheck

    It is just an AppleScrips that lists your system stats and will not modify anything. Does the listing ring a bell, what you have added lately?

     

    And how did you reinstall your OS? With the Combo update installer, or did you reinstall by booting into recocery? Try to reinstall by booting into the Recovery Partition. You will need a good network connection for this:  OS X: About OS X Recovery

  • mrjgc Level 1 Level 1 (0 points)

    Thanks leonieDF, that's a very useful tool.  One of my conclusions was also that there might be a non standard system extension, but I wasn't sure how to identify them.

     

    The only thing I've installed recently was the Fitbit Connect Manager.  I wanted to rule that out so one of the first things I did was uninstall it.  Running the EtreCheck tool I spotted a few items in Launch Daemons and User Launch Agents that related to the Fitbit software which hadn't been removed during my uninstall.  When I uninstalled I simply dropped the software in the trash.  The right way to uninstall the fitbit software is to run the uninstaller from the original install dmg.  I've just done that and re-booted, but unfortunately that hasn't solved the problem.

     

    I'm still not 100% convinced that this isn't part of the cause though.  The main reason being the first incidence of the problem was around the time I first installed the Fitbit software, and also I did a little bit of web research and found quite a few similar problems where there was indication of presence of the fitbit software.

     

    I'm wondering whether it's worth trying to do the iPhoto and/or OS X reinstall now that the Fitbit software is off the system, but equally not that confident that it'll make any difference.

     

    To your question, I used the combo update / installer.  I would consider the recovery mode reinstall as a last last resort, just since it takes so long.

     

    Another thing.  I mentioned in my previous messages that the qtkitserver process crashes when a Finder window is opened that contains a picture preview.  I narrowed this down a little and it's only when there are movie files present (.AVI or .MOV) in the directory.  I've got a directory under iPhoto that contains 7 .MOV videos pulled off my iPhone 5 (so no weird codecs or anything), and when I open that location in Finder the qtkitserver process crashes.  It seems to struggle to generate the thumbnail and big previews.  It's generated 4 out of 7 no problem, and 3 of them it won't generate thumbs or large previews at all.  All the videos play fine though, and they played fine when I originally loaded them into iPhoto.

  • léonie Level 9 Level 9 (68,245 points)

    To your question, I used the combo update / installer.  I would consider the recovery mode reinstall as a last last resort, just since it takes so long.

    The difference between the Combo updater and the Recovery install is, that the Combo updater only restores frameworks that have been updated since the introduction of Mt. Lion. Any framework that has been released before that, will not be restored. And the qtkit and the sandboxing and XCP services have already been introduced with Lion, so that is why I am suspecting, it might be necessary to do the full Monty to restore the system. You can reinsatll on top of the current system. There is no need for a clean install.

     

    If the problem is only caused by the movies, you might consider to remove the movies from your iPhoto library for the time being. You cannot edit movies in iPhoto anywy. I store my movies in iMovie, so that I can edit and stabilize them; and if I want to use a movie in a slideshow I load it from iMovie using the Media Browser.

     

    I have never used Fibit, so I cannot help you with that problem. Is your Etrecheck now clean, after you removed the Fitbit leftovers?

  • mrjgc Level 1 Level 1 (0 points)

    An update for those interested...  I knew that the Mavericks release was imminent, so rather than go through a full recovery re-install I waited patiently for the update.  I ran the standard Mavericks update process and all the subsequent software updates (including iPhoto), and with much trepidation and fingers and toes crossed I started up iPhoto.  It worked.  Relief!

     

    I do think a full recovery install would have worked, but I decided to wait out the new OS release.

     

    Thanks Leonie and Terrence for your assistance.