11 Replies Latest reply: Mar 22, 2014 7:10 PM by lrhilsendager
iThunk Level 1 Level 1

My Apple ID included my name and our company's domain, so to make things like calendar invites a bit more anonymous as they fly around the web, a while back I went to https://appleid.apple.com and changed my Apple ID to correspond to a more anonymous email address.

 

While on https://appleid.apple.com I registered and verified the original email address as an Alternate Email Addresses.

 

It seemed like it was hard or impossible to change some things, like my iPhone 5, to use the new Apple ID with iCloud, because it only allows me to enter a password, not change the account's email address.

 

In general it seemed like everything still worked, though, until the recent update to iOS 7.

 

In iOS 7 > settings > iCloud, it's asking me to "Sign in to iCloud" and to "Enter the Apple ID password for "[my old Apple ID email address]."  But when I do enter the password, it doesn't accept it and simply tells me to again to "Sign in to iCloud..." and to "Enter the Apple ID password..."

 

I thought perhaps it was confusing my old ID w/ an old password, but neither old or new passwords work.

 

After doing research in the Apple Support Communities, I found some saying that I'd just have to go to the bottom of the iCloud screen and it the "Delete Account" button.  Frustrated, I did.  But whether I next selected "Keep on My iPhone" or "Delete from My iPhone" the next thing is says is "Password Required" and "Enter the Apple ID password for  "[my old Apple ID email address]."

 

Since that's the very thing that isn't possible for me (always giving the error "Your Apple ID or password is incorrect") I:

  • went to https://iforgot.apple.com and entered my old Apple ID (which, again, is verified still in my Apple ID account as an Alternate Email Address)
  • clicked "next"
  • selected "Email authentication: To access your information, we will send an email to the address(es) on file for you."
  • clicked "next"
  • and go this message, "Email has been sent."


However... it never sent the message to that email account.  So I did it again multiple times.  Then I went and checked spam filters. Then I looked at email logs on the server... Nope... it is not sending the message.

 

In desperation I decided to just wipe the phone clean and start afresh through iTunes, where I clicked "Restore iPhone..."  When I did a dialogue box popped up that said, "Find my iPhone must be turned off before [iPhone 5's name] can be restored. Go to iCloud Settings on your iPhone and turn off Find My iPhone before restoring your iPhone." 

 

On the phone in settings > iCloud, there is a "Terms and Conditions" blue link that I "Agreed" to, which gives me access in iCloud to turn off Find My iPhone, but as soon as I do, the Apple ID password for that old email address is demanded, again... and of course I don't have it...

 

In researching I read that perhaps another alias could be added to my https://www.icloud.com > email > preferences > accounts, but as it turns out the alias can't be my old Apple ID.  It has to be an alias that include @icloud.com in the address.

 

What can I possibly do, now, please? 


iPhone 5, iOS 7.0.2, iCloud, Apple ID, iPhone 5 problems
Solved by iThunk on Oct 19, 2013 5:05 AM Solved

Well, in my case things have turned out well.

 

Apple Supports' highest level personnel talked to the Apple engineers.  The Apple engineers said that if I had a receipt for my phone that they would be able to release the phone's Apple ID.  I did have the receipt, because thankfully the Apple Store emailed it to me when I made the in-store purchase, so I emailed it them along w/ a link to this discussion because they were asking for a description of the scenario.


A couple days later they emailed me saying:

~~~~~

Thanks for contacting Apple.

 

The device serial number on your case does not have an Activation Lock enabled. To get help for the issue you’re experiencing, you’ll need to contact AppleCare Support.

 

You can start your support request online and get connected to an expert at the Contact Apple Support website:

http://www.apple.com/support/contact

 

[name]

AppleCare Account Security

~~~~~

 

Ouch. 

 

I then recontacted the Apple Support person who had been helping me. He said he'd talked for 45 minutes with the Apple engineers and had one *last* idea.

 

He had me log into https://appleid.apple.com/ > Password and Security, then he had me delete my Rescue Email Address (which was the same as my old/original Apple ID that has been stuck on my iPhone 5's iCloud account).

 

After doing that he had me go to the Name, ID, and Email Adresses tab (which you see when you first log into https://appleid.apple.com/) and change my newer Apple ID back to my old original one. (Note: An email is required to verify each of these account changes.)

 

Then I went into my iPhone's settings > iCloud, and YAY!!!! it let me log into my account!  Then I went to the bottom of the iCloud screen and deleted the account.

 

Then I went back into Apple ID, logged in, and deleted the old Apple ID, re-entered my new one, and saved it. (Note: An email is required to verify each of these account changes.)

 

Then I went back to my phone and entered my Apple ID's email address and password... and it worked!

 

Now I just need to fix some stuff that got goofed up in all of the experimenting.

 

If anyone else on the planet has read this much, I would recommend going back in and adding all the info you can to your Apple ID so that your backup addresses and aliases are right.

 

Final thought: My problem was a result of an error/problem with Apple's product.  I kind of wish it was like other industries that try to compensate for their own mistakes (restaurant = free meal, airline industry = upgrade, etc.) because this took a LOT of my time.  But I do appreciate the support workers' perseverance in helping.

  • WiseJD Level 4 Level 4

    Wow ...what a journey!  The only comment that I can make is that I believe the Apple email to your recovery email address is probably occurring.  Are you sure you don't have another email address that you may have at one time listed as the Recovery address?

  • iThunk Level 1 Level 1

    After doing the stuff described above I went to the Apple website and tried to get support, thinking I'd probably have to pay for it. 

     

    I went to https://getsupport.apple.com/GetproductgroupList.action > More Products & Services > Apple ID > Other Apple ID topics > The Topic is Not Listed…

     

    Then I typed in something like, "Cannot log in to verified email address, or delete the address, and Apple emails to reset the password don't arrive."

     

    The website then asked for a phone # to call me at. A couple minutes later I received a call from Apple and 65 minutes later (and a couple of "escalations" to higher level tech help) the tech guy said he was going to have to relay my case to engineers, because there was nothing more he could do.

     

    I just got an email from him saying:

     

    ~~~~~~~~~

    Hello [name],

    ...I received your voice mail.  I would love to already have an answer for you to resolve this issue.  Unfortunately I have not heard back from the engineers.  As soon as I hear something I will email you to set up a time to perform the tasks that they want us to accomplish.

    ~~~~~~~~~

     

    I just post this in case someone in a parallel situation might find it, so that they would know that the problem is with the product/services, and that they're going to need to get Apple engineers to fix it.

  • iThunk Level 1 Level 1

    Well, in my case things have turned out well.

     

    Apple Supports' highest level personnel talked to the Apple engineers.  The Apple engineers said that if I had a receipt for my phone that they would be able to release the phone's Apple ID.  I did have the receipt, because thankfully the Apple Store emailed it to me when I made the in-store purchase, so I emailed it them along w/ a link to this discussion because they were asking for a description of the scenario.


    A couple days later they emailed me saying:

    ~~~~~

    Thanks for contacting Apple.

     

    The device serial number on your case does not have an Activation Lock enabled. To get help for the issue you’re experiencing, you’ll need to contact AppleCare Support.

     

    You can start your support request online and get connected to an expert at the Contact Apple Support website:

    http://www.apple.com/support/contact

     

    [name]

    AppleCare Account Security

    ~~~~~

     

    Ouch. 

     

    I then recontacted the Apple Support person who had been helping me. He said he'd talked for 45 minutes with the Apple engineers and had one *last* idea.

     

    He had me log into https://appleid.apple.com/ > Password and Security, then he had me delete my Rescue Email Address (which was the same as my old/original Apple ID that has been stuck on my iPhone 5's iCloud account).

     

    After doing that he had me go to the Name, ID, and Email Adresses tab (which you see when you first log into https://appleid.apple.com/) and change my newer Apple ID back to my old original one. (Note: An email is required to verify each of these account changes.)

     

    Then I went into my iPhone's settings > iCloud, and YAY!!!! it let me log into my account!  Then I went to the bottom of the iCloud screen and deleted the account.

     

    Then I went back into Apple ID, logged in, and deleted the old Apple ID, re-entered my new one, and saved it. (Note: An email is required to verify each of these account changes.)

     

    Then I went back to my phone and entered my Apple ID's email address and password... and it worked!

     

    Now I just need to fix some stuff that got goofed up in all of the experimenting.

     

    If anyone else on the planet has read this much, I would recommend going back in and adding all the info you can to your Apple ID so that your backup addresses and aliases are right.

     

    Final thought: My problem was a result of an error/problem with Apple's product.  I kind of wish it was like other industries that try to compensate for their own mistakes (restaurant = free meal, airline industry = upgrade, etc.) because this took a LOT of my time.  But I do appreciate the support workers' perseverance in helping.

  • 4allyrose Level 1 Level 1

    Thanks for posting all the details. This worked for me!

  • iThunk Level 1 Level 1

    That's great, @4allyrose! Congrats!

  • mstrzepek Level 1 Level 1

    Worked for me too, the weird thing for me is that I hadn't changed anything recently, it just happed out of the blue today, anyway, all fixed thanks for posting, very detailed.

  • RhoadesD Level 1 Level 1

    Thanks. This solved my problem too!

  • iThunk Level 1 Level 1

    Glad it helped. That redeems some of the time spent when others benefit.

  • captain_cat Level 1 Level 1

    Just worked for me too! I wasn't getting much help from apple in store and didn't have the patience to wait another 45 minutes to talk to somebody who would likely have the same lack of answers on this issue.

     

    Thanks for the time explaining this!

  • iThunk Level 1 Level 1

    captain_cat, I'm gald to hear that it helped! Thanks for letting me know!

  • lrhilsendager Level 1 Level 1

    I know this is a lot later, but I've been having this problem for a while now and just been putting it up with it, re-entering my email, password, etc ... it will usually accept it (sometimes after the second or third try of entering it though), but ... I'm Sick of doing this. I will try you suggestions -- from all of the good responses you have received, I'm assuming it will work. And yeah -- they should compensate, or at least fix the problem with an update like they do everything else.