2 Replies Latest reply: Oct 26, 2014 12:38 PM by BoomBoomMe
KittyWhy Level 1 (0 points)

When I turn it on, it gets to the grey screen (no apple logo) and stays there for a long time, after which I get a black screen which says 'partition not found. grub rescue >'


I've previously used bootcap on my mac, setting aside ~150GB of space. However, I realised I wasn't using windows that much and wanted to free up space for my mac by deleting the bootcamp partition. When I tried using Disk Utility (both MacOS and SnowLeopard installation disc) I got the same error: "Mediakit: Partition not found". Decided to try to get around it using ubuntu's disk utility and deleted the bootcamp partition as well as one of the ext4 partitions (it took up a fair bit of space so I decided to delete it). Did not touch my Macintosh HD partition.


I then rebooted and realised I could no long boot into my mac. The partition is still there but when I press options at start up I cannot find it/boot it. Is there any way to get around this? Didn't do a backup for about two years so I would be losing all my work. Otherwise, is there any way i can recover my data (using another computer etc).


Thanks so much

MacBook, iOS 6.1