2 Replies Latest reply: Oct 15, 2013 8:32 AM by Geoff Roynon
Geoff Roynon Level 1 Level 1 (20 points)

I'm using Safari 6.0.5 under Mac OS X 10.8.5. When I visit the John Lewis broadband site at: https://www.johnlewisbroadband.com/standard/ it displays O.K. but none of the clickable links on the page work. The Error Console log shows a lot of strange text followed by: "Failed to load resource: Could not connect to the server."

Google Chrome 30.0 has the same problem with this site.

 

Firefox 24.0 works fine - all the links work.

 

Anyone else having problems with this site?


Mac Pro, OS X Mountain Lion, Canon iP4500 printer
  • Carolyn Samit Level 10 Level 10 (95,995 points)

    It's working ok here on Safari 6.0.5 / Mountain Lion v10.8.5

     

    Try troubleshooting extensions and third party plugins.

     

    From the Safari menu bar click Safari > Preferences then select the Extensions tab. Turn that OFF, quit and relaunch Safari to test. If that helped, turn one extension on then quit and relaunch Safari to test until you find the incompatible extension then click uninstall.

     

    If it's not an extensions issue, try troubleshooting third party plug-ins.

     

    Back to Safari > Preferences. This time select the Security tab. Deselect:  Allow all other plug-ins. Quit and relaunch Safari to test.

     

    If that made a difference, instructions for troubleshooting plugins here.

     

     

    Also, if your see Develop in the Safari menu bar between Bookmarks and Window click Develop. If you see any items that are checked in the drop down menu, click there one time to uncheck. Quit and relaunch Safari and try that website again.

  • Geoff Roynon Level 1 Level 1 (20 points)

    Thanks for the response Carolyn. I tried your suggestions but no change.

     

    I eventually solved the problem by removing my "Hosts" file and rebooting. I have a large hosts file which helps cut down on the advertising on web sites. Once this was removed the John Lewis site works as it should in Safari. Still a mystery why Firefox worked and Safari didn't.

     

    I'll need to try and find which element in the Hosts file is causing the problem now.