Skip navigation

Trouble with printing through 10.8 shared printer using lpd.

2911 Views 3 Replies Latest reply: Oct 15, 2013 1:39 PM by BDAqua RSS
tatthompson73 Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 15, 2013 9:28 AM

Hi, hoping someone will have had a similar issue.

 

I am using a OSX 10.8 mac mini as a print server.  I am using it as a print server because because i have clients that print across subnets and bonjour will not work for this application.  Previously with my 10.7 imac I had shared the generic printer aimed directly at the printers IP address.  Client macs aim at the print server using lpd (using ip or host name) and then the printer name (share) for the queue and also use the generic ppd. When a client adds this configuration aimed at the old 10.7 print server the printer would install and printing would be succesfull.  Now with the 10.8 print server a client (reguardless of client OS version) i get the "Unable to verify the printer on your network." when installing and printing fails. I have tried the proper ppd for the make/manufacture of the printer (i didnt think this would make a difference) I have tried using the cups commands as well:

 

cupsctl --share-printers

cupsctl --share-printers --remote-any

cupsctl 'BrowseLocalProtocols="cups dnssd lpd smb"'

 

assuming lpd was just not available and needed to be turned on...

I am able to ping the 10.8 on the network from clients verifying they can see the server

also have tried using ipp with no luck.

 

Anyone else had this issue and if so is there a work around?  Thanks!

iMac, OS X Mountain Lion (10.8.5), LPD Printing thorugh share

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.