13 Replies Latest reply: Oct 6, 2015 3:17 AM by FastFoxFive
RationalPuppet Level 1 (0 points)

The hide feature does not stop the songs from playing it only removes them from sight. Or how can I remove songs from my iCloud.


iPhone 5, iOS 7.0.2
  • norm123 Community Specialists

    Hello RationalPuppet

     

    If you go to Settings > Music and then toggle off Show All Music that will prevent from seeing your downloaded music. I have also provided other articles for hiding purchases and even deleting purchases from iTunes in the Cloud.

     

    Download purchased music to your iPhone

    http://support.apple.com/kb/index?page=tidetail&product=iphone&locale=en_US&tag= Music

     

    iTunes Store: Hiding and unhiding purchases

    http://support.apple.com/kb/HT4919

     

    iTunes Store: How to delete songs from iCloud

    http://support.apple.com/kb/HT4915

     

    Thanks for using Apple Support Communities.

     

    Regards,

    -Norm G.

  • probins2 Level 1 (0 points)

    Hi,

     

    I am having the same problem as RationalPuppet. I have turned off the Show All Music setting, and am still stuck with some songs that I do not want. I have tried swiping them to delete them, but it doesn't work.

  • xarmanno Level 1 (0 points)

    Hello all,

     

    It took me a while to figure this out, but there is a trick to only see & play the songs that are on your iPhone without playing any on iCloud.

     

    It's a bit of a work around, but here is the trick. As mentioned above, go to Settings > Music and toggle the Show All Music switch to the off position.

     

    Next, go to Settings > Cellular and scroll down until you see the Music setting and toggle that switch to the off position. This prevents your phone from using cellular connections to grab songs from iCloud to play.

     

    Special note ... if you are connected to wifi, this won't work, so you need to turn off wifi too.

     

    Hope this helps reduce the nuisance a bit. I also hope Apple adds a setting to disable that annoying feature in iOS 7 soon.

     

    -Xavier

  • tjinnz Level 1 (0 points)

    Hi there.

     

    I'm having the same issues. I've followed all of the above instructions and it's still showing music from iCloud on my iPhone. I have the settings off so in theory, cellular connections should not allow music from iCloud to come to my phone but this is making no difference - the songs are still there regardless of whether I'm logged into WiFi or just driving around, there are still extra songs coming up on my iPhone.

     

    I would really like to get this sorted so I don't have 'extra' music I haven't selected on my iPhone as it get's a bit boring having to constantly skip Christmas Songs throughout the year ...!!!!!

     

    I find iCloud anything but helpful so any tips to get rid of it off my phone would be greatly appreciated.

     

    Thanks.

     

    - Trisha

  • Dan Sette Level 1 (0 points)

    I have exactly the same problem as Trisha. I have just subscribed to iTunes match. I'm happy with everything being in the cloud EXCEPT the Christmas music - which I can import via playlist at the appropriate time.

     

    Is there a way of excluding a "genre" from being in the cloud? All my Christmas music is labelled "Christmas"

     

    Thanks Steve

  • Joseph Kannry Level 1 (5 points)

    Yes. See https://discussions.apple.com/thread/5676944?tstart=0

     

    Go to settings>general>usage>>storage>music app>edit and then delete

  • baileafholmez Level 1 (0 points)

    Okay, so I have done everything here, I turned off everything and all it did was delete all my songs EXCEPT the ones from icloud! Now all my music is gone except the songs I didn't want on there in the first place.

  • Tannubyky Level 1 (0 points)

    Sign OUT of the iTunes & App Store. You can do this by going into SETTINGS>ITUNES & APP STORE then clicking on your APPLE ID and choosing "sign out". Now apple has no idea what you have in the iCloud and will quit trying to play those songs! MWAHAHAHAHAHA take THAT apple!!!

  • Tannubyky Level 1 (0 points)

    If you have songs from iCloud showing up on your iPhone that won't delete, go into SETTINGS>MUSIC. Turn ON show all music. The songs you can't delete should have a "download from iCloud" icon. Download them. Once they are downloaded you can then delete them.
    *note- you will have to be signed into the iTunes & app store in order to download them.

  • Wr1ghty Level 1 (0 points)

    Hi there,

     

    I have tried all sorts of things in various posts to try and stop 'undesiarable' songs from pitching up on my phone when I don't want them to and this is the only thing that I have found that works:

     

    NOTE: This does mean that they are no longer playable via the cloud but just create a playlist of the music you DO want to listen to......

    Go to iTunes on your computer

    Open the iTunes store

    Scroll right down to the bottom of the page

    Under the heading 'Features' click on 'Purchased'

    Goto All Albums and here you should see all of the albums that you have bought all or part of

    Delete each one and when you resync your phone Hey Presto all of those songs that you didn't want have disappeared. (Well almost. In my case there's a Leonard Cohen song that just refuses to go but some might say that just serves me right!)

  • notredale Level 1 (0 points)

    This problem has been driving me insane.  I have iOS 8.4.1 and many of these "solutions" provided in the forums aren't even on the phone anymore.  In Settings --> Music, there is not option to show or not show all songs, it just says "Show Apple Music" which changes nothing.  Under Settings --> iTunes & App Store, I was able to stop my phone from using cellular data to play from iCloud, but this does nothing when my phone is on Wifi.

     

    Like many, I had a very well organized music library that I tailored carefully for my phone, iPad, and computer.  All the songs I put on my phone were intentionally put there, just like the songs that were not on the phone were intentionally left off.  Now iCloud plays whatever it wants without my permission, clogging up bandwidth, and Apple appears more driven to competing with streaming media platforms then honoring the iTunes purchases I've made over the years. 

     

    The only way, once and for all, to stop unwanted iCloud songs from playing was to sign out of iCloud altogether.  With all the privacy hacks/leaks popping up out there, maybe this is for the best anyway.

  • 4c10 Level 1 (5 points)

    I finally found the way.

    On your iPod -> Music.

    I have mine set to show by Artist.  In the middle of the screen it will say Artist.

    Touch the word and it will bring up another sorting window.

    At the bottom of the new window will be "Only Offline Music"  If you are seeing all kinds of iCloud music that you know is not yours, and you may not even be a fan of, turn this feature on. 

    When you return to the main music screen you will only have what you have loaded onto your iPod.

  • FastFoxFive Level 1 (0 points)

    Thanks 4c10, your solution worked for me on my iPhone. Now only the music on my iPhone is displayed! Yay!