1 Reply Latest reply: Oct 16, 2013 9:51 AM by lllaass
Rosie200 Level 1 Level 1 (0 points)

When I try and update an app, it's asking for the wrong email address/apple ID, and as it's an old account, it wont work!! Ive tried everything and all the settings are in the right email address so why is it asking me for an old one? I can't update or install any apps because of this and it's very irritating. CAN SOMEBODY PLEASE HELP ME?!?!


iPod touch, iOS 7