1 Reply Latest reply: Nov 26, 2013 6:48 PM by Alfred.tay
ghazala13 Level 1 Level 1 (0 points)

please guys i need help in this ------> The startup disk must be formatted as a single Mac OS Extended (Journaled) volume or already partitioned by Boot Camp Assistant for installing Windows.

  • Alfred.tay Level 1 Level 1 (0 points)

    I have attemted many times and finally solved this problem. I'll share my story of the whole process, perhaps you'll find some parts useful.

     

    I bought my new iMac i7 Haswell machine and gave a score of 11 out of 10. It's beautiful. But for work purposes, I need to install Windows. So I heard good things about Windows 8.1 and tried bootcamp. I successfully partitioned 2TB for Windows 8.1 and left 1TB for Mac without problem.

     

    I am quickly dissapointed with Windows 8.1 and decided to install Windows 7. However in Bootcamp Assistant, the option to remove Windows 8.1 is greyed out. I read many forums, from old to new, I decided to erase that partition using Disk Utility. But after doing so, Bootcamp Assistant still doesnt allow me to install Windows because the harddisk has to be singleton (without partition). Disk Utility is not able to combine the two partition for some reason. So after lots of googling, I manage to remove the partitions (Windows and a small partition for windows systems) using gParted, from http://gparted.org/ (download the ISO and burn into a CD)

     

    However, for some reason, Disk Utility is still not able to combine the partitions I erased. The partitions are some how arranged in an order with the Mac Partition sitting in the middle of two. eg. Partition 1, empty, Partition 2, Mac, Partition 3, empty. With lots of frustration, I decided to wipe everything using gParted again and then I manage to combine all partitions.

     

    I reinstalled OS X using USB created using DiskMakerX. This time Bootcamp Assistant gave me this error message. "Startup disk cannot be formatted...". I tried using cmd+R during boot and Disk Utility to review and repair multiple times, erase and reinstall multiple times, all failed. I also tried to remove the Recovery partition using commands in Terminal to get that final 600mb partition into the "singleton" hoping that Bootcamp Assistant will work. But unfortunately it doesnt work either.

     

    At that time I totally gave up and start using VMware with half the processing power. Then, for some reason, I decided to wipe the hdd again, this time, I did not choose "1 partition" in the partition tab. I realised I am so focus on getting it back to a singleton, everytime I erase, I make sure I selected "1 partition". I simply click the main hdd  and click erase. I use this picture from Wikipedia for example.

     

    http://en.wikipedia.org/wiki/File:Disk_Utility_screenshot.png

     

    I just clicked the "465.8 GB ST3500641AS Q" and clicked "erase". In the "Evolution" partition, there will be just one partition and labelled "Current".

     

    I reinstall OS X again and then Bootcamp Assistant works again.