4 Replies Latest reply: Oct 16, 2013 2:59 PM by hussdajani
hussdajani Level 1 Level 1 (0 points)

Dear community;

 

I hope all's well with you.

 

I would greatly appreciate your help with this as I have tried all options but I am still unable to get the desired result.

 

I am using a MacBook Air (OS X 10.8.5), an iPhone 5 (iOS 7.0.2) and an Apple TV (software 6.0).

 

All of them are working on the same WiFI network. All of them have the most updated softwares.

 

AirPlay is "ON" for the Apple TV.

AirPlay Mirroring is saying "No devices detected"

iPhone: I am unable to see the AirPlayin the command center.

 

I tried everything. Rebooting the systems and the router. Everything. Yet, the same problem remains.

 

Any advise?

 

Thanks.

 

H

  • Winston Churchill Level 10 Level 10 (87,350 points)

    Welcome to the Apple community.

     

    It sounds as though your router is blocking access for AirPlay.


    As with most router issues, I would recommend that you contact your ISP with details of your problem (assuming that it was your ISP that provided it to you).


    There are simply too many manufacturers with different software features and settings and often different names for such features and settings, that the best advice will likely come from those that are knowledgeable about your particular router.

  • hussdajani Level 1 Level 1 (0 points)

    Thanks for the prompt feedback Winston. Much appreciated.

     

    The ISP doesn't provide a router actually. I bought it myself. It is NetGear WNDR3400 N600 Dual Band Wireless Router.

     

    Are you familiar with it?

     

    Looking forward to your feedback.

     

    Cheers.

     

    H

  • Winston Churchill Level 10 Level 10 (87,350 points)

    Unfortunately not, do you have a manual or do they have online forums you can ask at.

     

    A frequent cause of consistent failure to enable AirPlay or HomeSharing at all, is the service being blocked on the network. Make sure your network isn't hidden, has a unique name, that MAC address authentication is disabled, security is set to use WPA 2 Personal and that there is only one router/device acting as a DHCP server and providing NAT services.


    Make sure your router/computer allows access over the following ports


    Port

    Type

    Protocol

    Used By

    53

    TCP/UDP

    DNS

    DNS

    80

    TCP

    HTTP

    AirPlay, iTunes Store

    123

    TCP/UDP

    NTP

    Network Time

    443

    TCP

    HTTPS

    AirPlay, PhotoStream, iTunes Store

    554

    TCP/UDP

    RTSP

    AirPlay

    1900

    UDP

    SSDP

    Bonjour

    3689

    TCP

    DAAP

    iTunes, AirPlay, HomeSharing

    5297

    TCP

    -

    Bonjour

    5298

    TCP/UDP

    -

    Bonjour

    5350

    UDP

    NAT

    Bonjour

    5351

    UDP

    NAT

    Bonjour

    5353

    TCP/UDP

    MDNS

    Bonjour, AirPlay, HomeSharing

    8000-8999

    TCP

    -

    iTunes Radio Streams

    42000-42999

    TCP

    -

    iTunes Radio Streams

    49159

    UDP

    MDNS (Win)

    Bonjour, AirPlay

    49163

    UDP

    MDNS (Win)

    Bonjour, AirPlay


    Refer to your router manual/manufacturer for any settings that are specific to that model.


    Another frequent cause of consistent failure to enable AirPlay or HomeSharing at all, is security software, in many cases configuring it correctly, disabling it or even uninstalling it can help, but in some cases the security software can cause problems that simply reconfiguring, disabling or uninstalling cannot reverse.


    If you are consistently unable to activate AirPlay, have tried all the steps in this article and have security software installed on your system, you might benefit from contacting its provider or participating in any online forums they run to discuss the matter with them.

  • hussdajani Level 1 Level 1 (0 points)

    Perfect! Thanks alot for this Winston.

     

    I am going to check all the provided info and will let you know tomorrow if the issue is sorted or not.

     

    Thanks again for the prompt reply.

     

    Cheers.

     

    H