1 Reply Latest reply: Oct 17, 2013 12:33 PM by Kappy
greg11872 Level 1 Level 1

i have had my HDD replaced and now my previously purchased versions of pages and keynote can't reinstall as it says it needs an earlier version of OS. what now?

  • Kappy Level 10 Level 10

    Buy later versions of iWork from the App Store. You need to have 10.7.5 or later installed. If you are using Snow Leopard now, then you may need to download updates to the version of iWork you now have.