4 Replies Latest reply: May 11, 2014 10:40 PM by Terence Devlin
Ike's MacbookPro Level 1 Level 1 (0 points)

how do I resolve this issue: Your photo library is either in use by another application or has become unreadable

  • ds store Level 7 Level 7 (30,315 points)

    1: Right or hold option/alt key and click on the iPhoto Library in your Pictures folder and choose "show package contents"

     

    Copy/duplicate the Masters or Originals folder (not the shortcut) containing your original pictures to the Desktop, close the window/folder. Copy to a external drive and unmount and disconnect.

     

    Make any other backups in case you have a much more serious problem.

     

     

    2: Perform this iPhoto rebuild

     

    http://support.apple.com/kb/HT2638

     

     

    3: If still having issues, then run through this larger set of Steps to narrow down your issue and repair your software.

     

    You might have User account or other permissions/problems which the Steps will solve or at least inform you if done methodically.

     

    ..Step by Step to fix your Mac

  • Terence Devlin Level 10 Level 10 (133,305 points)

    Rather more simple:

     

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Repair Database. If that doesn't help, then try again, this time using Rebuild Database.

     

    If that fails:

     

    Option 2

    Download iPhoto Library Manager and use its rebuild function. (In early versions of Library Manager it's the File -> Rebuild command. In later versions it's under the Library menu.)

     

    This will create an entirely new library. It will then copy (or try to) your photos and all the associated metadata and versions to this new Library, and arrange it as close as it can to what you had in the damaged Library. It does this based on information it finds in the iPhoto sharing mechanism - but that means that things not shared won't be there, so no slideshows, books or calendars, for instance - but it should get all your events, albums and keywords, faces and places back.

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one.  

     

    Regards

     

     

    TD

  • Dan Gilliam Level 1 Level 1 (0 points)

    Hi Terence,

     

    I am getting the same error after my computer froze using imovie and I had to do a cold restart. I have the iphoto 11 with latest updates and mavericks.

     

    I have a couple questions-

     

    1. I tried reparing permissisons in iphoto and it didnt work.

     

    2. I installed Iphoto Library Manager and my whole library appears to be there, but I cant watch any movies, it just says .tiff, cant open.  I also am not sure what I should do next. Do I rebuild from iphoto or from "iphoto library manager"?  Do I need to rebuild if I see everyting in iphoto manager?

     

    My question is-

     

    1. What should I do next to fix my iphoto library? Should I go to next step in iphoto and try to rebuild or will this potentially cause more problems?

     

    2.  How come I see all my photos and albums in iphoto library manager and iphoto still cant open? I want to ake sure I dont make this worse by doing the wrong thing next.

     

    3. Is there a way to view and see .mov files in Iphoto Library manager like you can in iphoto?

     

    4. Any suggestions on how to proceed twithout making things worse, would be much appreciated!

     

    Thanks,

     

    Dan

  • Terence Devlin Level 10 Level 10 (133,305 points)

    See my response to your duplicate post