4 Replies Latest reply: Oct 20, 2013 7:07 PM by Tom Gewecke
KTTJ1999 Level 1 Level 1

The letters on my mac book are not working , they have changed to latin??? How do i change them back to english please


Mac Pro
  • dominic23 Level 8 Level 8
    expertise.macosx
    Mac OS X

    Change your OS X language

    Your Mac is set to display the language for the country in which you bought the computer. For example, if you bought your Mac in the United States, your Mac is set to English. If you bought your Mac in France, your Mac is set to French. If you prefer to use a different language, you can easily switch languages.

    http://support.apple.com/kb/HT2490

    Best.

  • Tom Gewecke Level 9 Level 9

    KTTJ1999 wrote:

     

    The letters on my mac book are not working , they have changed to latin???

     

    Do you get the following when you type asdfg:  åß∂ƒ© ?   If so, it means your keyboard thinks that the  option/alt key is always being depressed.  It may mean your keyboard is damaged and needs to be replaced.  To test this, try an external usb or wireless keyboard.  If that works, the internal one is broken.

     

    If you do not get those letters, tell us what you do get.

  • fatboyray05 Level 1 Level 1

    I was having the same issue with my machine recently.

    Thinking it was an issue with the keyboard, I replaced it myself ( very much the pain in the butt ). After that i still had the problem. After trying to backup the machine, I totally hosed the OS. I finally gave up and reinstalled the OS 10.6.3 which it came with.

    I was able to get the machine running do all the updates and now am using the  OS 10.8.5.

    Works great with no problems.

     

    Hope this helps!

  • Tom Gewecke Level 9 Level 9

    Did you try an external keyboard before replacing the internal one?