5 Replies Latest reply: Oct 24, 2013 9:01 AM by UG64
monolith1985 Level 1 Level 1 (0 points)

Hi,

 

I just got given a iphone 3g as a hand me down, and I think im having problems with the wifi, but cant find anything sensible as fix (one video suggested put it in the oven)

 

when using safari, or internet apps (namely, facebook, kik, igotchat) and probably any other apps that need an internet connection, I get randomly "disconnected" for lack of a better word. on safari it says "no network is available, please connect to wifi" and kik says the same thing.  normally with safari i can just refresh the page a couple of times, and it will work, but when using the instant messenger apps, it just doesnt send or receive my messages, for hours,

 

the thing is, when all this is going on, i dont actully lose wifi, the signal symbol is there the whole time, I go into settings and my routers name is there, and also igotchat's wifi status always says its good.

 

So far ive tried changing my wireless channel on the router, and also trying to use it on a diferent internet connection, but the problem still persists (my home network is fine on all other devices)

i understand that im using "legacy" apps, and therefore not on the latest version, but im on the latest that ios 4.2.1 will allow, and im sure app developers/apple wouldnt just have people unable to use their old devices

 

so what im asking is there any fixes i can try, either with the phone, the router, or the apps, as currently its fairly unusable as an internet device
im pretty new to apple products (except my old ipod video) but im decent with technology so il try anything if it might help even slightly


iPhone 3G, iOS 4.2
  • UG64 Level 2 Level 2 (150 points)

    Don't put your phone in an oven!  Yikes!  This is an iOS problem with some third party routers.  The simple solution is to turn WiFi off and then turn it back on again when this problem occurs.  A more lasting work around is to set your wifi hotspot to use just one protocol, like 802.11g ONLY.  This will be in your router's configuration. 

     

    A solution that will cost more money than the phone is worth is to upgrade your router or buy a router made by Apple.

     

    You can read Apple's recommendations here http://support.apple.com/kb/TS1398

  • monolith1985 Level 1 Level 1 (0 points)

    hi, thank you for your reply

     

    I had changed the router to channel 11, instead of channel 13 with auto-set, which i mentioned in my first post, the next night internet in the whole house died for about an hour even when i tried resetting the router

     

    yeah a few suggestions stated it was to dry out the anntenna, but i didnt wanna risk it.
    I dont fancy turning the router off and on when this happens, as im currently switching the iphone into airplane mode and off again which kind of helps, but is a nuiscence just doing that.  also dont like the idea of paying out

     

    I have now set the router to only use 802.11g (it was using g, b and n) but so far (on safari at least) it still stops at the start of loading a webpage sometimes, saying server not responding, forcing me to refresh til it opens, but il wait and see if this does anything and il check over apples recommendations and post back tomorrow

  • UG64 Level 2 Level 2 (150 points)

    Hi Monolith

    I had changed the router to channel 11, instead of channel 13 with auto-set, which i mentioned in my first post, the next night internet in the whole house died for about an hour even when i tried resetting the router

    Changing the channel will help with the radio noise.  When you say the whole house died, are you reffering to the network going down or a power outage? 

     

     

    I have now set the router to only use 802.11g (it was using g, b and n) but so far (on safari at least) it still stops at the start of loading a webpage sometimes, saying server not responding, forcing me to refresh til it opens, but il wait and see if this does anything and il check over apples recommendations and post back tomorrow

    So, you are sill having the disconnection.  Another trick is something I use on my networks is to reserve the device's address on the network.  I have read some folks had success with giving their iPad or iPhone a Static address and that helped clear up the problem.

     

    As the admin at my office, I like to know what is running on my network and I reserve the addresses for everything on the network.  I've taken that practice home and my router allows me to reserve the addresses of my devices.  When I was having the problem you are discribing, my router then allowed me to reseve addresses, so when I dedicated the protocol to 802.11G only, the problem went away.  I never tested without a static address.

     

    If your router allows you to reserve an address, write down the settings for your network connection and enter them in under the Static tab in your phone's network settings which you will find under the blue > dot.  On your router, I'm assuming you are not running a server running the DHCP, but if your router is running the Dynamic Host Configuration Protocol (DHCP) you might find in the network settings to reserve the address for your devices.  In keeping it simple, just reserve your phone with the same address it already has, you will need to know your MAC address or under Settings>About your Wi-Fi address.  Before you clear or revoke the your phone's address in the address pool, put your phone in airplane mode so it won't creat conflicts as you enter the static address in the router.  After you create the reservation, save the settings and take your phone out of airplaine mode.  Cross your fingers.

     

    A rule of thumb, if you are working in your router's settings, make sure other devices on the network are not making any network traffic.  Take them offline or at least know that the router will restart knocking everything offline for a few minutes.

     

    If your router doesn't have a way for you to reserve addresses, then I'm afraid I can't help you any further, sorry.

     

    Best of luck,

    UG

  • UG64 Level 2 Level 2 (150 points)

    Hello monolith,

     

    So, you are still having the disconnection after changing the protocol to G only.  Another tip some folks have used to help clear this up, is to set up a Static address for your phone.  This is something I do at work, so I took the practice home. 

     

    Not all routers, will let you reserve addresses for devices, but some do.  If your router is the DHCP for your network, look in the network settings for resevations.

     

    If you can add a reservation, then add the one your phone is already using to see if this elimates the problem, at least on your network.

     

    -----

    If you know how to set up a reservation, you can skip this part.

     

    First write down the network settings that are on your phone under the blue > dot.  When you change from DHCP to Static, iOS will clear the settings, so write them down.

     

    Tap on Static and fill in the information you just wrote down for the static address settings.

     

    Now put the phone in airplane mode or turn off WiFi on your phone.

     

    Assuming you can add a reservation to your router, you will need to know you phone's MAC address (Settings>About WiFi address) so you can find it in the address pool. 

     

    Your phone's address in the pool should be the same as what you wrote down already and revoke the address from the pool.

     

    Now you can make the new reservation and type in the IP address, the MAC address and a description of your phone, typically.

     

    Save the settings and the router will probably restart the network, so make sure anything already on the network is ready to go offline for a minute or so.

     

    Take your phone off airplane mode and it should join the network.  If it doesn't, confirm the addresses are the same and make sure the MAC address is correct.

    ----

     

    If your router can't take a reservation, then the only other suggestion I can make is to aquire an Apple router.  Check around ebay to see if you can't get an old AirPort Extreme Base Station (the ones that look like a space ship) and attach it to your nettwork as a subnet.  I just spotted some on ebay for under $10.  Also if your network is secure, just make sure the subnet is also secure. 

     

    If you're unfamilar with Apple routers, you set them up using software from Apple, so if you have a Windows PC you will need to download the AirPort Utility software http://support.apple.com/kb/DL524 and install it on your PC.

     

    Beyond that I'm afraid I can't help, sorry.

     

    Best of luck,

    UG

  • UG64 Level 2 Level 2 (150 points)

    Sorry for the redundant double reply, but the website went goofy and I can not see my post when I'm signed in.