2 Replies Latest reply: Oct 21, 2013 1:19 PM by Dennis Robinson4
Dennis Robinson4 Level 1 Level 1 (15 points)

Using 10.5.8 on a MacBook. There have been attempts to upgrade system with no success.

Now when opening iTunes, error message reads we need newer version of quicktime. Says

we need 7.5.5 and am running 7.3.0. How do I update this software?