Previous 1 2 3 4 5 6 Next 82 Replies Latest reply: Dec 19, 2013 6:50 AM by Vexver01 Go to original post Branched to a new discussion.
  • Lilig Level 1 Level 1 (0 points)

    @Plmegalo & SomeMacUser1

    A BIG thank you !

    The 6.1 update gave me several problems too (slow down, a few crashes, couldn't use plugins like addblock or clicktoflash, some Flash animations I use at work didn't load at all...).

    Was quite frightened to use some "sudo" command and missed a heart beat when I pressed "enter" but all worked as you said (I'm still on Lion)

    Great tip !

  • lisafink Level 1 Level 1 (0 points)

    The Safari 6.0.5 update is no longer available at Has anyone found it anywhere else?

  • wollbratt Level 1 Level 1 (0 points)

    As with 7sk_city, after i tried the following command, safari stopped working altogether.

    I copied the exact line of text, but replaced "10.8" with "10.7" as I am a lion user, that is 10.7 and not 10.8.

    This is what i copied: "sudo tar -xvf /Library/Application\ Support/Apple/.Safari6.1-10.7Archive/SafariArchive.tar.gz -C /"

    First i tried with the code including 10.8, but terminal let me know that it could not find the file written. When i replaced the 10.8 with 10.7, it seemed to work, alot of commands where appearing automatically for a few seconds. When it was done, I copied the line "sudo rm -rf /private/var/db/receipts/*"

    And nothing special seemed to happen. But I guess it worked as it should. Then I restarted the computer, and afterwards tried starting safari. Now it says i cannot start safari. I get the option to try again, which leads to the same error, or report (which doesnt do nothing), or ignore which shuts it off completly.

    So no I have no safari whatsoever, which ***** balls. I have no idea what happened, cause I did use the exact command (replaced the 10.8 with 10.7) and no it will not start.. Got any suggestions ?

  • DrSFG Level 1 Level 1 (0 points)

    It seems to be at the bottom of the page for Safari 7.0

  • DrSFG Level 1 Level 1 (0 points)

    Try using Pacifist to replace the version you have with a newly downloaded version of Safari 6.0.5. If you are using Lion, shouldn't you be using 6.0.4?

  • 7sk_city Level 1 Level 1 (0 points)

    i had the same problem. I just reinstalled whole systeme as it was said before. It took about 2 houres

  • SomeMacUser1 Level 1 Level 1 (0 points)

    Wollbratt, I’m not sure why Safari wouldn’t start up, but I’d check the following (it’s what I have done):


    1) Have you applied the second command given in plmegalo's answer Re: How can I downgrade Safari 6.1 to 6.0.5?

    sudo rm -rf /private/var/db/receipts/*

    2) If Safari still doesn’t start up, try trashing the folder named ‘Safari’ within the Library folder of your user home folder, and also delete the Safari preference files and, that are located in the folder ‘Preferences’ within that Library folder.


    (To get to your user Library folder (not the other ‘Library’ folders of the system!), click the Go menu of the Finder's top menu bar, hold down the Option key ⌥, and choose 'Library'. )


    Beware, this deletes installed Safari extensions (but not plugins – they are located in a different folder) as well as reading list items and bookmarks – so, before deleting the Safari folder, you might want to save your bookmarks by dragging the file ‘Bookmarks.plist’ from the Safari folder to the Desktop first. Later, if Safari does start up, use File > Import Bookmarks to re-insert them.

  • wollbratt Level 1 Level 1 (0 points)

    It is at the bottom, the version 6.0.4(u r right about it shud be 6.0.4 and not 6.0.5), but when I click on that link I get "403 Forbidden" and says "You don't have permission to access /content/downloads/23/43/041-9947/nhdrfwwon5q2z00wm0i88hbd643yxo82dj/Safari6.0. 4Lion.pkg on this server." "Apache Server at Port 80" So it will not work.

  • wollbratt Level 1 Level 1 (0 points)

    When I use pacifist, it turns out like this. I open the package "Safari5-1-7LionManual" with pacifist. Then the files are displayed. It is not possible to click on "install" button, no matter which files I select. The only option is to choose "extract button". If I choose "Contents of Safari5-1-7LionManual.dmg" to extract I get the error message "“Safari 5.1.7 for Lion” couldn’t be copied to “7C94D49C-D72E-43E7-B6B9-0473B8CBCEC9 Contents” because an item with the same name already exists." and if I choose continue I get error message "The file “PubSub” couldn’t be opened because there is no such file." And it continues like that with all files.


    If I instead choose to extract the file called "Contents of Safari5-1-7LionManual.pkg" it starts extracting. It creates a folder called "Safari5.1.7LionManual Folder". In that folder there is several subfolders like "system, usr etc..." but I cannot see any dmg's or anything similar to continue from. So it seems it doesnt work.

  • wollbratt Level 1 Level 1 (0 points)

    Thanks for giving me some advise. I tried exactly what you said. But with no luck. I turns out the same. Now when I open safari, it looks like it runs, but without no window. I I click a new window, nothing appears. And after a while, it shuts down.

  • SomeMacUser1 Level 1 Level 1 (0 points)

    Something is different on your system, and I wonder if you have already tried the usual routine of repairing permissions (using Disk Utility) and resetting home directory permissions (boot from the Recovery HD … see instructions at

  • wollbratt Level 1 Level 1 (0 points)

    yes, I have done that. As matter of fact three times to be sure. Still safari will not start. Guess I have to reset the whole system. Too bad as it takes time to back up all the data and downloading a new copy of OS x lion and then resetting. Nice for those of you who got it to work, but beware that not all got successful result by using those codes mentioned in earlier posts.

  • SomeMacUser1 Level 1 Level 1 (0 points)

    OK, here's my last bid: After repairing all permissions (system + home folder), trash the folder 'Safari' located within the folder ‘Macintosh HD/System/Library/StagedFrameworks’. Then run the Terminal commands again (I just tested it – the trashed folder is created anew during this re-install). To trash this folder, you need to have Administrator permissions on the Mac.

  • Lilig Level 1 Level 1 (0 points)


    You can also try first to uninstall Safari completely (after a backup!) with a software like Appcleaner, so you avoid any conflict between two files, the old that could remain and a new one. Then run the terminal commands as said above.

  • wollbratt Level 1 Level 1 (0 points)

    Thanks for your time. It actually worked. I dont know how, but I did what you said "repairing all permissions (system + home folder), trash the folder 'Safari' located within the folder ‘Macintosh HD/System/Library/StagedFrameworks’. Then run the Terminal commands again". The version now is 5.1.7. I would like it to be 6.04 as i found the first 6 versions to be quite nice, everything seemed to be going faster overall. But after the 6.1 upgrade all that dissapeared. Is it any way possible to get it to be 6.04 ?


    thanks alot!