Previous 1 2 3 4 5 6 Next 84 Replies Latest reply: Oct 29, 2014 7:58 PM by Ennaylloh Go to original post
  • thefullmonti Level 1 Level 1 (0 points)

    Had Mavericks for about a month now with no problems, then out of nowhere this pops up. Was even completely freezing up when I tried to do anything. Terminal fix worked right away, thanks shellcode!

  • joolsjoint Level 1 Level 1 (0 points)

    I'm typing this on my MBP because I can't get into my MBA at all.

     

    I was going to upload a photo to iPhoto but got the message that I needed to upgrade iPhoto before I could do so. Fair enough. Did the 'upgrade all' thing. Restarted the computer. Logged in and I keep getting the %$^&*@ demand for my keychain password. As far as I know, I don't even have a keychain password. Have tried to use my Apple ID password - didn't work. Have tried to use my computer log in password - also didn't work. None of the above suggestions are possible because I can't get into the computer at all.

     

    This is seriously annoying me. I was actually in an Apple Store yesterday. If I'd known this was going to happen, I'd have taken the MBA with me for some hands on help.

     

    I'm useless with technical stuff, which is why I got Apple in the first place.

  • joolsjoint Level 1 Level 1 (0 points)

    So I did a naughty thing and just turned the computer off (what else could I do?) and I did try Shellcode's solution. I clicked on the lock at the top left of the window, to lock it. Then I clicked to unlock it and now nothing's happening at all. I would have described it as 'pinwheeling' before but now the pinwheel's gone and I've got that multi-coloured twirly thing just going round and round.

     

    I read the further comments about logging in to terminal or something but I have no idea what terminal is. I thought Macs were supposed to be user friendly?

  • mlagrand Level 1 Level 1 (0 points)

    I don't have a login keychain. I only have a Local Items, System, and System Roots. I can get into my System keychain, but cannot for the life of me get into my local items, as it is an unknown password.   And I just keep getting the popups.

     

    This only occurred this evening when I performed a system update to Mavericks.

     

    I am so sorry I upgraded to this OS. Snow Leopard worked so much better for me and my MBP.

  • Clif H Level 1 Level 1 (115 points)

    @mlagrand: follow the thread. You don't need a password for Local Items if all you want to do is delete and reset it. See shellcode's first-page post on Oct 24, 2013 11:52 AM for the resolution. It works.

  • joolsjoint Level 1 Level 1 (0 points)

    I did what shellcode said to do but my MBA can't reset it because it says it's not there. Not saying shellcode's advice is wrong, only that my problem with Keychain is obviously different. Now I won't be able to make it into an Apple Store until after Christmas.

  • Clif H Level 1 Level 1 (115 points)

    If you are trying to reset the keychain you are reading the wrong post. He posted later at that specific date/time. Sorry cannot link to it directly, but it is there. Basically you have to delete ~/Library/Keychains/FolderWithAllTheNumbersInIt then restart.

  • mlagrand Level 1 Level 1 (0 points)

    Shellcode's solution doesn't work for me either, as I don't have a LOGIN KEYCHAIN

     

    After rebooting, I get the following messages:

     

    Keychain "login" cannot be found to store "registrationV1."  When I select "reset to defaults" it asks me to use my login password, which I use, and then I get the same message. It is a loop.

     

    When I cancel out of that loop, I get iCloud password:  please enter your password for {email address}.  When I type it in, I get the message

    Keychain "login" cannot be found to store "email address-AuthToken."

     

    Unless anyone has a better idea, I'm thinking about restoring my computer from my last time machine backup and going back to Snow Leopard.

     

     

    Besides this problem, since I upgraded to Mavericks my MBP takes about 1 minute to connect wirelessly to the internet. I'm wondering what the benefit of Mavericks is.

  • joolsjoint Level 1 Level 1 (0 points)

    Same thing happening here, mlagrand.

  • mlagrand Level 1 Level 1 (0 points)

    Clif H, I don't have a folder with numbers in it located in the Library/keychains folder.   I only have four documents:

     

    Applepushserviced.keychain

    Aspd.keychain

    System.keychain

    System.keychain-orig

     

    Maybe it is because I've tried to reset to default so many darned times. I dunno.

  • Clif H Level 1 Level 1 (115 points)

    Seems a lot of confusion over what Local Items is. This is simply the items from the local login or system keychains that are eligible to be saved to OS X 10.9's iCloud Keychain, regardless of whether or not you use it. Think of it as a "staging area" for potential iCloud Keychain activation later on.

     

    That said, I saw the missing login keychain / registration v1 same errors on a Mac 2 days ago and rectified by the following the steps outlined in page 1 of this thread. In detail:

     

    1. System Prefs > iCloud > Keychain. Make sure Keychain is UNCHECKED (no iCloud Keychain).
    2. Applications > Utilities > Keychain Access > Preferences. Click "Reset My Default Keychain" to be sure login keychain is wiped/reset.
    3. Switch to Finder > Go menu > Go to Folder... Enter "~/Library/Keychains" in the field. (NOTE: ~/Library is not /Library/Keychains - totally different folders. Be sure to include the tilde character).
    4. Find the folder with the bunch of numbers in its name. Often the only folder there. Move it the Trash.
    5. Restart you Mac.
    6. Create a new keychain when/if prompted. Make sure the password matches your account login.

     

    Note: this is just about the same steps shellcode outlined in his earlier post.

  • joolsjoint Level 1 Level 1 (0 points)

    I will try those steps again, ClifH, but I repeat my earlier comment:  I thought Macs were supposed to be user friendly. Nothing like this has ever happened before; I've done loads of updates and they've all just 'worked'. This one has been a nightmare.

  • Clif H Level 1 Level 1 (115 points)

    OS X's keychain can be a blessing and a curse. Mavericks introduced the potential to move every user name and password you ever used as well as credit cards and banking info into Apple's cloud service safely and securely. No small feat by any means. And if you want pain, try editting the Windows registry or tracking down viruses in msconfig. The grass is not always greener.

  • mlagrand Level 1 Level 1 (0 points)

    Thanks Clif H for spelling this out.  See my comments:

     

    1.  Cannot get into my iCloud system prefs as when I try to login, I get another "keychain not found message."  However, I CAN see that keychain is not checked so I will go to step 2.

    2. When I go to keychain preferences, and click on Reset My Default Keychain, I get a message that says UNIX[invalid argument]

    3-4, found that folder with the numbers in it. Moved it to trash.

    5.  Rebooted, no pop ups after I logged in, seems promising!

     

    Got into Safari, and all of the popups started again. Never prompted for a new keychain. Experiencing same problems with resetting defaults as described above. I want to tear my hair out!

  • joolsjoint Level 1 Level 1 (0 points)

    I've never had to try. I hate Windows, having used is almost exclusively since I tumbled into computers compulsorily in 1997. I know for sure that the grass most certainly isn't greener over there but I am surprised that a simple update to one or two applications would cause this sort of mayhem in the Apple system.