Previous 1 2 3 4 Next 431 Replies Latest reply: Jul 26, 2014 9:33 PM by Justin From Milwaukee Go to original post
  • KiltedTim Level 8 Level 8 (46,525 points)

    Scott Rose wrote:

     

    This is one of the largest bugs in Mavericks’ Mail app, which affects Gmail accounts and Google Apps email accounts.

    I understand what you're saying, but I believe the blame for this really needs to be placed on google for their non-standard handling of IMAP folders. It's not possible for a message to be in more than one IMAP folder at a time. It IS possible for this to happen with gmail.

  • nickleonard Level 1 Level 1 (0 points)

    I'm having the same problem today, having installed Mavericks last night. If I move emails out of my inbox using an IOS 7 device, then these seem to stay where they've been moved to on that device, but they still show up in the inbox on the Mac.

  • jonny-green Level 1 Level 1 (0 points)

    Yes, second this. The solution does not work for apps accounts when using a custom domain. "All Mail" -> "Show in IMAP" has always been marked as visible for me, and I am unable to move messages from my inbox in Mavericks.

  • ryan_powers Level 1 Level 1 (0 points)

    Here is the work around I have for this issue

    after moving a message to another folder go to the folder then back to the inbox

    the message will appear back in the inbox

    select the message and choose archive this will remove the inbox label that is causing it to show up in the inbox

     

    annoying but at least I can move messages out of my inbox

    hope this gets fixed by apple or google

  • peterfromtelford Level 1 Level 1 (0 points)

    Same for me.

    Custom domains, Show All never turned off.

  • Scott Rose Level 3 Level 3 (895 points)

    Actually, the bugs in Mavericks Mail (for Gmail users and Google Apps users) get even worse:

     

    Mail no longer recognizes custom-mapped folders for "Sent Mail" and "Trash". Mail in Mavericks FORCES deleted messages to go into Google's Trash, instead of the custom-mapped folder that you might have created for yourself.

     

    This is terrible, because if you use Google's Trash, your deleted messages will automatically delete after 30 days. But if you use your own custom-mapped Trash folder, then you can keep your deleted messages around forever.

     

    Furthermore, if you DO try to use a custom-mapped folder in Mail, those folders will appear compeltely BLANK in Mail, even if they already contain thousands of messages in them. So you can't even go back and look at your previously-trashed messages from before Mavericks! You have to log into the Gmail website.

     

    Terrible!

  • KiltedTim Level 8 Level 8 (46,525 points)

    As I already pointed out, Google's handling of IMAP is non-standard. No folders actually exist in gmail, only labels. They "translate" labels to folders, but it's not the same thing.

  • jonny-green Level 1 Level 1 (0 points)

    I've managed to get this working now. I turned "Show in IMAP" off, waited for a bit, then turned it back on again. After a few minutes, mail started downloading thousands of messages (it may also help to restart mail at this point). I also noticed that the old, "[Google Mail]" folder (the icon was filled with white unlike the others) that previously contained "Important" and "Starred" had disappeared, but "Important" and "Starred" had risen to the top level, with standard folder icons. I then hid those in IMAP via the gmail settings. Once mail caught up with the downloaded messages, everything is back to normal and I am able to file and delete messages again.

  • epaulino Level 1 Level 1 (0 points)

    jonny-green, but didi you select "Show in IMAP" in system labels or "Labels"? I have the "Show in IMAP" selected in system labels, but it still doens't appear...

  • jonny-green Level 1 Level 1 (0 points)

    "All Mail" in "system labels". I unchecked it, waited, then checked it again. All I can suggest is that toggling the control like this forces Mail.app to refresh the account in some way.

  • Scott Rose Level 3 Level 3 (895 points)

    You just need to quit and relaunch Mail.

  • Massimo Gallina Level 1 Level 1 (0 points)

    Enabling "All Mail" is NOT a solution... it does not matter in anyway with Mail.

    Mail 7.0 (1816) at this moment is the ONLY mail client that is not able to use correctly label/folder in GMAIL. It's not a problem of Google 'cause if u use Mail 6 everything's ok!

    This problem with Mail 7 - Gmail was know since last GM 13A598... i supposed it was fixed in version 1816 of Mail.

    Fix it as soon as possibile cause i don't wanna use other client mail as Airmail or PostBox

  • jonny-green Level 1 Level 1 (0 points)

    Massimo, for a lot of people here, "All Mail" has always been enabled. This detailed article http://tidbits.com/article/14219 suggests in Mavericks it should be kept enabled. Are you saying it should be disabled? Can you provide any reason for this? Thanks

  • connollybob Level 1 Level 1 (0 points)

    Similar question to this thread... not sure where to put it. With Mavericks, I'm now getting multiple copies (31 copies over a 12 minute period for this one) of the same gmail message in my trash. Any suggestions on how to prevent?

    mail.png

     

    Bob

  • nickleonard Level 1 Level 1 (0 points)

    Hi Bob, I noticed this happening to me a couple of weeks ago while using Mountain Lion, so it doesn't appear to be something 'new and exclusive' to Mavericks.

Previous 1 2 3 4 Next