Previous 1 28 29 30 31 32 Next 431 Replies Latest reply: Jul 26, 2014 9:33 PM by Justin From Milwaukee Go to original post
  • ElPapa Level 1 Level 1 (0 points)

    Oh I hear ya.. all I can tell you is that Airmail works, Thunderbird works, and Mail in 10.8 worked.  Mail in 10.9 just.. poops out.

     

    Maybe I'll re-tweek settings and try again.  For now I'm limping between two email programs.

     

    Thanks again for your interest.

  • JuanEspejo Level 1 Level 1 (0 points)

    I had the same issue.

    In this thread, I read about checking the "all mail" checkbox.

    It was already checked.

    So I unchecked it and marked it again.

    I don't know if that solved the problem, but the thing is that

    by openind the "activity" window

    I could see the Mail app was downloading messages (as many people here have explained). When it finished (about two days) it started working properly. No issues since.

    I suggest you open the "activity" window and see what the app is doing.

  • maplavi Level 1 Level 1 (0 points)

    Hello again, I unchecked the Show in IMAP option for All Mail on Thursday night. The activity window keeps showing folders being synchronized even if no changes are made. It never stops. Not sure if this is normal behavior and eventually it will stop. Any help would be highly appreciated.

  • Barney-15E Level 8 Level 8 (43,320 points)

    Depending on how much email you have, it may take a while to sync.

    If it doesn't stop, you could remove the gmail account and re-add it. However, that will have to sync all your other folders.

     

    If you've been using Gmail for a while and have never changed the trash settings, everything you ever deleted is still sitting in the All Mail label/mailbox. That could be a huge number of emails.

  • maplavi Level 1 Level 1 (0 points)

    I'll wait a little longer. I just moved from Office 365 to Google Apps. I migrated all my mailboxes through migrationwiz.com. I'm not really happy with the change because all these problems with Mavericks Mail. I'm not really convinced in using some other email client. Thanks for your help.

  • Chris Elley Level 1 Level 1 (5 points)

    Hello All,

     

    Right or wrong, I seem to have finally found a solution that works for me.  Here is what I have done to get Apple Mail in Mavericks 10.9.2 to sync properly with Gmail.  I have done this succesffully on all three of my machines (iMac, MacBook and MacMini).

     

    Gmail Setting Prerequisties

    Settings > Forwarding/IMAP - As you would expect, IMAP needs to be turned in your Gmail settings (if you have found this post, I'm guessing that's not your issue).  I have had success with Auto Expunge turned on in my Gmail IMAP settings.  I am not liming my folder size.

     

    Settings > Labels

    I have read that you must have Show in IMAP checked for All Mail when syncing with Mavericks, while it needed to be unchecked for Mountain Lion.  I can't speak to this need, but I can tell you that Show in IMAP for All Mail is checked in my functioning system.  In fact, I have everything checked except Chats.  I am "showing" Starred, Important, Sent, Drafts.  I am "hiding" Chats, All Mail, Spam and Trash.

     

    On your Mavericks Mac:

    1.  Remove all Gmail accounts from your system using System Prefs > Internet Accounts.  This includes all of it, not just mail.

    2.  Restart just to be safe.

    3.  In System Prefs > Internet Accounts, add your Google account with all components EXCEPT the mail component; leave Mail unchecked.  At this point, your Contacts, Calendars and Messages should begin functioning throughout the OS.  I have experienced a probelm with Notes activating on one of the machines.

    4.  In Apple Mail, select Preferences from Mail Menu.  Do not select Accounts directly from Mail menu, because this will take you back to System Prefs. 

    5.  Inside Mail Prefs, select the Accounts tab.

    6.  Select Plus Sign to add a mail account.  Do NOT select the Google preset, as doing so seems to create infinite sync problems.  Instead select Add Other Mail account. - I don't understand it, but I suspect this step is the real trick.

    7.  Enter your full Gmail email address (user@whatever.com) and password, plus your name as you'd like it to appear.

     

    8.  Account Information Tab

     

    Enable, Description, Address and Name as previously entered.

    Incoming Mail Server: imap.gmail.com

    User Name: Full Gamil address (user@whatever.com)

    Password: Google Password

     

    9.  Outgoing Mail Server (Edit SMTP List)

    Server Name: smtp.gmail.com

    TLS Certificate: None

    (Advanced Tab)

    Use Default Ports 25/465/587

    Use SSL

    Authentication: Password

    User Name: Full gmail address (user@whatever.com)

    Password: Google Password

     

    10.  Mailbox Behaviors Tab

    Uncheck Drafts

    Uncheck Sent

    Check Junk (I left as Never)

    Check Move Deleted to Trash

    Check Store Deleted on Server (I chose to delete after one month old)

     

    11.  Advanced Tab

    Leave Checked - Include when automatically checking

    Leave Checked - Automatically download all attachments

    IMAP Path Prefix: [Blank]

    Port: 993 Use SSL

    Authentication: Password

    Leave Checked Use IDLE command if server supports

     

    12.  Close Mail Prefs / Accounts window.  Save settings.

     

    With my Gmail account that's been around for many years, it takes a really long time to do the initial sync.  At first, it seems like nothing is happening, but I've left it overnight and come back and it's worked itself out.  However, with my newer Gmail account, it gets fully initially synced within a minute or two and stays up to date.  If you have a large gmail account, I suggest creating a test account just for the purposes of proving the methodology on your system.  In Gmail, you should add it to your overall Google account, so you can be sure all the settings are shared between your old account and the new.

     

    To test success on my machine, I exchange a conversation between my new gmail account and iCloud exclusively inside Apple Mail.

     

    I have attempted to include every setting, because I know this combination has worked across multiple machines and I can repeat it.  Some settings probably have zero effect, while making a change to something seemingly benign could potentially cause problems.  Once you get the system working, you can experiment with the individual settings and post back the more detailed of intricacies of what can be altered.

     

    After completing these steps, you'll see that System Prefs > Internet Accounts at the system level has updated itself to check Mail on your Google account where you had previously left it unchecked in Step 3.

     

    For now, I really hope this can get you back to normal real-time synchronization.  Under these settings (after an initial massive sync), my IMAP response time seems perfectly normal, from instaneous to a mintue on the long end.

     

    Good luck; I really hope it works for you and ends some huge headaches.  I'm just a user who just wants to use email.  It is likely I will not monitor replies to this post, but if I find anything new or different to what I've written here, I'll add it to the thread.

     

    Chris

  • maplavi Level 1 Level 1 (0 points)

    Hi, I have not tried your solution since I don't like the idea of showing All Mail in IMAP. My main issue with it is that in my particular case if I make a search in Mavericks Mail or if I'm reading a thread, the link showing the location of any particular mail points towards the "All Mail" folder instead of the folder where is located. Could you please tell me if this happens to you too or if after the long initial sync, the location points to the actual folder. Thanks for your help!

  • Owen Laws Level 1 Level 1 (0 points)

    I had the same problem, think it's fixed now.

    Bought a demo MBP with Mavericks preinstalled, about a week ago. Updated to 10.9.3. Migrated my stuff from my Time Capsule, documents but not programs.

     

    Set up Mail and it was really a mess. I have 3 :-( Gmail addresses, + iCloud. Mail synchronized continually. Took several hours, and I don't think new mail was loading properly. When I quit after a completed sync and restarted, syncing started all over again.

     

    I tried Chris Elleys instructions first but after 3-4 hours of syncing, they didn't work. After restart, a new round of syncing began immediately. Could be I was a bit sloppy though.

     

    I bought The Tidbits ebook Take Control of Apple Mail and followed the simple instructions "Set Up Mail to Use Gmail" that start on page 70. They are basically the same as Chrises instructions but simpler. Don't know if it's ok to copy-past the instructions, they're not very long. But basically:

    - Delete all Gmail accounts in System Preferences -> Internet Accounts (if you've already installed).

    - Go to Gmail and set your account settings for each address so that the defaults are on (if you've changed them before). Make sure IMAP is on,  and in Labels the "checkboxes for All Mail, Sent Mail, Drafts, All Mail, Spam, and Trash are selected".

    - In Mail Preferences, set up each account with the Gmail button.

    - Sync again (use a network cable if you can, faster and stabler than WiFi).

     

    That did it.

  • ElPapa Level 1 Level 1 (0 points)

    With 10.9.3 I can confirm the version of Mail that ships with it works exactly as I would expected it to work with GMail.

     

    Now if Apple can just keep it that way...

  • maplavi Level 1 Level 1 (0 points)

    Yes it seems that it's finally working. In my case, I'm not sure if it's because I finally checked the Show in IMAP for All Mail or becuase of the lastest Mavericks update. In any case, I'm glad that the eternal syncs are finally over.

  • Barney-15E Level 8 Level 8 (43,320 points)

    maplavi wrote:

     

    Yes it seems that it's finally working. In my case, I'm not sure if it's because I finally checked the Show in IMAP for All Mail or becuase of the lastest Mavericks update. In any case, I'm glad that the eternal syncs are finally over.

    I have always had All Mail disabled in IMAP, and my Mail and Gmail has always worked in Mavericks. I have had Gmail set up to delete emails that I delete as opposed to leaving them in All Mail since Mavericks.

    But, I can't explain why it works for some and not for others.

  • Doug Lerner2 Level 4 Level 4 (1,030 points)

    Is there any formal statement from Apple about upgrades to Mail in 10.9.3 regarding fixes for Gmail?

     

    doug

  • barkofdelight Level 1 Level 1 (25 points)

    Apple's official release notes don't mention Mail at all.

     

    So I guess it is up to us to decide if the most recent changes in Mail (now at version 7.3) have fixed our problems.

     

    Is there anyone who had serious GMail problems still reading this who can test? Or have you all long since moved off of Apple's Mail?

     

    Bark.

  • Owen Laws Level 1 Level 1 (0 points)

    Installing the update didn't help me, as I wrote above. Good luck :-)

  • cmoralespv Level 1 Level 1 (0 points)

    Mapalvi,  I am extremely annoyed by the search behavior you mentioned in your post.  That it always displays the "all mail" folder instead of the folder the mail is actually in..

     

    Did you ever resolve this issue??  I posted this issue in a few places and never got anyone to reply about this issue.

     

    Thanks