Previous 1 2 3 Next 44 Replies Latest reply: Apr 2, 2014 2:28 PM by nouveauphoto Go to original post
  • ratiolegis Level 1 Level 1 (0 points)

    I'm one of mid 2010 17" MBP users.

     

    I've also tried every tips mentioned in the above posts, but still no working.

     

    If Firmtek FAQ you linked is true, what I do next? How could this happen?

     

    Just wait until Apple resolve this issue without any promise of  deadline?

     

    Already I spend so much times and energy to solve this.. This is so annoying really, huh?

  • ratiolegis Level 1 Level 1 (0 points)

    Also This is interesting too.

     

    "The SeriTek/6G is also backward compatible with 2010 and 2009 MacBook Pro 17" models. However, pre-2011 MacBook Pro models will provide slower Read performance and are not bootable with the SeriTek/6G. For maximum performance, FirmTek recommends utilizing the SeriTek/6G with the 2011 Apple 17" MacBook Pro." (http://www.firmtek.com/seritek/seritek-6g/)

     

    That is to say, pre-2011 MacBook Pro models have PCI express card 1.0? Not 2.0?

     

    I'm thoroughly confused right now.

  • cascag Level 1 Level 1 (10 points)

    It´s interesting how apple dealing with support, because I don´t see any response till now.

    But I think they are very busy fixing many of the problems from Mavericks.

    I research many days and trying a lot because I need to work with my drives and I don´t know when

    Apple will really see our posts and fix the things.

     

    Anyway, about the ExpressCard the key thing to do for me was change this kext file (IOPCIFamily.kext)

    that I copied from Mountain Lion. I used Multibeast because I couldn´t find drivers

    for my ExpressCards. If you have the drivers for your cards maybe install them and change this kext file like

    I put in the previous post.

     

    Good luck!

  • captainpeter Level 1 Level 1 (0 points)

    I tried the suggested method of replacing IOPCIFamily.kext with a copy from Mountain Lion, rebooted (after repairing permissions) and all SATA drives are back.

     

    I haven't dicovered any drawbacks yet. It works even under heavy use so far.

     

    cheers

    peter

  • ratiolegis Level 1 Level 1 (0 points)

    Wow!! It really works!! Huge thanks to cascag~

     

    Lastly without no expection I tried the method you posted that replacing IOPCIFamily.kext with a copy from Mountain Lion and after rebooting all the drives in sata storage are perfectly working as before.

    It's like a miracle to me!

     

    Until now there is no problem at all. But still I hope Apple probe this matter to the bottom and offer a ultimate fix.

     

    Anyway thank you very much once again~!

  • matoro1989 Level 1 Level 1 (0 points)

    Where is someplace I could get ahold of Mountain Lion's IOPCIFamily.kext?  I did a clean instal for Mavericks, so I have no access to old Mountain Lion content.

     

    I'm trying to get a generic dual USB 3.0 PCI device working, and it's the first time I've ever used an ExpressCard device in my 2007 Macbook Pro.  The device only came with Windows drivers, but the seller said it worked fine on Mavericks for him (98%+ customer aproval rating on eBay).  Refreshing the system info when the device is in shows pci168c,24 which has a driver installed, and ExpressCard which has no driver.  Unplugging the device and refreshing the system report shows that ExpressCard is no more, and pci168c,24 stays.  I'm going to email the vendor about the drivers anyway, but could someone point me to a IOPCIFamily.kext download that isn't modified?  All my search results end up with patched versions for Hackintoshes.

     

    Fortunately I mostly wanted this for my dualboot Win7 to use for a playing steam games off a terabyte and ReadyBoost, which doesn't work so well on my stock USB 2 ports...

  • Cyrilos Level 1 Level 1 (0 points)

    I tried to replace the IOPCIFamily.kext file in from a frensh installed Mountain lion in WMware fusion but it did no work at all ! The system would not boot, i had to replace it again with the original one to get my Macbook Pro boot again. I don't know if it is because WMware changed the IOPCIFamily.kext file or because the trick does not work on everymac ? any idea ?

  • captainpeter Level 1 Level 1 (0 points)

    Did you repair permissions before trying to reboot? This patch works and only makes any sense on the mid 2010 Macbook Pro. Earlier as well as later models with Express Card slot do not need this.

     

    I have not tried any USB 3 Express cards. It does work with Sil3132-based SATA cards.

     

    cheers

    peter

  • matoro1989 Level 1 Level 1 (0 points)

    Fortunately it works fine for windows, which is why I got it, but it would be nice to use for OSX too.  Can someone just provide a link to file or something - is it even possible for me to get Mountain Lion without reverting to my Snow Leopard disk first?

  • Cyrilos Level 1 Level 1 (0 points)

    I did repair the permission before booting, and i had to do it again when i swithed back with the original file. I am using a Macbook pro Mid 2010. I did not pluged my card in, i tried to unplug everything before booting but the mac did not boot at all, i had the "empty sign" unstead of the apple logo after te while and the wheel kept spining...

     

    If is does work for you guys, i guess the files i took to make the test was changed by WMware when i installed the WMware tools ?

  • COFSM Level 1 Level 1 (0 points)

    I've been waiting for an official Apple solution, but I gave up and tried this. It worked on my 17-inch, Mid 2010 Macbook Pro, using a sil3132 based expresscard.

     

    I now have access to my esata drives, and so far all seems to be working properly. Thanks for the help.

  • cascag Level 1 Level 1 (10 points)

    Matoro1989,

     

    the file is in http://we.tl/qCECfnFXBf

     

    until 25/11

  • ViShVa Level 2 Level 2 (265 points)

    Thanks cascag,

     

    That helped me too!

  • matoro1989 Level 1 Level 1 (0 points)

    Thank you cascag.  Fortunately the ebay vendor just sent me the driver I needed for my specific ExpressCard and it works fine now, but I'm glad you were able to help ViShVa and whoever else stumbles on this thread.

  • Cyrilos Level 1 Level 1 (0 points)

    Thanks cascag,

     

    Works beautifully ! ! (I guess my file was corrupted before)