1 2 3 Previous Next 44 Replies Latest reply: Apr 2, 2014 2:28 PM by nouveauphoto
COFSM Level 1 Level 1 (0 points)

I have a LaCie eSATA / USB 2in1 Expresscard on my Macbook Pro 17', and upon upgrading to Maverick's it no longer works. There was a message I receeived after upgrading to Mavericks that said something about this device is not suported and is disabled. This card uses the Silicon Image sil3132 driver. 

 

Have not found any solutions as of yet (no new drivers are available anywhere as far as I can tell), so I can't use some of my external HD's over eSATA.

 

Any suggestions?


MacBook Pro, OS X Mavericks (10.9)
  • 1. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    mrolt Level 1 Level 1 (0 points)

    I have the same problem.. 17" Mid 2010 MacBook Pro using a Griffin eSata Expresscard. 

     

    On previous updates I've just uninstalled and reinstalled the Silicon Image driver but that doesn't seeem to work in this case..

     

    Infuriating!

  • 2. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    MaxNekko Level 1 Level 1 (0 points)

    Ditto, here. I'm using the Seritek 2SM2-E adapter. Also, my generic JB Micron adapter isn't working either. Without a solution in a day or two, I'll have to go back to Mountain Lion.

  • 3. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    mrolt Level 1 Level 1 (0 points)

    Someone on Creative Cow has got his Lacie expresscard working by using a very old driver from Silicon Image website. He backtracked and found Sil3132_1.2.3.0_Sil_Pkg worked for him. I've installed it on my MacBook Pro and it has given me my Expresscard Icon back in my Finder bar but most the options are greyed out and drives still won't mount. Do let me know if this works for anyone else.

  • 4. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    MEENOPHOTO Level 1 Level 1 (0 points)

    I have the Sonnet Tech Tempo SATA Express Card/34 and it the driver stopped working when I upgraded to Mavericks this morning. I contacted Sonnet and they told me just to reinstall the driver. Sure enough, it now works again.

  • 5. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    lehestro Level 1 Level 1 (0 points)

    Thanks Meenophoto. I don't have a Sonnet SATA expresscard, but it still worked on my Merax eSata expresscard all the same. Huge thanks.

  • 6. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    Swisscarl Level 1 Level 1 (0 points)

    I downloaded the old Sil3132_1.2.5.0_Sil_Pkg (found the hint on Creative Cow as well) and it works, i.e. my external Drive would mount. So far I am not able to use it as my TimeMachine backup drive any more. I'll probably have to re-format the drive. Will let you know if it works.

  • 7. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    mrolt Level 1 Level 1 (0 points)

    Can't figure out why Sonnet or old Silicon Image driver is working for most but not me. I'm worried I deleted something else when I was messing around with Extensions etc. Did you guys uninstall the old driver? Or just install the driver over the older one? Did you have your card in or out? Any other info would be great. Going to reinstall Mavericks, requarantine the driver and then try again.

     

    To the guys that have it working- do you have just the Sil3132 driver in your extensions folder or do you have two - the other one called something like sil3132r5 which is the RAID 5 driver?

  • 8. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    Surrey Indian Level 1 Level 1 (0 points)

    I had the same problem. I have Lacie eSATA 2 port card in my MacPro 12 Core. When Mavericks got installed, it gave me the same message (ie SilicomImage device is not supported). I then remembered I had the same problem when I upgraded Lion to Mountain Lion. I followed a procedure that I found on the internet called "Uninstalling Sil 3132 driver". Sorry I cant remember the URL, but after following it, I got all my eSATA drives working in Mavericks. Hope it is works for others too.

     

    How to uninstall the driver in Mac OSX

    1. Disconnect all devices that connected to Lacie eSATA card. Completely remove the

    card. Reboot without the card. This clears the information about the existing card from

    the system cache

    2. Reboot

    3. Delete /System/Library/Extensions/SiliconImage3132.kext (If this file exist in the OS)

    4. Delete /System/Library/Extensions.kextcache (Does not exist, ignore for 10.8)

    5. Delete /System/Library/Caches/com.apple.kext.caches/startup/kernelcaches

    6. Reboot

    (If you would like to re-install the driver, please follow below steps.)

    7. Login in as an administrator user

    8. Re-download and install the Mac OSX driver.

  • 9. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    dtomiller Level 1 Level 1 (0 points)

    Surrey Indian wrote:

     

    I had the same problem. I have Lacie eSATA 2 port card in my MacPro 12 Core. When Mavericks got installed, it gave me the same message (ie SilicomImage device is not supported). I then remembered I had the same problem when I upgraded Lion to Mountain Lion. I followed a procedure that I found on the internet called "Uninstalling Sil 3132 driver". Sorry I cant remember the URL, but after following it, I got all my eSATA drives working in Mavericks. Hope it is works for others too.

     

    How to uninstall the driver in Mac OSX

    1. Disconnect all devices that connected to Lacie eSATA card. Completely remove the

    card. Reboot without the card. This clears the information about the existing card from

    the system cache

    2. Reboot

    3. Delete /System/Library/Extensions/SiliconImage3132.kext (If this file exist in the OS)

    4. Delete /System/Library/Extensions.kextcache (Does not exist, ignore for 10.8)

    5. Delete /System/Library/Caches/com.apple.kext.caches/startup/kernelcaches

    6. Reboot

    (If you would like to re-install the driver, please follow below steps.)

    7. Login in as an administrator user

    8. Re-download and install the Mac OSX driver.

     

    Thanks Surrey Indian! 

    This solution worked perfectly for getting my old Best Connectivity Expresscard/34mm to 2x eSATA ports (SIL3132 chipset) to connect again in Mavericks. 

  • 10. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    KaiKane505 Level 1 Level 1 (0 points)

    A bit off the thread here but I have a Sonnet Tech Tempo SATA Pro Express Card/34. It worked with 10.9 with no reinstallation of the driver. Has been working all weekend on a home server set up with no issues. Just wanted to note that here as the comment above gave me the confidence to upgrade and I wanted others to see this if they searched as I did.

  • 11. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    Cyrilos Level 1 Level 1 (0 points)

    My card dos not work either even when i installed the lastet driver again. Maybe it is because i am using a localized french version of the Maverick ? when i checked in the apple menu in harware report i can see "no" in the "driver installed"

    I tried uninstal and re-install the 2.2.9 driver à few times ...

    Any suggestions ?

  • 12. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    COFSM Level 1 Level 1 (0 points)

    Well, I've tried everything mentioned in the above posts, and still no working ExpressCard (LaCie / sil3132 based) esata adapter. Luckily I've been able to get by being that my drives also have firewire, but still not ideal. Hoping that Apple comes out with a fix for this issue soon....

  • 13. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    cascag Level 1 Level 1 (10 points)

    So, Maybe I found some solutions for my ExpressCards (JMicron 363)that was not working after installed Mavericks.

    I read many days in foruns trying to reconnect my eSata HDD and in the end I did the following:

     

    1)Install using the Multibeast software the drivers 3rd Party esata and 3rd Party sata.

    2)Reboot the system

    3)Go to your Mavericks /System/Lybrary/Extensions and delete the kext IOPCIFamily.kext

    4)From a installed copy of Mountain Lion go to the same folder /System/Lybrary/Extensions and copy the same file (IOPCIFamily.kext) to a pen drive or other place.

    5) download the Kext Wizard software and open it.

    6) Go to the tab instalation and drag the kext copied form Mountain Lion inside the white box in the window software.

    7) Install the kext.

    8) Go to the Maintenance tab and select System/Library/Extension (Repair Permitions and Rebuild Cache) and Execute.

    9) Reboot the system and conect the eSata HDD.


    You have your esata working again.

     

    (I didn´t test everything yet but at least they are mounted in Mavericks and I have my esata working.

    Hope that don´t cause other problems.)

     


  • 14. Re: Expresscard 34 eSATA driver not working in Mavericks 10.9
    captainpeter Level 1 Level 1 (0 points)

    I have just read an interesting post on the Firmtek FAQ page which may explain why some folks report success by simply reinstalling the drivers which worked for them in Mountain Lion whereas others like me have tried every possible version of the SiliconImage drivers and still can't get a drive to mount.

     

    According to Firmtek

    'Mac OS X 10.9 (13A603) Does Not Support 2010 17" MacBook Pro ExpressCards

    If you have a 2009 or a 2011 MacBook Pro with an ExpressCard slot, all FirmTek ExpressCards will work with Mac OS X Mavericks and the currently posted FirmTek drivers. However, if you have a 17" 2010 MacBook Pro model MacBookPro6,1 with 10.9 installed, no drives mount with any manufactures eSATA card in our tests. This suggests the 10.9 installer may not fully support the 2010 MBP ExpressCard hardware.

    SOLUTION: If you have a 17" 2010 MacBook Pro and require ExpressCard slot functionality, please stay with 10.8.x or earlier until this issue is corrected.'

     

    If this is true I really hope Apple or SiliconImage resolve this issue.

     

    It would be interesting to hear if anyone with a MBP 6,1 (Mid 2010) managed to get a SiI 3132 based express card working.

     

    cheers

    Peter

1 2 3 Previous Next